Route 2 Eigrp Implementingeigrp
Route 2 Eigrp Implementingeigrp
Route 2 Eigrp Implementingeigrp
3
EIGRP Capabilities and Attributes
EIGRP formerly known as Cisco-proprietary distance-vector protocol with link-state
features.
On May 2016 EIGRP Become Standard based on RFC-7868
EIGRP features include:
• Fast convergence
• Partial updates
• Multiple network layer support
• Use of multicast and unicast communication
• Variable-length subnet masking (VLSM) support
• Seamless connectivity across all data link layer protocols and topologies
• By default, it performs automatic route summarization at major network
boundaries (can be disabled) but can also be configured to summarize on
interfaces.
EIGRP Terminology
Neighbor table
Topology table
Routing table
Advertised Distance (AD)
Feasible Distance (FD)
Successor
Feasible successor (FS)
Passive Versus Active Routes
EIGRP Tables
Neighbor table
Contains EIGRP neighbor addresses and the interface through
which they can be reached.
Topology table
Contains all destinations advertised by neighboring routers.
Routing table
Contains EIGRP successor routes.
AD versus FD
Advertised Distance (AD)
Advertised distance (AD), also referred to as the Reported
Distance, is the cost between the next-hop router and the
destination.
Feasible Distance (FD)
Feasible distance (FD) is the cost between the local router and the
next-hop router plus the next-hop router’s AD to the destination
network.
Successor and Feasible Successor
Successor
A successor is a neighboring router that has a least-cost path to a destination
(the lowest FD) that is guaranteed not to be part of a routing loop.
Successor routes are offered to the routing table to be used for forwarding
packets.
Multiple successors can exist if they have the same FD.
Feasible successor (FS)
A feasible successor is a neighbor that is closer to the destination, but it is not
the least-cost path.
A feasible successor ensures a loop-free topology because it must have an AD
less than the FD of the current successor route.
Feasible successors are selected at the same time as successors but are kept
in the topology table as backups to the successor routes.
The topology table can maintain multiple feasible successors for a destination.
Passive versus Active Routes
Passive Route
A route is considered passive when the router is not performing
recomputation on that route.
Passive is the operational, stable state.
Active route
A route is active when it is undergoing recomputation.
Key EIGRP Technologies
Reliable Transport Protocol (RTP)
Responsible for guaranteed, ordered delivery of EIGRP packets to all
neighbors.
Neighbor discovery/recovery mechanism
Enables EIGRP routers to dynamically learn when their neighbors become
unreachable or inoperative by periodically sending small hello packets.
Protocol-dependent modules (PDMs)
Responsible for network layer protocol-specific requirements such as IP, IPv6,
AppleTalk, and Novell NetWare.
DUAL finite-state machine
Diffusing Update Algorithm (DUAL) is the routing algorithm that tracks all
routes advertised by all neighbors and uses distance information, known as the
composite metric, to select efficient, loop-free paths to all destinations.
Reliable Transport Protocol
EIGRP cannot use the services of UDP or TCP since IPX and
Appletalk do not use the TCP/IP protocol suite.
Reliable Transport Protocol (RTP) is the Transport layer protocol
uniquely used by EIGRP for the delivery and reception of EIGRP
packets.
RTP is similar to TCP but is a Cisco proprietary.
RTP provides reliable or unreliable service as the situation warrants.
Reliable packets (Update, Query, Reply) require explicit
acknowledgement while unreliable packets (Hello, ACK) do not.
Neighbor Discovery / Recovery
EIGRP routers actively establish relationships with their neighbors.
Adjacencies are established using small Hello packets which are sent
every 5 or 60 seconds.
If a neighbor misses 3 consecutive Hello packets then the route is
considered invalid.
Default = 15 seconds or 180 seconds.
Neighbor Discovery / Recovery
Protocol-Dependent Modules
Various routed protocols are supported through its PDMs.
Provides independence from routed protocols.
PDMs are modular, scalable and adaptable.
EIGRP can adapt to new or revised routed protocols.
PDMs protect EIGRP from painstaking revision.
Each PDM is responsible for all functions related to its specific routed
protocol.
Protocol-Dependent Modules
Topology
/24
/24
Initial Config – R1
interface GigabitEthernet0/0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0/0
description R1-->R2
bandwidth 64
ip address 10.1.102.1 255.255.255.248
clock rate 64000
!
interface Serial0/0/1
description R1-->R3
bandwidth 1544
ip address 10.1.103.1 255.255.255.248
17
Initial Config – R2
interface GigabitEthernet0/0
ip address 172.16.2.1 255.255.255.0
!
interface Serial0/0/0
description R2-->R1
bandwidth 64
ip address 10.1.102.2 255.255.255.248
!
interface Serial0/0/1
description R2-->R3
bandwidth 1024
ip address 10.1.203.2 255.255.255.248
clock rate 64000
18
Initial Config – R3
interface GigabitEthernet0/0
ip address 172.16.3.1 255.255.255.0
!
interface Serial0/0/0
description R3-->R1
bandwidth 1544
ip address 10.1.103.3 255.255.255.248
clock rate 64000
!
interface Serial0/0/1
description R3-->R2
bandwidth 1024
ip address 10.1.203.3 255.255.255.248
19
Configuring Basic EIGRP
R1(config)# router eigrp 1
R1(config-router)# network 172.16.0.0
R1(config-router)# network 10.0.0.0
R1(config-router)#
Hello packets are used to discover & form adjacencies with neighbors.
Multicasted to:
IPv4: 224.0.0.10
IPv6: FF02::A
Hello packets are always sent unreliably.
Therefore Hello packets do not require acknowledgment. 23
EIGRP Neighbors Amount of time since this neighbor
was added to the neighbor table.
R2# show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.203.3 Se0/0/1 10 00:03:15 28 168 0 19
0 10.1.102.1 Se0/0/0 12 00:13:22 23 2340 0 46
R2#
The local
Neighbor’s interface Seconds remaining
IPv4 receiving before declaring
address EIGRP Hello neighbor down.
packets. Reset to hold time
when Hello is
received.
24
EIGRP Interfaces
R2# show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/0/0 1 0/0 0/0 23 10/390 478 0
Se0/0/1 1 0/0 0/0 28 0/23 139 0
Gi0/0 0 0/0 0/0 0 0/0 0 0
R2#
25
EIGRP Interfaces
R2# show ip eigrp interfaces detail
EIGRP-IPv4 Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/0/0 1 0/0 0/0 23 10/390 478 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 20/0
Hello's sent/expedited: 2186/4
Un/reliable mcasts: 0/0 Un/reliable ucasts: 23/23
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 1
Topology-ids on interface - 0
Authentication mode is not set
26
IPv4 Routing Protocols
R2# show ip protocols
*** IP Routing is NSF aware ***
27
Routing Protocol is "eigrp 1"
IPv4 Routing Protocols EIGRP Process ID
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP-IPv4 Protocol for AS(1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 2.2.2.2 EIGRP Router ID
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170 Hopcount is not a metric
Maximum path: 4
Maximum hopcount 100 Variance – For unequal cost load
Maximum metric variance 1 balancing
Automatic Summarization: disabled Starting with 15.0 no auto-
Maximum path: 4
Routing for Networks: summary is the default
10.0.0.0
172.16.0.0
network statements
Routing Information Sources:
Gateway Distance Last Update
10.1.102.1 90 00:23:27 neighbors
10.1.203.3 90 00:23:28
Distance: internal 90 external 170
28
R2#
Routing Protocol is "eigrp 1"
IPv4 Routing Protocols
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
EIGRP Composite
Default networks accepted from incoming updates
EIGRP-IPv4 Protocol for AS(1)
Metric Formula
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID:
METRIC 2.2.2.2
= ( [K1 x Bandwidth + (K2 x Bandwidth) / (256-load) + K3 x Delay] x [K5 / (Reliability + K4] ) x 256
Topology : 0 (base)
METRIC = ( Timer:
Active [1 x Bandwidth
3 min + (0 x Bandwidth) / (256-load) + 1 x Delay] x [0 / (Reliability + 0] ) x 256
Distance: internal 90 external 170
METRIC = (1 path:
Maximum x Bandwidth
4 + 1 x Delay) x 256
Maximum hopcount 100
Maximum metric variance 1
NOTE:
Automatic Summarization: disabled
Maximum path:• 4The multiplication by 256 is a legacy feature to maintain
backwards compatibility with IGRP.
Routing for Networks:
10.0.0.0
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
10.1.102.1 90 00:23:27
10.1.203.3 90 00:23:28
Distance: internal 90 external 170
29
R2#
EIGRP Wide Metrics
The EIGRP composite cost metric does not scale correctly for high-bandwidth
interfaces or Ethernet channels, resulting in incorrect or inconsistent routing
behavior.
The lowest delay that can be configured for an interface is 10 microseconds.
As a result, high-speed interfaces, such as 10 Gigabit Ethernet (GE) interfaces,
or high-speed interfaces channeled together (GE ether channel) will appear to
EIGRP as a single GE interface.
To resolve this issue, the EIGRP Wide Metrics feature supports 64-bit metric
calculations
The 64-bit metric calculations work only in EIGRP named mode configurations.
30
Configuring Passive Interfaces X
31
EIGRP Interfaces after Passive
R2# show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se0/0/0 1 0/0 0/0 23 10/390 478 0
Se0/0/1 1 0/0 0/0 28 0/23 139 0
R2#
R2# show ip protocols
<selected output>
Passive Interface(s):
GigabitEthernet0/0
35
Initial
Route
Discovery
Observing EIGRP
R3# debug eigrp packet
R3# conf t
R3(config)# router eigrp 1
R3(config-router)# network 10.1.203.0 0.0.0.7
*Feb 1 22:06:45.678: EIGRP: Sending HELLO on Se0/0/1 - paklen 20
*Feb 1 22:06:45.698: EIGRP: Received HELLO on Se0/0/1 - paklen 30 nbr 10.1.203.2
*Feb 1 22:06:45.698: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.203.2 (Serial0/0/1) is up:
new adjacency
*Feb 1 22:06:45.698: *Feb 1 22:06:45.698: EIGRP: Enqueueing UPDATE on Se0/0/1 - paklen 0 nbr
10.1.203.2 tid 0 iidbQ un/rely 0/1 peerQ un/rely 0/0
*Feb 1 22:06:45.706: EIGRP: Sending UPDATE on Se0/0/1 - paklen 0 nbr 10.1.203.2 tid 0
*Feb 1 22:06:45.706: AS 1, Flags 0x1:(INIT), Seq 63/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ
un/rely 0/1
*Feb 1 22:06:47.770: EIGRP: Received UPDATE on Se0/0/1 - paklen 222 nbr 10.1.203.2
*Feb 1 22:06:47.770: AS 1, Flags 0x0:(NULL), Seq 64/63 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ
un/rely 0/1
*Feb 1 22:06:47.770: EIGRP: Enqueueing ACK on Se0/0/1 - paklen 0 nbr 10.1.203.2 tid 0
*Feb 1 22:06:47.770: Ack seq 64 iidbQ un/rely 0/0 peerQ un/rely 1/1
*Feb 1 22:06:47.774: EIGRP: Sending ACK on Se0/0/1 - paklen 0 nbr 10.1.203.2 tid 0
*Feb 1 22:06:47.774: AS 1, Flags 0x0:(NULL), Seq 0/64 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ
un/rely 1/1
*Feb 1 22:06:47.778: EIGRP: Received ACK on Se0/0/1 - paklen 0 nbr 10.1.203.2
*Feb 1 22:06:47.778: AS 1, Flags 0x0:(NULL), Seq 0/64 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ
un/rely 0/1 37
Observing EIGRP
R3# 38
IPv4 Routing Table – EIGRP Routes
R2 R3
I will choose R3 to
get to 10.0.0.0/8
RA R1 which means I
have a cost of 120.
Is R2 a valid back
RB up?
No, because it comes back through me
R1 (loop). It only knows this route
because of me.
41
I can get to 10.0.0.0/8 I can get to
10.0.0.0/8 with a 10.0.0.0/8 with a
metric of 300. metric of 100.
RX
RB
R2 R3
I will choose R3 to
get to 10.0.0.0/8
RA R1 which means I
have a cost of 120.
Is R2 a valid back
up?
Yes, because it has its own
path to 10.0.0.0/8. (no loop)
42
I can only use R2 as a
backup if it reports a
cost less than my total
cost through R3.
Successor
45
The Feasible Successor
R2#The reported
show distance
ip eigrp - EIGRP neighbor’s FD to the same destination network.
topology
The metric that a router reports to a neighbor about its own cost to that network.
Feasibility Condition:
P 172.16.3.0/24, The FC is met when
1 successors, FD isa neighbor’s
3014400 reported distance (RD)
to a network is less than the(3014400/28160),
local router’s FD to the R1: Feasible
same destination network.
via 10.1.203.3 Serial0/0/1 Successor
via 10.1.102.1 (41026560/2172416), Serial0/0/0
Outbound interface to
reach this network
R2’s feasible R1’s (feasible
Next hop
distance if R1 successor)
address of
becomes the Reported
the Feasible
Successor. Distance to R2
Successor
This would the Feasible
metric in R2’s Successor
routing table via
R1. 46
Why is R1 a Feasible Successor?
R2# show ip eigrp topology
Feasibility Condition:
R1’s Reported Distance is less than
R2’s Feasible Distance via R3, so
R1 is a Feasible Successor.
A Feasible Successor is a neighbor who has a Feasible
loop-free backup path to the same network as the
successor by satisfying the feasibility condition.
Successor
Can become new successor with no packets lost.
47
Why is R1 a Feasible Successor?
R2# show ip eigrp topology
Feasible
Successor Successor
R2(config)# interface serial 0/0/1
R2(config-if)# no shutdown
R2(config-if)# end
*Feb 2 00:02:59.422: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
*Feb 2 00:03:03.346: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.203.3
(Serial0/0/1) is up: new adjacency
50
IPv4 Routing Table – EIGRP Routes
R1#
52
The Successor
R1# show ip eigrp topology
Outbound interface to
reach this network
Next hop Feasible distance
address of
the successor Successor’s (R3’s)
Reported Distance
NO feasible successor
To be a feasible successor, R2 must satisfy the
Feasibility Condition.
53
Why is R2 is NOT a Feasible Successor?
R1# show ip eigrp topology all-links
X
55
Observing EIGRP
Reply Query
R1# debug eigrp fsm
EIGRP Finite State Machine debugging is on
Query
R1# conf t Reply
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# interface serial 0/0/1
R1(config-if)# shutdown
X
*Feb 2 00:38:10.082: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.103.3 (Serial0/0/1) is down:
interface down
*Feb 2 00:38:10.086: DUAL: Destination 172.16.3.0/24 for tid 0
*Feb 2 00:38:10.086: EIGRP-IPv4(1): Find FS for dest 172.16.3.0/24. FD is 2172416, RD is 2172416
on tid 0
*Feb 2 00:38:10.086: DUAL: AS(1) Dest 172.16.3.0/24 entering active state for tid 0.
*Feb 2 00:38:10.086: EIGRP-IPv4(1): Set reply-status table. Count is 1.
*Feb 2 00:38:10.554: DUAL: AS(1) Removing dest 172.16.3.0/24, nexthop 10.1.103.3
*Feb 2 00:38:10.554: EIGRP-IPv4(1): rcvreply: 172.16.3.0/24 via 10.1.102.2 metric
41026560/3014400 for tid
*Feb 2 00:38:10.554: EIGRP-IPv4(1): Find FS for dest 172.16.3.0/24. FD is 72057594037927935, RD
is 72057594037927935 on tid 0found
*Feb 2 00:38:10.554: DUAL: AS(1) Removing dest 172.16.3.0/24, nexthop 10.1.103.3
*Feb 2 00:38:10.554: DUAL: AS(1) RT installed 172.16.3.0/24 via 10.1.102.2
*Feb 2 00:38:10.554: DUAL: AS(1) Send update about 172.16.3.0/24. Reason: metric chg on tid 0
56
New Route I’m the new successor
R1#
R1# show ip route eigrp
<>
59
EIGRP Queries
Router
Queries B
Replies
Router
A
X
X
n When there is no feasible successor DUAL puts the route into Active
(topology table) and sends queries to neighbors looking for another path.
60
EIGRP
Queries and
Stuck in
Active
Router loses a route and does not have an FS in its topology table, it looks for an alternative
path to the destination. - known as going active on a route
If a neighbor does not have an alternative route, it queries each of its own neighbors for an
alternative path.
The queries then propagate through the network, thus creating an expanding tree of queries.
61
Router
Stuck in Active (SIA) C Router D
Router
Queries
Replies
SIA Router
B
X
A
X
X
n When EIGRP returns a stuck in active (SIA) message, it means that it has
not received a reply to a query.
n Summarization can help prevent SIA. 62
EIGRP 101 EIGRP 102
Stuck-in-Active
Optimizing EIGRP
Reduce queries
EIGRP Summarization
EIGRP Stub Routing
Reduce the affect of SIAs
EIGRP Active Enhancement Process
64
Reduce Queries by using Summary Routes
S0/0/0
70
Verify EIGRP
Manual 192.168.0.0/22
Summarization 192.168.0.0/22
Classful Networks
Class A: 0.0.0.0 to 127.255.255.255 Default Mask: 255.0.0.0 or /8
Class B: 128.0.0.0 to 191.255.255.255 Default Mask: 255.255.0.0 or /16
Class C: 192.0.0.0 to 223.255.255.255 Default Mask: 255.255.255.0 or /24
Propagating a
Default Route
R2(config)# ip route 0.0.0.0 0.0.0.0 serial 0/1/0
R2(config)# router eigrp 1
R2(config-router)# redistribute static
74
Queries
Optimizing EIGRP
Reduce queries
EIGRP Summarization
EIGRP Stub Routing
Reduce the affect of SIAs
EIGRP Active Enhancement Process
75
EIGRP Interfaces The summary route of 192.168.16.0/23 is
installed in HQ’s route table rather than the
directly connected 192.168.16.0/24 because
HQ# show ip route eigrp 192.168.16.0/24 is included in the summary.
D 192.168.0.0/24 [90/409600] via 172.16.1.2, 00:12:07, Ethernet0/0
D 192.168.16.0/23 [90/307200] via 172.16.1.2, 00:12:07, Ethernet0/0
D EX 192.168.18.0/24 [170/307200] via 172.16.1.2, 00:12:07, Ethernet0/0
76
Stub Routers
EIGRP
Updates
X
Stub
Queries X
Stub Routers learn routes from nonstub routers but…
Stub routers do not forward EIGRP learned routes to other neighbors
Nonstub routers do not send query messages to stub routers…. Stub
will send what it wants (if anything).
77
Stub Router Options
Options – One or more, except for receive-only EIGRP Updates
connected – Sends connected routes covered by a network statement.
Most widely practical stub option (default)
summary - Sends summary routes, manually created or automatic. (default)
static - Sends static routes redistributed with the redistribute static
command.
redistributed – Sends all redistributed routes configured with the
redistribute command.
receive-only - Restricts the stub router from sharing any of its routes with
any other EIGRP router.
This option does not permit any other option to be used.
This option is rarely used.
Router has a single interface or using NAT (later) 78
Stub default: connected and summary
BR1A(config)# router eigrp 1
BR1A(config-router)# eigrp stub
*Oct 18 11:51:16.232: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.1.1
(Ethernet0/0) is down:
79
Stub default: connected and summary
BR1A(config)# router eigrp 1
BR1A(config-router)# eigrp stub
HQ# show ip eigrp neighbors detail
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.2.2.2 Se0/0/0 14 00:21:37 20 120 0 15
Version 16.0/2.0, Retrans: 0, Retries: 0, Prefixes: 3
Topology-ids from peer - 0
Stub Peer Advertising (CONNECTED SUMMARY ) Routes
Suppressing queries
Max Nbrs: 0, Current Nbrs: 0
HQ#
80
Stub default: connected
BR1A(config)# router eigrp 1
BR1A(config-router)# eigrp stub connected
82
Queries
Optimizing EIGRP
Reduce queries
EIGRP Summarization
EIGRP Stub Routing
Reduce the affect of SIAs
EIGRP Active Enhancement Process
83
Active Process
Enhancement
feature
Cisco IOS Software Release 12.1(5) and later, with the Active
Process Enhancement feature.
This feature enables an EIGRP router to monitor the progression of
the search for a successor route and ensure that the neighbor is still
reachable.
84
BEFORE Active Process Enhancement feature.
X 10.1.1.0/24 gone; no FS
A Never heard from B
Query
X 3 min timer
So after 3 min reset adjacency along with all networks
B 10.1.1.0/24 gone; no FS
No entry so sends Query
10.1.1.0/24 gone; no FS
SIA Reply: I’m ok but waiting on C B
No entry so sends Query
After 1.5 min SIA Query
(3 attempts until I terminal Bad link; reply never makes it
adjacency with C)
86
EIGRP Load Balancing
87
Variance command
Router(config)# router eigrp 1
Router(config-router)# variance multiplier
Cisco IOS allows up to 32 equal-cost paths (IOS dependent), 4 by default.
EIGRP does unequal cost load balancing, forwarding packets relative to the metric.
The variance command:
Instructs the router to include routes with a metric less than or equal to n times
the minimum metric route for that destination
n is the number specified by the variance command (1 -128).
Default = 1
The maximum-paths number EIGRP is used to sent the number of load-balancing
paths (up to 32 paths).
1 disables load balancing
Note: If a path isn't a feasible successor, then it isn't used in load balancing.
Note: Load balancing is only performed on traffic that passes through the router, not
88
traffic generated by the router.
Variance command
RD
FS
Succ
FS
Successor: R3 with a FD of 20
Feasible Successors: R2 and R5
R2’s RD of 10 < R3’s FD of 20
R5’s RD of 10 < R3’s FD of 20
91
Layer 2 and Layer 3 MPLS VPN Solutions
192.168.1.0/30 192.168.2.0/30
network network
192.168.1.100/27
network