Network (8 9)
Network (8 9)
Network (8 9)
Title: Dynamic Routing Using Cisco Packet Tracer: RIP, OSPF, and BGP
INTRODUCTION: Dynamic routing protocols such as RIP (Routing Information Protocol), OSPF (Open
Shortest Path First), and BGP (Border Gateway Protocol) are integral components of modern computer
networking, facilitating the automatic exchange of routing information among routers to determine optimal
paths to network destinations. RIP, with its distance-vector algorithm, is suited for smaller networks, while
OSPF, employing the link-state algorithm, offers scalability and faster convergence, making it ideal for
larger and more complex networks. On the other hand, BGP, a path-vector protocol, enables routing
between different autonomous systems on the Internet, providing flexibility and scalability to maintain
global connectivity. Together, these dynamic routing protocols underpin the efficiency and reliability of
network communication, catering to diverse network architectures and requirements.
RIP : 8.a To understand the concept and operation of Routing Information Protocol (RIP)
Requirements
• Windows pc – 2 Nos
• CISCO Packet Tracer Software (Student Version)
• 8 port switch – 2 No
• Router – 2 Nos
• Cat-5 LAN cable
Procedure
• Open the CISCO Packet tracer software
• Drag and drop 5 pcs using End Device Icons on the left corner
• Select 8 port switch from switch icon list in the left bottom corner
• Select Routers and Give the IP address for serial ports of router and apply clock rate as per the table.
• Make the connections using Straight through Ethernet cables
• Ping between PCs and observe the transfer of data packets in real and simulation mode.
Theory
RIP (Routing Information Protocol) is one of the oldest distance vector routing protocols. It is usually used on
small networks because it is very simple to configure and maintain, but lacks some advanced features of
routing protocols like OSPF or EIGRP. Two versions of the protocol exists: version 1 and version 2. Both
versions use hop count as a metric and have the administrative distance of 120. RIP version 2 is capable of
advertising subnet masks and uses multicast to send routing updates, while version 1 doesn’t advertise subnet
masks and uses broadcast for updates. Version 2 is backwards compatible with version 1. RIPv2 sends the
entire routing table every 30 seconds, which can consume a lot of bandwidth. RIPv2 uses multicast address of
224.0.0.9 to send routing updates, supports authentication and triggered updates (updates that are sent when a
change in the network occurs).
IP configuration on PCs
And now:
Router 1 Router 2
As you can see,to configure rip on each router,we enable enable RIP using router rip command then
advertise the networks directly connected to the router interfaces using network command.That’s all for RIP
configuration.
4. We’ll now verify RIP configuration.To verify that RIP is indeed advertising routes, we can use the show ip
route command on R1.
OSPF: 8.b Configuration of Open shortest Path First (OSPF) Algorithm : To construct multiple router
networks and understand the operation of OSPF Protocol.
Requirements
• Windows pc – 3 Nos
• CISCO Packet Tracer Software ( Student Version)
• 8 port switch – 3 No
• Router – 3 Nos
• Cat-5 LAN cable
Procedure
• Open the CISCO Packet tracer software.
• Drag and drop 5 pcs using End Device Icons on the left corner.
• Select 8 port switch from switch icon list in the left bottom corner.
• Select Routers and Give the IP address for serial ports of router and apply clock rate.
• Add HWIC -2T Peripheral to all routers, type CLI’s for all routers.
• Make the connections using Straight through Ethernet cables.
• Ping between PCs and observe the transfer of data packets in real and simulation mode.
Theory
The OSPF routing protocol has largely replaced the older Routing Information Protocol (RIP) in corporate
networks. Using OSPF, a router that learns of a change to a routing table (when it is reconfigured by network
staff, for example) or detects a change in the network immediately multicasts the information to all other
OSPF hosts in the network so they will all have the same routing table information. Unlike RIP, which requires
routers to send the entire routing table to neighbors every 30 seconds, OSPF sends only the part that has
changed and only when a change has taken place. When routes change -- sometimes due to equipment failure
-- the time it takes OSPF routers to find a new path between endpoints with no loops (which is called "open")
and that minimizes the length of the path is called the convergence time.
Now comes the main part now we have to configure the OSPF implementation:
Step 1: Configure the Router0 and create router OSPF1 and then add network id with wildcard mask.
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.255.255.255 area 0
Router(config-router)#network 10.0.0.0 0.0.0.255 area 0
Step2: Configure the Router1 and create router OSPF 1 and then add network id with wildcard mask.
Router(config)#router ospf 1
Router(config-router)#network 10.0.0.0 0.0.0.255 area 0
Router(config-router)#network 20.0.0.0 0.0.0.255 area 0
Router(config-router)#network 192.168.2.0 0.255.255.255 area 0
Step 3: Configure the Router2 and create router OSPF 1 and then add network id with wildcard mask.
Router(config)#router ospf 1
Router(config-router)#network 192.168.3.0 0.255.255.255 area 0
Router(config-router)#network 255.0.0.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#do write
Building configuration...[OK]
R1(config)#
R2(config-router)#exit
R2(config)#do write
Building configuration...[OK]
R2(config)#
R3(config)#do write
Building configuration...[OK
PC>ping 10.0.0.2
R2#show ip protocols
R3#show ip protocols