1_IPv4OSPF
1_IPv4OSPF
1_IPv4OSPF
Authored By:
Khawar Butt
CCIE # 12353
Hepta CCIE#12353 OSPF Fundamentals
CCDE # 20110020
Netmetric Solutions
(c) KBITS Live | https://kbits.live
Http://www.Netmetric-Solutions.com 1 of 67
Lab 1 – Initializing EIGRP
Interface Configuration
R9
R10
Hostname R9
!
Interface E 0/0
Ip address 192.1.89.9 255.255.255.0
No shut
!
Interface E 0/1
ip address 192.1.90.9 255.255.255.0
no shut
!
Interface Loopback1
ip address 9.9.9.9 255.0.0.0
!
router eigrp 111
network 192.1.90.0
network 9.0.0.0
R10
Hostname R10
!
Interface E 0/0
ip address 192.1.90.10 255.255.255.0
no shut
!
Interface Loopback1
ip address 10.10.10.10 255.0.0.0
!
router eigrp 111
network 192.1.90.0
network 10.0.0.0
Interface Configuration
R7
R8
Hostname R7
!
Interface E 0/0
ip address 192.1.67.7 255.255.255.0
no shut
!
Interface E 0/1
ip address 192.1.78.7 255.255.255.0
no shut
!
Interface Loopback1
ip address 7.7.7.7 255.0.0.0
!
router ospf 1
router-id 0.0.0.7
network 192.1.78.0 0.0.0.255 area 0
network 7.0.0.0 0.255.255.255 area 0
R8
Hostname R8
!
Interface E 0/0
ip address 192.1.78.8 255.255.255.0
no shut
!
Interface E 0/1
Ip address 192.1.89.8 255.255.255.0
No shut
!
Interface Loopback1
ip address 8.8.8.8 255.0.0.0
!
router ospf 1
router-id 0.0.0.8
network 192.1.78.0 0.0.0.255 area 0
network 192.1.89.0 0.0.0.255 area 0
network 8.0.0.0 0.255.255.255 area 0
R9
router ospf 1
router-id 0.0.0.9
network 192.1.89.0 0.0.0.255 area 0
R9
router ospf 1
redistribute eigrp 111
!
Router eigrp 111
Redistribute ospf 1 metric 10 10 10 10 10
Interface Configuration
R1
R2
R3
R5
R6
R1
Hostname R1
!
Interface E 0/0
ip address 192.1.100.1 255.255.255.0
no shut
!
Interface Loopback1
ip address 1.1.1.1 255.0.0.0
!
router ospf 1
Hostname R2
!
Interface E 0/0
ip address 192.1.100.2 255.255.255.0
no shut
!
Interface S 1/0
Ip address 192.1.101.2 255.255.255.0
No shut
!
Interface Loopback1
ip address 2.2.2.2 255.0.0.0
!
router ospf 1
router-id 0.0.0.2
network 192.1.100.0 0.0.0.255 area 10
network 192.1.101.0 0.0.0.255 area 10
network 2.0.0.0 0.255.255.255 area 10
R3
Hostname R3
!
Interface E 0/0
ip address 192.1.100.3 255.255.255.0
no shut
!
Interface E 0/1
Ip address 192.1.103.3 255.255.255.0
No shut
!
Interface Loopback1
ip address 3.3.3.3 255.0.0.0
!
router ospf 1
router-id 0.0.0.3
network 192.1.100.0 0.0.0.255 area 10
network 192.1.103.0 0.0.0.255 area 10
network 3.0.0.0 0.255.255.255 area 10
Hostname R4
!
Interface E 0/0
ip address 192.1.103.4 255.255.255.0
no shut
!
Interface S 1/0
Ip address 192.1.102.4 255.255.255.0
Encapsulation ppp
No shut
!
Interface Loopback1
ip address 4.4.4.4 255.0.0.0
!
router ospf 1
router-id 0.0.0.4
network 192.1.102.0 0.0.0.255 area 10
network 192.1.103.0 0.0.0.255 area 10
network 4.0.0.0 0.255.255.255 area 10
R5
Hostname R5
!
Interface S 1/0
ip address 192.1.101.5 255.255.255.0
no shut
!
Interface S 1/1
Ip address 192.1.102.5 255.255.255.0
Encapsulation ppp
No shut
!
Interface Loopback1
ip address 5.5.5.5 255.0.0.0
!
router ospf 1
router-id 0.0.0.5
network 192.1.101.0 0.0.0.255 area 10
network 192.1.102.0 0.0.0.255 area 10
network 5.0.0.0 0.255.255.255 area 10
Hostname R6
!
Interface E 0/0
ip address 192.1.103.6 255.255.255.0
no shut
!
Interface E 0/1
Ip address 192.1.67.7 255.255.255.0
No shut
!
Interface Loopback1
ip address 6.6.6.6 255.0.0.0
!
router ospf 1
router-id 0.0.0.6
network 192.1.103.0 0.0.0.255 area 10
network 192.1.67.0 0.0.0.255 area 10
network 6.0.0.0 0.255.255.255 area 10
R7
router ospf 1
network 192.1.67.0 0.0.0.255 area 10
R11
router ospf 1
router-id 0.0.0.11
network 192.1.100.0 0.0.0.255 area 10
network 11.0.0.0 0.255.255.255 area 10
o Configure all routers in OSPF such that they do not send updates
on links that do not have other routers, basically Loopbacks.
R1 R2
router ospf 1
passive-interface Loopback0
R1
Router ospf 1
auto-cost reference-bandwidth 10000
R2
Router ospf 1
auto-cost reference-bandwidth 10000
!
Interface S 1/0
Bandwidth 2048
Router ospf 1
auto-cost reference-bandwidth 10000
R4
Router ospf 1
auto-cost reference-bandwidth 10000
!
Interface S 1/0
Bandwidth 1024
R5
Router ospf 1
auto-cost reference-bandwidth 10000
!
Interface S 1/0
Bandwidth 2048
!
Interface S 1/1
Bandwidth 1024
R6
Router ospf 1
auto-cost reference-bandwidth 10000
R7
Router ospf 1
auto-cost reference-bandwidth 10000
R8
Router ospf 1
auto-cost reference-bandwidth 10000
R9
Router ospf 1
auto-cost reference-bandwidth 10000
R1
Interface E 0/0
Ip ospf priority 255
R2
Interface E 0/0
Ip ospf priority 250
Interface E 0/1
Ip ospf priority 255
R4
Interface E 0/0
Ip ospf priority 250
o Configure the link between R6 and R7 such that it brings the OSPF
relationship without the DR/BDR election. This optimizes the
convergence times in OSPF on a Ethernet segment that is
connected in a Point-to-Point manner.
R6
Interface E 0/1
Ip ospf network point-to-point
R7
Interface E 0/0
Ip ospf network Point-t-point
R1
Interface Loopback0
Ip ospf network point-to-point
R2
Interface Loopback0
Ip ospf network point-to-point
R3
Interface Loopback0
Ip ospf network point-to-point
Interface Loopback0
Ip ospf network point-to-point
R5
Interface Loopback0
Ip ospf network point-to-point
R6
Interface Loopback0
Ip ospf network point-to-point
R7
Interface Loopback0
Ip ospf network point-to-point
R8
Interface Loopback0
Ip ospf network point-to-point
R9
Interface Loopback0
Ip ospf network point-to-point
R7 R8
Interface E 0/0
Ip ospf network non-broadcast
!
router ospf 1
neighbor 192.1.89.8
Authored By:
Khawar Butt
CCIE # 12353
Hepta CCIE#12353
CCDE # 20110020 OSPF Multi-Area & Multi-Domain
Functionalities
R1
R2
R5
R6
R8
R11
Task 1
Configure OSPF in Area 0 between R1, R2 & R3. Besides the physical
links, enable the Loopback 0 interfaces of all 3 routers in Area 0.
Loopbacks should be advertised with the Interface Mask. Hard Code the
Router-id based on the following:
R1 – 0.0.0.1
R2 – 0.0.0.2
R3 – 0.0.0.3
R1 R2
Router OSPF 1
Task 2
Configure OSPF in Area 10 between R2, R4, R10 & R11. Besides the
physical links, enable the Loopback 1 interface on R2 and all the
loopbacks of the other 3 routers in Area 10. Loopbacks should be
advertised with the Interface Mask. Hard Code the Router-id based on
the following:
R4 – 0.0.0.4
R10 – 0.0.0.10
R11 – 0.0.0.11
R2 R4
R5 R5
Router OSPF 1
Router-id 0.0.0.6
Network 6.0.0.0 0.255.255.255 area 20
Network 192.1.56.0 0.0.0.255 area 20
!
Interface Loopback0
Ip ospf network point-to-point
R1 R7
Task 5
Configure EIGRP is AS 222 between R6 & R9. Enable all loopbacks on R9
in EIGRP 222. Enable Loopback 1 on R6 in EIGRP 222.
R6 R9
Task 6
Configure Mutual Redistribution between the appropriate routers to
allow end-to-end connectivity between all routing domains. Use Seed
metric of your choice.
R1 R6
Task 1
Configure Route Summarization on the appropriate ABR to summarize
all the R11 Loopbacks.
R2
Router ospf 1
Area 10 range 111.111.100.0 255.255.252.0
Task 1
Configure Route Summarization on the appropriate ASBR to summarize
all the routes from the 107.0.0.0/8 major network towards OSPF. Use
the longest mask for Route Summarization.
R1
Router ospf 1
Summary-address 107.7.72.0 255.255.252.0
Task 1
Configure LSA Filtering such that network 4.0.0.0/8 is not allowed to
leave Area 10.
R2
Task 1
Configure text authentication on all routers in 10. Use a key-string
cisco.
R2
interface E 0/1
ip ospf authentication
ip ospf authentication-key cisco
R4
interface E 0/0
ip ospf authentication
ip ospf authentication-key cisco
!
interface E 0/1
ip ospf authentication
ip ospf authentication-key cisco
R10
interface E 0/0
ip ospf authentication
ip ospf authentication-key cisco
Task 1
Configure the most secure authentication on all routers in Area's 0. Use
a key of 1 and a key-string ccie123.
R1
interface E 0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ccie123
!
interface E 0/1
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ccie123
R2
interface E 0/0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 ccie123
R3
Task 1
Configure Area 10 such that it does not receive any External Routes. It
should maintain connectivity to the External Routes. (Stub Area)
R2 R4
Task 1
This step is a continuation of Task 1. Area 10 should also block Inter-
Area routes maintaining reachability to them. (Totally Stubby Area)
R2
Router ospf 1
Area 10 stub no-summary
Note: The ABR will block the Inter-Area Routes from getting
propagating into Area 10. Instead R2 will inject a default route
instead. This is a Totally Stubby Area. Verify it on R4, R10 & R11 by
checking the Routing table.
Task 1
Configure Area 20 such that it does not receive any external routes from
the backbone. The External routes from EIGRP 222 should continue to
be received in Area 20 and propagated into the Backbone. (NSSA Area)
R3
Router ospf 1
Area 20 nssa
R5
Router ospf 1
Area 20 nssa
R6
Router ospf 1
Area 20 nssa
Note: The ABR will block the External routes from the Backbone
(EIGRP). Area 20 will continue to receive the external routes from
EIGRP 222 as N routes. These routes will continue to be propagated
towards the backbone. The ABR will convert the N routes into E
Task 1
This step is a continuation of Task 3. Configure Area 20 such that the
previous requirement is maintained but Area 20 should also have
reachability to the external routes from the backbone (EIGRP Routes).
(NSSA-Stub Area)
R3
Router ospf 1
Area 20 stub default-information-originate
Note: This builds on the NSSA area by regaining reachability to the
Backbone external routes. This is done by having the ABR injecting
the default route into Area 20.
Task 1
Configure Area 20 such that the Inter-Area routes are also blocked in
addition to the external routes from the backbone. (NSSA-Totally
Stubby Area)
R3
Router ospf 1
Area 20 nssa no-summary
Authored By:
Khawar Butt
CCIE # 12353
Hepta CCIE#12353
CCDE # 20110020 Redistribution with OSPF
R1
R2
R4
R5
R6
R7
R1 R7
Router OSPF 1
Router-id 0.0.0.8
Network 8.0.0.0 0.255.255.255 area 0
Network 192.1.18.0 0.0.0.255 area 0
!
Interface Loopback0
Ip ospf network point-to-point
Task 2
Configure EIGRP in AS 111 between R1, R2 & R3. Besides the physical
links, enable the Loopback 0 interfaces of R2 & R3 in EIGRP. R1
Loopback1 should also be enabled in EIGRP.
R1 R2
R3 R4
Router OSPF 1
Router-id 0.0.0.5
Network 5.0.0.0 0.255.255.255 area 20
Network 192.1.45.0 0.0.0.255 area 20
!
Interface Loopback0
Ip ospf network point-to-point
Task 4
Configure Static Routing between R5 & R6. Configure R5 with a static
route towards the 6.0.0.0/8 network. R6 should be configured with a
default route towards R5.
R5
Task 1
Configure mutual route redistribution between OSPF Area 0 & EIGRP
111 on R1. OSPF should inject the EIGRP routes using metric-type E2
(static metric). Use a metric of 10 10 10 10 10 to redistribute OSPF
routes into EIGRP. This metric should also be used in case of other
redistributions into EIGRP.
R1
Router OSPF 1
Redistribute eigrp 111 subnets
!
Router eigrp 111
Default-metric 10 10 10 10 10
Redistribute ospf 1
R3
Router OSPF 1
Redistribute eigrp 111 metric-type 1 subnets
!
Router eigrp 111
Redistribute ospf 1 metric 10 10 10 10 10
Task 1
Redistribute Static routes into OSPF on R5.
R5
Router OSPF 1
Redistribute static
Task 1
Configure the following loopbacks on R4.
R4
Interface loopback101
Ip address 44.1.1.1 255.255.255.0
!
Interface loopback102
Ip address 44.1.2.1 255.255.255.0
R1
Authored By:
Khawar Butt
CCIE # 12353
Hepta CCIE#12353
CCDE # 20110020 OSPF Advanced Configurations
R1
R2
R5
R6
Task 1
Configure OSPF in Area 0 between R1, R7 & R8. Besides the physical
links, enable the Loopback 0 interfaces of all 3 routers in Area 0.
Loopbacks should be advertised with the Interface Mask. Hard Code the
Router-id based on the following:
R1 – 0.0.0.1
R7 – 0.0.0.7
R8 – 0.0.0.8
Router OSPF 1
Router-id 0.0.0.8
Network 8.0.0.0 0.255.255.255 area 0
Network 192.1.18.0 0.0.0.255 area 0
!
Interface Loopback0
Ip ospf network point-to-point
Task 2
Configure OSPF in Area 10 between R1, R2 & R3. Besides the physical
links, enable the Loopback 0 interfaces of R2 & R3 in Area 10. R1
Loopback1 should also be enabled in area 10. Loopbacks should be
advertised with the Interface Mask. Hard Code the Router-id based on
the following:
R2 – 0.0.0.2
R3 – 0.0.0.3
R1 R2
Router OSPF 1
Router-id 0.0.0.3
Network 3.0.0.0 0.255.255.255 area 10
Network 192.1.13.0 0.0.0.255 area 10
Task 3
Configure OSPF in Area 20 between R3, R4 & R5. Besides the physical
links, enable the Loopback 0 interfaces of R4 & R5 in Area 20. R3
Loopback1 should also be enabled in area 20. Loopbacks should be
advertised with the Interface Mask. Hard Code the Router-id based on
the following:
R4 – 0.0.0.4
R5 – 0.0.0.5
R3 R4
Router OSPF 1
Router-id 0.0.0.5
Network 5.0.0.0 0.255.255.255 area 20
Network 192.1.45.0 0.0.0.255 area 20
!
Interface Loopback0
Ip ospf network point-to-point
R1
router ospf 1
area 10 virtual-link 0.0.0.3
R3
router ospf 1
area 10 virtual-link 0.0.0.1
Task 1
Configure OSPF in Area 30 between R5 & R6. Besides the physical links,
enable the Loopback 0 interfaces of R6 in Area 30. R5 Loopback1 should
also be enabled in area 30. Loopbacks should be advertised with the
Interface Mask. Hard Code the Router-id based on the following:
R6 – 0.0.0.6
R5 R6
R3
router ospf 1
area 20 virtual-link 0.0.0.5
R5
router ospf 1
area 20 virtual-link 0.0.0.3
Task 1
Configure BFD between all routers in area 0. Configure the BFD Interface
interval to be 300 for sending and receiving. A neighbor should be
deemed dead is the router misses 3 hellos.
R1 R7
Interface E 0/0
bfd interval 300 min_rx 300 multiplier 3
!
Router ospf 1
bfd all-interfaces
R1
Task 1
Configure OSPF in Area 0 between R1, R2, R3 & R4. Besides the physical
links, enable the Loopback 0 interfaces of all 4 routers in Area 0.
Loopbacks should be advertised with the Interface Mask. Hard Code the
Router-id based on the following:
R1 – 0.0.0.1
R2 – 0.0.0.2
R3 – 0.0.0.3
R4 – 0.0.0.4
R1 R2
R1 R2
R3 R4
Task 3
Verify the routing table and CEF on R1 for Network 4.0.0.0/8. It should
have a single path via R2 (Lower cost)
R1
R1
Router ospf 1
fast-reroute per-prefix enable area 0 prefix-priority low
R2
Router ospf 1
fast-reroute per-prefix enable area 0 prefix-priority low
R3
Router ospf 1
fast-reroute per-prefix enable area 0 prefix-priority low
R4
Router ospf 1
fast-reroute per-prefix enable area 0 prefix-priority low
Task 5
Verify the routing table and CEF on R1 for Network 4.0.0.0/8. It should
have a repair path via R3 (higher cost) installed and ready in case the
lower cost route goes down.
R1