Ospfv2 Ospf
Ospfv2 Ospf
Ospfv2 Ospf
The OSPFv2-OSPF Live-Live feature delivers multicast streams over non overlapping paths to various
applications. The multicast traffic is split into multiple streams at the beginning of a protected network. All
streams flow over non overlapping paths so that when a link failure occurs on one path, multicast traffic is
still delivered through other paths. All streams are merged back at the end of the protected network. This
module describes how to configure the OSPFv2-OSPF Live-Live feature.
demand to reduce multicast traffic loss to the range of milliseconds or to zero packet loss. The zero packet
loss solution for multicast in case of single link failure is also known as live-live.
In a live-live network, multicast streams (typically two flows) form their own reverse path forwarding
(RPF)/shortest path trees (SPT) over diversified physical links, so that failure on one link does not affect
multicast traffic on other link. The existing multi topology technology in Cisco IOS software supports the
multiple multicast topologies.
The OSPFv2-OSPF Live-Live feature enables the protocol independent multicast (PIM) to handle multiple
multicast topologies. When a multicast topology is created and enabled on OSPF, IP prefixes on each topology
are injected into topology-based Routing Information Base (RIB). PIM then decides which RIB to use for
RPF lookup.
PIM RPF topology is a collection of routes used by PIM to perform the RPF operation when building shared
or source trees. In a multi topology environment, multiple RPF topologies can be created in the same network.
A particular source may be reachable in only one of the topologies or in several of them through different
paths.
To select the RPF topology for a particular multicast distribution tree, consider the following:
1 Configure a policy that maps a group range to a topology. When RPF information needs to be resolved
for the RP or the sources for a group within the range, the RPF lookup takes place in the specified topology.
This can be used for PIM Sparse Mode (PIM-SM)/source-specific multicast (SSM)/Bidirectional(Bidir)
PIM.
2 Configure a policy that maps a source prefix range to a topology. This can be used for PIM-SM and
PIM-SSM.
3 Use the topology identified by the Join Attribute encoding in the received PIM packets.
The PIM Join Attribute extends PIM signaling to identify a topology that should be used when constructing
a particular multicast distribution tree. For more details on the PIM Join Attribute, see PIM Multi-Topology
ID (MT-ID) Join-Attribute IEEE draft.
1. enable
2. configure terminal
3. ip multicast-routing
4. ip multicast rpf multitopology
5. global-address-family ipv4 multicast
6. topology {topology-A | topology-B}
7. exit
8. interface type number
9. ip address address mask
10. ip pim sparse-dense-mode
11. ip ospf process-id area area-id
12. topology ipv4 multicast topology-name
13. exit
14. router ospf process-id
15. network ip-adddress mask area area-id
16. address-family ipv4 multicast
17. topology topology-name tid topology-id
18. end
19. configure terminal
20. ip multicast topology multicast topology-name tid topology-id
21. ip multicast rpf select topology multicast topology-name access-list number
22. ip access-list extended access-list-number
23. permit ip any ip-adddress
24. end
25. show ip multicast topology multicast topology-name
26. debug ip multicast topology
DETAILED STEPS
Example:
Device# configure terminal
Example:
Device(config)# ip multicast-routing
Step 4 ip multicast rpf multitopology Enables Multi Topology Routing (MTR) support for IP
multicast routing.
Example:
Device(config)# ip multicast rpf multitopology
Step 5 global-address-family ipv4 multicast Enters global address family configuration mode and
configures multi topology routing.
Example:
Device(config)# global-address-family ipv4
multicast
Step 6 topology {topology-A | topology-B} Configures an OSPF process to route IP traffic under the
specified topology instance.
Example:
Device(config-af)# topology live-A
Step 7 exit Exits address family configuration mode and returns to global
configuration mode.
Example:
Device(config-af)# exit
Step 8 interface type number Configures an interface type and enters interface configuration
mode.
Example:
Device(config)# interface Gigabitethernet 1/0
Step 9 ip address address mask Sets a primary or secondary IP address for an interface.
Example:
Device(config-if)# ip address 192.108.1.27
255.255.255.0
Step 10 ip pim sparse-dense-mode Enables PIM on an interface and treats the interface in either
sparse mode or dense mode of operation, depending on which
Example: mode the multicast group operates in.
Device(config-if)# ip pim sparse-dense-mode
Example:
Device(config-if)# ip ospf 10 area 0
Step 12 topology ipv4 multicast topology-name Configures a multi topology instance on an interface.
Example:
Device(config-if)# topology ipv4 multicast
live-A
Step 14 router ospf process-id Enables OSPF routing and enters router configuration mode.
Example:
Device(config)# router ospf 102
Step 15 network ip-adddress mask area area-id Defines an interface on which OSPF runs and defines the area
ID for that interface.
Example:
Device(config-router)# network 192.168.129.16
0.0.0.3 area 20
Step 16 address-family ipv4 multicast Enters router address family configuration mode and
configures OSPF to exchange IPv4 multicast prefixes.
Example:
Device(config-router)# address-family ipv4
multicast
Step 17 topology topology-name tid topology-id Configures an OSPF process to route IP traffic under the
specified topology instance.
Example: • Repeat this step to configure the OSPF process to route
Device(config-router-af)# topology live-A tid
100 IP traffic under another topology instance (topology
live-B tid 200).
Step 18 end Exits router address family configuration mode and returns
to privileged EXEC mode.
Example:
Device(config-router-af)# end
Example:
Device# configure terminal
Step 20 ip multicast topology multicast topology-name tid Configures topology selection for the multicast streams.
topology-id
Step 21 ip multicast rpf select topology multicast Associates a multicast topology with a multicast group with
topology-name access-list number a specific route entry.
• Repeat this step to associate the topology with another
Example: multicast group (ip multicast rpf select topology
Device(config)# ip multicast rpf select
topology multicast topology live-A 111 multicast live-B 122).
Step 22 ip access-list extended access-list-number Defines an IP access list to enable filtering for packets with
IP helper-address destinations and enters extended named
Example: access list configuration mode.
Device(config)# ip access-list extended 111
Step 23 permit ip any ip-adddress Sets condition to allow a packet to pass a named IP access
list.
Example: • Repeat Steps 22 and 23 to define another IP access list
Device(config-ext-nacl)# permit ip any
203.0.113.1 and to set conditions to allow a packet to pass another
named IP access list.
Step 24 end Exits extended named access list configuration mode and
enters privileged EXEC mode.
Example:
Device(config-ext-nacl)# end
Step 25 show ip multicast topology multicast topology-name Displays topology information for multicast streams.
Example:
Device# show ip multicast topology multicast
live-A
Step 26 debug ip multicast topology Enables debugging output for multicast stream topology.
Example:
Device# debug ip multicast topology
!
global-address-family ipv4 multicast
topology live-A
topology live-B
!
ip access-list extended 111
permit ip any 203.0.113.254
Technical Assistance
Description Link
The Cisco Support website provides extensive online http://www.cisco.com/support
resources, including documentation and tools for
troubleshooting and resolving technical issues with
Cisco products and technologies.
To receive security and technical information about
your products, you can subscribe to various services,
such as the Product Alert Tool (accessed from Field
Notices), the Cisco Technical Services Newsletter,
and Really Simple Syndication (RSS) Feeds.
Access to most tools on the Cisco Support website
requires a Cisco.com user ID and password.