ICTNWK503 Install and Maintain Valid Authentication Processes
ICTNWK503 Install and Maintain Valid Authentication Processes
ICTNWK503 Install and Maintain Valid Authentication Processes
authentication processes
ICTNWK503 Install and maintain valid authentication
processes
Determine authentication
requirements
Configure authentication
software or tools
Apply authentication
methods
Monitor authentication
system
User Authentication Overview
User Authentication
• Fundamental security building block
• basis of access control & user accountability
• The process of verifying an identity claimed by or for a system entity
• Two steps:
• identification: specify identifier
• verification: bind entity (person) and identifier
• Distinct from message authentication (when communicating parties are
concerned with the integrity of the exchanges messages)
A model for electronic user authentication
Mod/
Personal safety None None Low
High
Verification is analogous to
user login via a smart card
and a PIN
• eavesdropping
• replay
• trojan horse
Authentication Security Issues
• Basic idea
• User has a secret password
• System checks password to authenticate user
• Issues
• How is password stored?
• How does system check password?
• How easy is it to guess a password?
• Difficult to keep password file secret, so best if it is hard to guess password even if you
have the password file
Basic password scheme
kiwifruit
exrygbzyf
kgnosfix
hash function ggjoklbsz
…
…
Basic password scheme
Compare
Salt
Input
Constant, Key
Ciphertext
A 64-bit block of 0 25x DES
Plaintext
“I am Alice”
Failure scenario??
Authentication
in a network,
Bob can not “see”
Alice, so Trudy simply
“I am Alice” declares
herself to be Alice
Authentication: another try
Protocol ap2.0: Alice says “I am Alice” in an IP packet
containing her source IP address
Alice’s
IP address
“I am Alice”
Failure scenario??
Authentication: another try
Protocol ap2.0: Alice says “I am Alice” in an IP packet
containing her source IP address
Alice’s Alice’s
“I’m Alice”
IP addr password
Alice’s Alice’s
“I’m Alice”
IP addr password
playback attack: Trudy
Alice’s records Alice’s packet
OK
IP addr and later
plays it back to Bob
Alice’s Alice’s
“I’m Alice”
IP addr password
Authentication: yet another try
Protocol ap3.1: Alice says “I am Alice” and sends her
encrypted secret password to “prove” it.
Alice’s encrypted
“I’m Alice”
IP addr password
Alice’s encryppted
IP addr password
“I’m Alice” record
and
Alice’s
OK playback
IP addr
still works!
Alice’s encrypted
“I’m Alice”
IP addr password
Authentication: yet another try
Goal: avoid playback attack
Nonce: number (R) used only once –in-a-lifetime
ap4.0: to prove Alice “live”, Bob sends Alice nonce, R. Alice
must return R, encrypted with shared secret key
“I am Alice”
R
KA-B(R) Alice is live, and
only Alice knows
key to encrypt
nonce, so it must
Failures, drawbacks? be Alice!
Authentication: ap5.0
ap4.0 doesn’t protect against server database reading
• can we authenticate using public key techniques?
ap5.0: use nonce, public key cryptography
“I am Alice”
Bob computes
R + -
- KA(KA (R)) = R
K A (R) and knows only Alice
could have the private
key, that encrypted R
such that
+ -
K (K (R)) = R
A A
Outline
• User authentication
• Password authentication, salt
• Challenge-response authentication protocols
• Biometrics
• Token-based authentication
• Authentication in distributed systems (multi service providers/domains)
• Single sign-on, Microsoft Passport
• Trusted Intermediaries
Biometrics
• Use a person’s physical characteristics
• fingerprint, voice, face, keyboard timing, …
• Advantages
• Cannot be disclosed, lost, forgotten
• Disadvantages
• Cost, installation, maintenance
• Reliability of comparison algorithms
• False positive: Allow access to unauthorized person
• False negative: Disallow access to authorized person
• Privacy?
• If forged, how do you revoke?
Biometrics
• Common uses
• Specialized situations, physical security
• Combine
• Multiple biometrics
• Biometric and PIN
• Biometric and token
Physical Biometrics
• Fingerprint • Smell
• Iris • Thermal Face
• Hand Geometry • Hand Vein
• Finger Geometry • Nail Bed
• Face Geometry • DNA
• Ear Shape
• Palm Print
• Retina
Behavioral Biometrics
• Signature
• Voice
• Keystroke
• Gait
Token-based Authentication
Smart Card
• With embedded CPU and memory
• Carries conversation w/ a small card reader
• Various forms
• PIN protected memory card
• Enter PIN to get the password
• Cryptographic challenge/response cards
• Computer create a random challenge
• Enter PIN to encrypt/decrypt the challenge w/ the card
eToken
function
• Some complications
• Initial data (PIN) shared with server
• Need to set this up securely
• Shared database for many sites
• Clock skew
Fingerprints
• Global features
• Features that can be seen with the naked eye
• Basic ridge patterns
• Local features
• Minutia points
• Tiny unique characteristics of fingerprint ridges used for positive
identification
Basic Ridge Patterns
• Loop
• 65% of all
fingerprints
• Arch
• Plain and tented
arch
• Whorl
• 30% of all
fingerprints
• One complete
circle
Local Features
• Ridge ending
• Ridge bifurcation
• Ridge divergence
• Dot or island – ridge so short it appears to be a dot
• Enclosure – ridge separates and then reunites around an area of
ridge-less skin
• Short ridge – bigger than a dot
Minutia Characteristics
• Orientation
• The direction the minutia is facing
• Spatial frequency
• How far apart the ridges are around the point
• Curvature
• Rate of change of orientation
• Position
• X,Y location relative to some fixed points
Algorithms
• Image-based
• Pattern-based
• Minutia-based
Fingerprint Scanners
LAN
Rules Database
user name,
Authenticati
password, Application
other auth on
Server
• Advantages
– User signs on once
– No need for authentication at multiple sites, applications
– Can set central authorization policy for the enterprise
Microsoft Passport
• Launched 1999
• Claim > 200 million accounts in 2002
• Over 3.5 billion authentications each month
• Log in to many websites using one account
• Used by MS services Hotmail, MSN Messenger or MSN subscriptions; also Radio
Shack, etc.
• Hotmail or MSN users automatically have Microsoft Passport accounts set up
Passport log-in
Trusted Intermediaries
Symmetric key problem: Public key problem:
• How do two entities establish • When Alice obtains Bob’s
shared secret key over network? public key (from web site, e-
Solution: mail, diskette), how does she
know it is Bob’s public key,
• trusted key distribution center
not Trudy’s?
(KDC) acting as intermediary
between entities Solution:
• trusted certification
authority (CA)
Key Distribution Center (KDC)
• Alice, Bob need shared symmetric key.
• KDC: server shares different secret key with each registered
user (many users)
• Alice, Bob know own symmetric keys, KA-KDC KB-KDC , for
communicating with KDC.
KDC
KA-KDC KP-KDC
KX-KDC
KP-KDC KB-KDC
KY-KDC
KZ-KDC
KA-KDC KB-KDC
Key Distribution Center (KDC)
Q: How does KDC allow Bob, Alice to determine shared
symmetric secret key to communicate with each other?
Bob’s digital
+
public +
signature KB
key KB (encrypt)
CA
certificate for
K-
Bob’s private
identifying key CA Bob’s public key,
information signed by CA
Certification Authorities
• When Alice wants Bob’s public key:
• gets Bob’s certificate (Bob or elsewhere).
• apply CA’s public key to Bob’s certificate, get Bob’s public key
• CA is heart of the X.509 standard used extensively in
• SSL (Secure Socket Layer), S/MIME (Secure/Multiple Purpose Internet Mail
Extension), and IP Sec, etc.
+ digital Bob’s
KB signature public
+
(decrypt) KB key
CA
public +
K CA
key
Single KDC/CA
• Problems
• Single administration trusted by all principals
• Single point of failure
• Scalability
• Solutions: break into multiple domains
• Each domain has a trusted administration
Multiple KDC/CA Domains
Secret keys:
• KDCs share pairwise key
• topology of KDC: tree with shortcuts
Public keys:
• cross-certification of CAs
• example: Alice with CAA, Boris with CAB
• Alice gets CAB’s certificate (public key p1), signed by CAA
• Alice gets Boris’ certificate (its public key p2), signed by CAB (p1)
Key Distribution Center (KDC)
Q: How does KDC allow Bob, Alice to determine shared
symmetric secret key to communicate with each other?
KDC
generates
KA-KDC(A,B) R1
109
110
Authentication (Online Video, 50 minutes)
111
112
Kerberos (Online Video, 22 minutes)
113
114
Application Example
Next Generation
Two Factor Authentication
21st Century Remote Access
• Laptop
Hardware Tokens
• End user must remember to carry the token!
• Deployment - Remote users must be sent a hardware device
• Token may require resynchronisation
• Support – Pin Management & Failed token must be managed
• Short Term Contractors - Don’t always return the token
• B2B – One to many companies requires many identical tokens
The Next Generation
123
The SecurEnvoy Approach
Passcode
Passcode
Each Code can only be used once
573921
347865
198462
Day Code
Each day (or set number of days) a new code is sent if used
If the current day code hasn’t been used, it’s still secret and
will
not require updating
Each day code can be reused for the current and following
day Tmp Code
A pre-agreed static code that automatically switches back to
One Time or Day Code after a set number of days
Cost Vs Risk
Expensive / Hard Tokens /
Smartcards
Cost / Use
SecurEnvoy SecurEnvoy
SecurEnvoy
1 Day Code One Time Code
7 Day Code
30 Day
Password
Fixed
Cheap Password
Easy
High Risk Risk Low Risk
Standard Authentication Solutions
SecurEnvoy Solution
Re-enter user information
SecurAccess Authentication
Andyk
Passcode
Something You Know
P0stcode
573921
www.SecurEnvoy.com
Implementing an EIGRP-Based
Solution
Implementing and Verifying EIGRP Authentication
Router Authentication
• EIGRP AS number
• Authentication mode
• One or more keys
• Key lifetimes (optional)
Steps to Configure EIGRP MD5 Authentication
• If you wish, you can define when the key will be accepted or sent.
Enable Authentication of EIGRP Packets
R1(config)#
interface Serial0/0/1
ip authentication key-chain eigrp 110 routerR1chain
R2(config)#
interface Serial0/0/1
ip authentication key-chain eigrp 110 routerR2chain
• Enable authentication of EIGRP packets using the key or keys in the key chains
routerR1chain and routerR2chain on routers R1 and R2, respectively.
Router R1 Configuration for MD5
Authentication
R1#
<output omitted>
key chain routerR1chain
key 1
key-string firstkey
accept-lifetime 04:00:00 Jan 1 2009 infinite
send-lifetime 04:00:00 Jan 1 2009 04:00:00 Jan 31 2009
key 2
key-string secondkey
accept-lifetime 04:00:00 Jan 25 2009 infinite
send-lifetime 04:00:00 Jan 25 2009 infinite
<output omitted>
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0/1
bandwidth 256
ip address 192.168.1.101 255.255.255.224
ip authentication mode eigrp 110 md5
ip authentication key-chain eigrp 110 routerR1chain
!
router eigrp 110
network 172.16.1.0 0.0.0.255
network 192.168.1.0
auto-summary
Verifying MD5 Authentication for EIGRP
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 110
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.102 Se0/0/1 12 00:03:10 17 2280 0 14
R1#show ip route
<output omitted>
Gateway of last resort is not set
D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:02:22, Serial0/0/1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:31:31, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.96/27 is directly connected, Serial0/0/1
D • Verify that the IP routing
192.168.1.0/24 table is populated
is a summary, 00:31:31, Null0
Verifying MD5 Authentication for EIGRP
(Cont.)
R1#show key chain
Key-chain routerR1chain:
key 1 -- text “firstkey"
accept lifetime (04:00:00 Jan 1 2009) - (always valid) [valid now]
send lifetime (04:00:00 Jan 1 2009) - (04:00:00 Jan 31 2009)
key 2 -- text “secondkey"
accept lifetime (04:00:00 Jan 25 2009) - (always valid) [valid now]
send lifetime (04:00:00 Jan 25 2009) - (always valid) [valid now]
•
R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 110
• The EIGRP neighbor relationship is down.
Summary
• There are two types of router authentication: simple password and MD5
authentication.
• When EIGRP authentication is configured, the router generates and checks
every EIGRP packet and authenticates the source of each routing update
packet that it receives. EIGRP supports MD5 authentication.
• To configure MD5 authentication, use the ip authentication mode eigrp and
ip authentication key-chain interface commands. The key chain must also be
configured to define the keys.
• Use show ip eigrp neighbors, show ip route, and debug eigrp packets to
verify MD5 authentication.
Questions