Voip Over PPP Low Bandwidth

Download as pdf or txt
Download as pdf or txt
You are on page 1of 7

o − VoIP with PPP Over Low Bandwidth Leased Line with IP Pre

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence

Table of Contents
VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence.......................................................1
Introduction..............................................................................................................................................1
Using IP Precedence................................................................................................................................1
Before You Begin....................................................................................................................................2
Configurations.........................................................................................................................................2
Debug and Show Commands to Use for Troubleshooting......................................................................5
Related Information.................................................................................................................................5

i
VoIP with PPP Over Low Bandwidth Leased Line
with IP Precedence

Introduction
Using IP Precedence
Before You Begin
Configurations
Debug and Show Commands to Use for Troubleshooting
Related Information

Introduction
The configs below are for two Cisco 2611s to communicate via VoIP with Point−to−Point Protocol (PPP)
over a low bandwidth leased line and with IP Precedence. Click on the links in the configurations below to
access conceptual information about VoIP commands.

It is important to note that in the topology below the two routers are connected back−to−back over a leased
line. In most topologies, however, the voice enabled routers can exist anywhere. Usually, the voice routers are
connected via LAN connectivity to other routers that are connected to the WAN. This is important to note
because if your voice routers are not connected with PPP over a leased line, all WAN connectivity
configuration commands will be configured on those routers that are connected to the WAN, and not on the
voice routers, as they are in the configurations listed below.

While we use Cisco 2611s in this configuration example, these configurations can be used for Cisco 3640 and
5300 series routers also.

Note: The four port Cisco 5300 series voice ports do not support a data connection to a WAN. You will need
to use your Cisco 5300s as intermediate LAN routers, with other routers acting as direct connections to the
WAN.

Using IP Precedence
When using Multilink PPP, the ip precedence command causes data packet fragmenting. This is to minimize
voice packet delay. Setting the precedence bit in an IP header gives priority to the voice packets over data
frames or data packets.

Multilink PPP with interleave provides:

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence
1. Packet fragmentation
2. Interleaving of real time frames within fragmented data frames through the PPP interleave
3. A guaranteed maximum delay that reduces the chances of voice packet delay

If you try to run VoIP with PPP over a low bandwidth leased line, you run the risk of encountering massive
latency and jitter due to large data packets that seize the leased line, "freezing out" all other traffic until these
large packets are sent across. This is where the concept of packet fragmentation comes into play. Real−time
frames can then be interleaved among the fragmented data frames.

The ip precedence command causes a router to set the precedence bit in an IP header, which works in
conjunction with Weighted Fair Queuing (WFQ), so voice frames have priority over data fragments and data
frames. When packets arrive in a router's output queue, the voice packets will be placed on the wire before
data frames.

Note: In the configs below, when you configure the ip rtp header−compression iphc−format command, the
router by default will add the ip tcp header−compression iphc−format command to your config.

Before You Begin


Before you can configure a Cisco router to use VoIP, it is best if you understand the concepts of Quality of
Service (QOS) features in Cisco IOS software. To learn more about QOS features, please see Queuing, Traffic
Shaping, and Filtering and QoS Signaling from the Cisco IOS Quality of Service page on CCO.

Configurations
Cisco 2611 San Jose
sanjose2611A#sh run
Building configuration...

Current configuration:
!
! Last configuration change at 18:04:31 UTC Thu Apr 29 1999
! NVRAM config last updated at 18:04:02 UTC Thu Apr 29 1999
!
version 11.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password−encryption
!
hostname sanjose2611A
!
enable secret cisco
!
multilink virtual−template 1
!
dial−peer voice 1 pots <−−More on Dial Peers
destination−pattern 14085558001
port 1/0/0
!
dial−peer voice 2 voip
destination−pattern 19195552...

ip precedence 5

session target ipv4:172.16.120.1


!

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence
dial−peer voice 3 pots
destination−pattern 9
port 1/1/0
!
dial−peer voice 4 pots
destination−pattern 14085558002
port 1/0/1
!
num−exp 2... 19195552...
!
voice−port 1/0/0
!
voice−port 1/0/1
!
voice−port 1/1/0
!
voice−port 1/1/1
!
!
!
interface Ethernet0/0
ip address 172.16.110.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation ppp
bandwidth 64
no fair−queue
clockrate 64000
ppp multilink
!
interface Ethernet0/1
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
interface Virtual−Template1
ip unnumbered Ethernet0/0
ip rtp header−compression iphc−format
ip tcp header−compression iphc−format
fair−queue
ppp multilink
ppp multilink fragment−delay 20
ppp multilink interleave
!
ip classless
ip route 172.16.120.0 255.255.255.0 172.16.120.1
!
logging buffered 50000 debugging
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence
raleigh2611A#sh run
Building configuration...

Current configuration:
!
! Last configuration change at 18:03:52 UTC Thu Apr 29 1999
! NVRAM config last updated at 18:03:58 UTC Thu Apr 29 1999
!
version 11.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password−encryption
!
hostname raleigh2611A
!
enable secret cisco
!
multilink virtual−template 1
!
dial−peer voice 1 pots
destination−pattern 19195552001 <−−More on Dial Peers
port 1/0/0
!
dial−peer voice 2 voip
destination−pattern 14085558...

ip precedence 5

session target ipv4:172.16.110.1


!
dial−peer voice 3 pots
destination−pattern 9
port 1/1/0
!
dial−peer voice 4 pots
destination−pattern 19195552002
port 1/0/1
!
num−exp 8... 14085558...
!
voice−port 1/0/0
!
voice−port 1/0/1
!
voice−port 1/1/0
!
voice−port 1/1/1
!
!
!
interface Ethernet0/0
ip address 172.16.120.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation ppp
bandwidth 64
no fair−queue
ppp multilink
!
interface Ethernet0/1
no ip address
shutdown
!

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence
interface Virtual−Template1
ip unnumbered Ethernet0/0
ip rtp header−compression iphc−format
ip tcp header−compression iphc−format
fair−queue
ppp multilink
ppp multilink fragment−delay 20
ppp multilink interleave
!
ip classless
ip route 172.16.110.0 255.255.255.0 172.16.110.1
!
logging buffered 50000 debugging
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

Debug and Show Commands to Use for Troubleshooting


• debug voip ccapi inout
• debug vpm all Warning: This debug will generate large amouts of output.
• show call active voice
• show call history voice
• show voice port
• show interface serial
• show interface virtual access
• show queue serial
• show queue virtual access
• show ip rtp header compression

Before attempting any of the above debug commands, please see Important Information on Debug
Commands.

Related Information
• Voice, Telephony and Messaging Technologies
• Voice, Telephony and Messaging Devices
• Voice, Telephony and Messaging Software
• Voice, Telephony and Messaging TAC eLearning Solutions

All contents are Copyright © 1992−−2002 Cisco Systems Inc. All rights reserved. Important Notices and Privacy Statement.

Updated: Oct 24, 2002 Document ID: 14085

Cisco − VoIP with PPP Over Low Bandwidth Leased Line with IP Precedence

You might also like