HCIE-R&S Lab Mock Exam 2 With Solutions
HCIE-R&S Lab Mock Exam 2 With Solutions
HCIE-R&S Lab Mock Exam 2 With Solutions
1.1.1.1 VLAN
Create VLANs 4, 5, 27, 42, 58 and 255 on switches SW1, SW2, SW3 and SW4.
SW1-SW4:
vlan batch 4 to 5 27 42 58 255
interface Ethernet0/0/4
port link-type access
port default vlan 42
interface Ethernet0/0/5
port link-type access
port default vlan 5
interface Ethernet0/0/6
port link-type access
port default vlan 255
interface GigabitEthernet0/0/1
port link-type access
port default vlan 255
interface GigabitEthernet0/0/2
port link-type access
port default vlan 255
SW2:
interface Ethernet0/0/4
port link-type access
port default vlan 4
interface Ethernet0/0/5
port link-type access
port default vlan 58
interface Ethernet0/0/20
port link-type access
port default vlan 42
interface Ethernet0/0/22
port link-type access
port default vlan 255
SW3:
interface Ethernet0/0/20
port link-type access
port default vlan 255
interface GigabitEthernet0/0/1
port link-type access
port default vlan 27
SW4:
interface GigabitEthernet0/0/1
port link-type access
port default vlan 5
interface GigabitEthernet0/0/2
SW2:
interface Eth-Trunk12
mode lacp-static
interface Ethernet0/0/11
eth-trunk 12
interface Ethernet0/0/12
eth-trunk 12
SW2:
interface Ethernet0/0/11
undo negotiation auto
speed 10
interface Ethernet0/0/12
undo negotiation auto
speed 10
Ensure the maximum bandwidth on the link between SW1 and SW2 is 20Mbps.
SW1:
interface Eth-Trunk12
max active-linknumber 2
SW2
interface Eth-Trunk12
max active-linknumber 2
1.1.1.3 Mirroring
Incoming and outgoing traffic on G0/0/2 of SW4 should be copied to G0/0/1 for
analysis.
SW4:
observe-port 1 interface GigabitEthernet0/0/1
interface GigabitEthernet0/0/2
port-mirroring to observe-port 1 both
1.1.1.5 Trunk
All links between switches SW1, SW2, SW3 and SW4 should be configured as
trunk interfaces. Only VLANs 2 to 4094 should be allowed to pass across these
links.
SW1:
interface Eth-Trunk12
port link-type trunk
SW2:
interface Eth-Trunk12
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
interface Ethernet0/0/13
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
SW3:
interface Ethernet0/0/11
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
interface Ethernet0/0/13
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
SW4:
interface Ethernet0/0/11
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
interface Ethernet0/0/13
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 4094
1.1.1.6 MSTP
Switches SW1, SW2, SW3 and SW4 run MSTP as follows.
VLANs 4, 5 and 27 are in instance 10, VLANs 42, 58 and 255 are in instance 20.
Set the MST region name to huawei and revision-level to 10.
SW1-SW4:
stp mode mstp
stp region-configuration
region-name huawei
revision-level 10
instance 10 vlan 4 5 27
instance 20 vlan 42 58 255
active region-configuration
Spanning tree path cost calculations, should use Huawei proprietary values.
SW1-SW4:
stp pathcost-standard legacy
Configure SW1 to be root for instance 10 and SW2 to be root for instance 20.
SW1:
stp instance 10 priority 0
SW2:
stp instance 20 priority 0
1.1.1.7 Hub-and-Spoke
R1, R5 and R3 use Frame Relay (FR) encapsulation and are connected in hub and
spoke mode with R3 as the hub. Connect R3 to R1 and R5 using P2P sub-
interfaces.
Traffic between R1 and R5 must pass through R3.
Only the DLCIs and IP addresses shown in the topology may be used. Your
configuration should take into account that IS-IS will need to run over these links.
Automatic FR mapping between layer 2 and layer 3 must be disabled.
Spoke devices may not send any multicast traffic to the hub.
R1:
interface Serial1/0/1
link-protocol fr
undo fr inarp
R3:
interface Serial1/0/1
link-protocol fr
undo fr inarp
R5:
interface Serial1/0/1
link-protocol fr
undo fr inarp
interface Serial1/0/1.1 P2P
ip address 10.1.135.5 255.255.255.0
fr dlci 503
1.1.1.8 Point-to-Point
The link between R3 and R4 should be configured as FR point to point.
Static layer 3 to layer 2 mapping may not be used on R3 or R4.
Automatic FR mapping between layer 2 and layer 3 must be disabled. On R3 and
R4.
Only the interfaces, DLCIs and IP addresses shown in the topology can be used.
R3:
interface Serial1/0/0
link-protocol fr
undo fr inarp
interface Serial1/0/0.1 p2p
fr dlci 304
ip address 10.1.34.3 255.255.255.0
R4:
interface Serial1/0/0
link-protocol fr
undo fr inarp
interface Serial1/0/0.1 p2p
fr dlci 403
ip address 10.1.34.4 255.255.255.0
1.1.1.9 FR
Perform the necessary configuration on R6 to ensure the following output can be
displayed:
[R6]display fr map-info
Map Statistics for interface Serial1/0/1 (DTE)
DLCI = 116, IP 157.68.1.254, Serial1/0/1
create time = 2013/09/03 16:54:33, status = ACTIVE
encapsulation = ietf, vlink = 1, broadcast
R6:
interface Serial1/0/1
link-protocol fr
undo fr inarp
fr map ip 157.68.1.254 116 broadcast
ip address 157.68.1.6 255.255.255.0
1.1.1.10 PPP
R4 and R5 are connected through a pair of serial links, which should be combined
using a suitable mechanism to make best use of the bandwidth.
Only the specified IP network may be used for this link.
R4:
interface Mp-group0/0/0
ip address 10.1.45.4 255.255.255.0
interface Serial2/0/0
link-protocol ppp
ppp mp Mp-group 0/0/0
interface Serial2/0/1
link-protocol ppp
ppp mp Mp-group 0/0/0
R5:
interface Mp-group0/0/0
ip address 10.1.45.5 255.255.255.0
interface Serial2/0/0
link-protocol ppp
ppp mp Mp-group 0/0/0
interface Serial2/0/1
link-protocol ppp
ppp mp Mp-group 0/0/0
R2:
router id 10.1.2.2
interface GigabitEthernet0/0/0
ip address 10.1.22.2 255.255.255.0
interface LoopBack0
ip address 10.1.2.2 255.255.255.255
R3:
router id 10.1.3.3
interface Serial2/0/0
ip address 10.1.13.3 255.255.255.0
interface GigabitEthernet0/0/0
ip address 157.68.3.3 255.255.255.0
interface LoopBack0
ip address 10.1.3.3 255.255.255.255
R4:
router id 10.1.4.4
interface GigabitEthernet0/0/0
ip address 157.68.2.4 255.255.255.0
interface GigabitEthernet0/0/1
ip address 10.1.44.4 255.255.255.0
interface LoopBack0
ip address 10.1.4.4 255.255.255.255
R5:
router id 10.1.5.5
interface GigabitEthernet0/0/0
ip address 10.1.50.5 255.255.255.0
interface GigabitEthernet0/0/1
ip address 10.1.52.5 255.255.255.0
interface LoopBack0
ip address 10.1.5.5 255.255.255.255
R6:
router id 10.1.6.6
interface GigabitEthernet0/0/0
ip address 157.68.3.6 255.255.255.0
interface LoopBack0
ip address 10.1.6.6 255.255.255.255
SW1:
interface Vlanif5
ip address 10.1.21.11 255.255.255.0
interface Vlanif27
ip address 10.1.22.11 255.255.255.0
SW2:
interface Vlanif5
ip address 10.1.21.22 255.255.255.0
interface Vlanif58
ip address 10.1.52.22 255.255.255.0
interface Vlanif255
ip address 157.68.3.22 255.255.255.0
SW4:
interface Vlanif4
ip address 10.1.44.44 255.255.255.0
2.1.1.2 RIP
R4 should run RIPv2 on G0/0/0, summarization should be disabled.
Enable MD5 authentication for RIP update packets, use a password of HW, the
IETF defined format for authentication packets should be used.
R4:
rip 1
undo summary
version 2
network 157.68.0.0
interface GigabitEthernet0/0/0
rip authentication-mode md5 nonstandard plain HW 1
R5:
interface LoopBack0
ip address 10.1.5.5 255.255.255.255
ospf network-type broadcast
ospf 1
area 0.0.0.1
network 10.1.52.0 0.0.0.255
network 10.1.5.5 0.0.0.0
SW1:
ospf 1
area 0.0.0.1
network 10.1.21.0 0.0.0.255
network 10.1.22.0 0.0.0.255
SW2:
ospf 1
area 0.0.0.1
network 10.1.21.0 0.0.0.255
network 10.1.52.0 0.0.0.255
R5:
interface GigabitEthernet0/0/1
ospf cost 10
ospf 1
area 0.0.0.1
authentication-mode md5 1 plain HW
SW1:
interface Vlanif5
ospf cost 10
interface Vlanif27
ospf cost 10
ospf 1
area 0.0.0.1
authentication-mode md5 1 plain HW
SW2:
interface Vlanif5
ospf cost 10
interface Vlanif58
ospf cost 10
ospf 1
area 0.0.0.1
authentication-mode md5 1 plain HW
R1:
isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0001.00
interface Serial2/0/0
isis enable 1
interface Serial1/0/1
isis enable 1
interface LoopBack0
isis enable 1
interface GigabitEthernet0/0/0
isis enable 1
R3:
isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0003.00
interface Serial2/0/0
isis enable 1
interface Serial1/0/1.1
isis enable 1
interface Serial1/0/1.5
isis enable 1
interface LoopBack0
isis enable 1
interface GigabitEthernet0/0/0
isis enable 1
R4:
isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0004.00
interface Mp-group0/0/0
isis enable 1
interface Serial1/0/0.1 p2p
isis enable 1
interface LoopBack0
isis enable 1
R5:
isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0005.00
interface Mp-group0/0/0
isis enable 1
interface Serial1/0/1
isis enable 1
R6:
isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0006.00
interface GigabitEthernet0/0/0
isis enable 1
interface LoopBack0
isis enable 1
interface GigabitEthernet0/0/0
rip summary-address 10.1.0.0 255.255.0.0 avoid-feedback
isis 1
import-route rip 1 tag 200
R5:
isis 1
default-route-advertise always
ospf 1
default-route-advertise always
R4:
rip 1
default-route originate
SW2:
bgp 65530
peer 10.1.21.11 as-number 65530
peer 10.1.52.5 as-number 100
ipv4-family unicast
peer 10.1.21.11 enable
peer 10.1.52.5 enable
R1:
bgp 100
peer 157.68.3.254 as-number 11
ipv4-family unicast
peer 157.68.3.254 enable
R3:
bgp 100
peer 157.68.3.254 as-number 11
ipv4-family unicast
R5:
bgp 100
peer 10.1.52.22 as-number 65530
ipv4-family unicast
peer 10.1.52.22 enable
R6:
bgp 100
peer 157.68.1.254 as-number 11
peer 157.68.3.254 as-number 11
ipv4-family unicast
peer 157.68.1.254 enable
peer 157.68.3.254 enable
R1:
bgp 100
peer 10.1.3.3 as-number 100
peer 10.1.3.3 connect-interface LoopBack0
R3:
bgp 100
peer 10.1.135.5 as-number 100
group AS100 internal
peer AS100 connect-interface LoopBack0
peer 10.1.1.1 as-number 100
peer 10.1.1.1 group AS100
peer 10.1.4.4 as-number 100
peer 10.1.4.4 group AS100
peer 10.1.6.6 as-number 100
R4:
bgp 100
peer 10.1.3.3 as-number 100
peer 10.1.3.3 connect-interface LoopBack0
R5:
bgp 100
peer 10.1.135.3 as-number 100
ipv4-family unicast
peer 10.1.135.3 enable
R6:
bgp 100
peer 10.1.3.3 as-number 100
peer 10.1.3.3 connect-interface LoopBack0
ipv4-family unicast
peer 10.1.3.3 next-hop-local
Note:
Apply a route-policy to R4 routes to be advertised to BB2 and change the AS-Path to 100.
R3:
bgp 100
peer 157.68.3.254 route-policy ADDAS export
route-policy ADDAS permit node 10
if-match ip-prefix ADDAS
apply as-path 100 additive
route-policy ADDAS permit node 20
ip ip-prefix ADDAS index 10 permit 10.1.44.0 24
ip ip-prefix ADDAS index 20 permit 10.1.50.0 24
R4:
bgp 100
ipv4-family unicast
network 10.1.44.0 255.255.255.0
R5:
bgp 100
ipv4-family unicast
network 10.1.50.0 255.255.255.0
R6:
bgp 100
peer 157.68.3.254 route-policy ADDAS export
route-policy ADDAS permit node 10
if-match ip-prefix ADDAS
apply as-path 100 additive
route-policy ADDAS permit node 20
ip ip-prefix ADDAS index 10 permit 10.1.44.0 24
ip ip-prefix ADDAS index 20 permit 10.1.50.0 24
Note:
R1, R3, and R6 each advertise two prefixes to AS 11. To ensure that traffic is received
through BB1 and R6, increase the value of AS-Path of the two prefixes. In this situation, the
AS-Path advertised by R6 to BB1 is the lowest. Should only ever add your own AS number to
the AS path..
R1:
bgp 100
ipv4-family unicast
peer 157.68.3.254 public-as-only
R3:
bgp 100
ipv4-family unicast
peer 157.68.3.254 public-as-only
R4:
bgp 100
ipv4-family unicast
peer 157.68.2.254 public-as-only
R6:
bgp 100
ipv4-family unicast
peer 157.68.1.254 public-as-only
peer 157.68.3.254 public-as-only
R3:
bgp 100
peer 10.1.135.5 advertise-community
4.1.1.1 PIM
Enable multicast routing on R1, R3, R4, and R5.
Enable PIM-SM on the Ethernet link between R1 and R3, the Frame Relay network
between R3 and R4, and interconnected interfaces between R4 and R5.
Enable PIM-SM on the loopback interfaces of R1, R3, R4, and R5.
R1
multicast routing-enable
interface GigabitEthernet0/0/0
pim sm
interface LoopBack0
pim sm
R3:
multicast routing-enable
interface Serial1/0/0.1 p2p
pim sm
interface GigabitEthernet0/0/0
pim sm
interface LoopBack0
pim sm
R4:
multicast routing-enable
interface Serial1/0/0.1 p2p
pim sm
interface Mp-group0/0/0
pim sm
interface LoopBack0
pim sm
R5:
multicast routing-enable
interface Mp-group0/0/0
pim sm
interface LoopBack0
pim sm
4.1.1.2 RP Redundancy
Use the IP address of loopback 0 on R1 as a C-RP address to serve group addresses
232.0.0.0-235.255.255.255.
Use the IP address of loopback 0 on R3 as a C-BSR address.
Ensure that R5 can learn the RP address.
R1
acl number 2100
rule 5 permit source 232.0.0.0 3.255.255.255
pim
c-rp LoopBack0 group-policy 2300
R3
pim
c-bsr LoopBack0
R5
ip rpf-route-static 10.1.3.3 255.255.255.255 10.1.45.4
Note:
Use an ACL to specify the range of group addresses that the C-RP serves.
Multicast routers learn RP addresses from BSR messages they receive. BSR messages are
transmitted hop-by-hop among routers in multicast mode. Each router performs an RPF
check on received BSR messages and accepts only those passing the check. BSR messages
that fail RPF checks are dropped. R5 can only receive BSR messages from R4 because PIM
is not enabled on the Frame Relay network between R5 and R3. As a result, the BSR
messages fail RPF checks on R5. To enable R5 to accept BSR messages sent from R4, modify
the RPF check setting on R5.
When performing an RPF check on a BSR message, a router obtains the C-BSR address from
the message and searches its routing table for the next-hop address based on the C-BSR
address. The router then compares the next-hop address with the source IP address in the IP
header of the BSR message. If the two addresses are the same, the BSR message passes the
RPF check. If not, the router drops the BSR message. Here, the C-BSR address is the IP
address of loopback 0 on R3, and the next-hop address in the matching route entry is the IP
address of S1/0/1 on R3. However, the source IP address of the BSR message received by R5
is the MP-group interface address on R4. Therefore, the RPF check fails under the default
RPF check configuration.
4.1.1.3 IGMP
Enable IGMP on G0/0/0 of R5 and statically bind the interface to group
235.10.10.10.
Change the RPT-to-SPT switchover threshold to ensure that an RPT-to-SPT
switchover will occur when the traffic rate exceeds 64 kbps.
Ensure that R5 can receive multicast traffic from the RP.
Ensure that R1 will be elected as the PIM DR in VLAN 255.
R5:
interface GigabitEthernet0/0/0
igmp enable
igmp static-group 235.10.10.10
pim
spt-switch-threshold 64
ip rpf-route-static 10.1.1.1 32 10.1.45.4
R1
interface GigabitEthernet0/0/0
pim hello-option dr-priority 3
Note:
An interface can be statically bound to a multicast group using the igmp static-group
command.
The source DR encapsulates multicast data packets in Register messages and sends unicast
Register messages to the RP, which then forwards the multicast data packets to receivers
along the RPT. By default, when the RP or receiver DR receives the first multicast data
packet, it initiates an SPT switchover to the multicast source. After the spt-switch-threshold
command is configured on the receiver DR, the receiver DR periodically checks the rate of
multicast data packets. When this rate exceeds the threshold, the receiver DR sends a Join
message to the source to trigger an SPT switchover.
A DR needs to be elected on a shared network segment of a PIM-SM network to manage
multicast source registration and receiver joining. DR election depends on the priorities and
IP addresses of multicast routers. Routers on a shared network segment exchange Hello
messages carrying their DR priorities, and the one with the highest priority becomes the DR.
If two or more routers share the highest priority, the one with the largest IP address becomes
the DR. Change the DR priority of an interface using the pim hello-option dr-priority
command.
R1:
mpls lsr-id 10.1.1.1
mpls
interface GigabitEthernet0/0/0
mpls
interface Serial1/0/1.1
mpls
interface Serial2/0/0
mpls
R3:
mpls lsr-id 10.1.3.3
mpls
interface GigabitEthernet0/0/0
mpls
interface Serial1/0/0.1
mpls
interface Serial1/0/1.1
mpls
interface Serial2/0/0
mpls
R4:
mpls lsr-id 10.1.4.4
mpls
interface Serial1/0/0.1
mpls
5.1.1.2 VPN-Instance
On R1: create a VPN instance TEST_R1, and set both RD and RT to 100:11.
Create Loopback1 and set its address to 192.168.100.11/32. Loopback1 belongs to
TEST_R1.
On R3: create a VPN instance TEST_HUB, and set both RD and export RT to
100:33. Create Loopback1 and set its address to 192.168.100.33/32. Loopback1
belongs to TEST_HUB.
On R4: create a VPN instance TEST_R4, and set both RD and export RT to
100:44. Create Loopback1 and set its address to 192.168.100.44/32. Loopback1
belongs to TEST_R4.
R1
interface LoopBack1
ip binding vpn-instance TEST_R1
ip address 192.168.100.11 255.255.255.255
ip vpn-instance TEST_R1
ipv4-family
route-distinguisher 100:11
vpn-target 100:11 export-extcommunity
R3
interface LoopBack1
ip binding vpn-instance TEST_HUB
ip address 192.168.100.33 255.255.255.255
ip vpn-instance TEST_HUB
ipv4-family
route-distinguisher 100:33
vpn-target 100:33 export-extcommunity
R4
interface LoopBack1
ip binding vpn-instance TEST_R4
ip address 192.168.100.44 255.255.255.255
ip vpn-instance TEST_R4
ipv4-family
route-distinguisher 100:44
vpn-target 100:44 export-extcommunity
5.1.1.3 MP-BGP
Use the VPNv4 address family for BGP connections among R1, R3, and
R4.
Set the import RT for each VPN instance on R1, R3, and R4 to ensure that
TEST_HUB on R3 can communicate with TEST_R1 on R1 and TEST_R4
on R4 while TEST_R1 on R1 and TEST_R4 on R4 remain isolated from
each other.
The VPN connection between R1 and R3 is not interrupted so long as there
is a reachable route between them.
R1
ip vpn-instance TEST_R1
ipv4-family
vpn-target 100:33 import-extcommunity
bgp 100
ipv4-family vpnv4
policy vpn-target
peer 10.1.3.3 enable
ipv4-family vpn-instance TEST_R1
network 192.168.100.11 255.255.255.255
static-lsp ingress 103 destination 10.1.3.3 32 nexthop 10.1.113.3 out-label 103
static-lsp egress 301 incoming-interface Serial1/0/1.1 in-label 301
static-lsp ingress 113 destination 10.1.3.3 32 nexthop 157.68.3.3 out-label 113
static-lsp egress 311 incoming-interface GigabitEthernet0/0/0 in-label 311
static-lsp ingress 123 destination 10.1.3.3 32 nexthop 10.1.13.3 out-label 123
static-lsp egress 321 incoming-interface Serial2/0/0 in-label 321
R3:
ip vpn-instance TEST_HUB
ipv4-family
vpn-target 100:11 100:44 import-extcommunity
bgp 100
ipv4-family vpnv4
policy vpn-target
peer 10.1.1.1 enable
peer 10.1.4.4 enable
ipv4-family vpn-instance TEST_HUB
network 192.168.100.33 255.255.255.255
static-lsp ingress 304 destination 10.1.4.4 32 nexthop 10.1.34.4 out-label 304
static-lsp egress 403 incoming-interface Serial1/0/0.1 in-label 403
static-lsp ingress 301 destination 10.1.1.1 32 nexthop 10.1.113.1 out-label 301
static-lsp egress 103 incoming-interface Serial1/0/1.1 in-label 103
static-lsp ingress 311 destination 10.1.1.1 32 nexthop 157.68.3.1 out-label 311
static-lsp egress 113 incoming-interface GigabitEthernet0/0/0 in-label 113
static-lsp ingress 321 destination 10.1.1.1 32 nexthop 10.1.13.1 out-label 321
static-lsp egress 123 incoming-interface Serial2/0/0 in-label 123
R4:
ip vpn-instance TEST_R4
ipv4-family
vpn-target 100:33 import-extcommunity
bgp 100
ipv4-family vpnv4
policy vpn-target
peer 10.1.3.3 enable
ipv4-family vpn-instance TEST_R4
network 192.168.100.44 255.255.255.255
static-lsp ingress 403 destination 10.1.3.3 32 nexthop Serial1/0/0.1 out-label 403
static-lsp egress 304 incoming-interface Serial1/0/0.1 in-label 304
Note:
Establish an LSP between BGP peers to ensure proper MPLS VPN function.
If LDP is used, LSPs are automatically established based on the unicast routing table. In this
exam, however, LDP cannot be enabled. Instead, manually configure static LSPs.
Three paths that serve as each others backups exist between R1 and R3. For this exam,
configure static LSPs for all three paths.
6. Section 6: QoS
SW3:
traffic classifier c1 operator and
if-match vlan-id 42
traffic behavior b1
remark 8021p 4
traffic policy p1
classifier c1 behavior b1
interface Ethernet0/0/13
traffic-policy p1 inbound
SW4:
traffic classifier c1 operator and
if-match vlan-id 255
traffic behavior b1
car cir 2000 pir 2000 cbs 250000 pbs 250000 green pass yellow discard red discard
remark 8021p 3
statistic enable
traffic policy p1
classifier c1 behavior b1
interface Ethernet0/0/11
traffic-policy p1 inbound
interface Ethernet0/0/0
trust 8021p
interface GigabitEthernet0/0/1
qos queue-profile qp1
qos gts cir 8000 cbs 200000
7. Section 7: Security
SW3:
vlan 255
broadcast-suppression 500
SW4:
icmp rate-limit interface Ethernet0/0/11 threshold 20
SW4
E0/0/11
storm-control multicast min-rate 1000 max-rate 2000
storm-control unicast min-rate 1000 max-rate 2000
storm-control action block
storm-control enable log
storm-control interval 90
Note:
1. Observe the differences between QoS lr, multicast suppression, and storm control.
2. Traffic shaping increases the delay because it uses the buffer mechanism. Multicast
suppression applies to only multicast packets and therefore is inapplicable to this section of
the exam.
7.1.1.2 DHCP
Configure SW1 to allocate IP addresses to clients connected to VLANIF 27. The
address of the network segment is 10.1.22.0/24; addresses 10.1.22.2 and 10.1.22.11
are reserved. The DNS server is 10.1.22.254 and the lease is 2 days.
The DHCP server should probe an IP address before allocating it to a client, the
maximum number of probe packets sent by the DHCP server should be 10 and the
waiting time to 100ms.
Enable DHCP snooping in VLAN 27 on SW3 to prevent unauthorized DHCP
servers disrupting the network.
SW1:
dhcp enable
dhcp server ping packet 10
dhcp server ping timeout 100
interface vlanif27
dhcp select interface
dhcp server excluded-ip-address 10.1.22.2
dhcp server excluded-ip-address 10.1.22.254
dhcp server lease day 2 hour 0 minute 0
dhcp server dns-list 10.1.22.254
SW3:
dhcp enable
dhcp snooping enable
vlan 27
dhcp snooping enable
dhcp snooping trusted interface Ethernet0/0/13
SW3:
vlan 27
arp anti-attack check user-bind enable
R6:
arp-miss speed-limit source-ip maximum 20
arp-miss speed-limit source-ip 157.68.3.100 maximum 40
arp learning strict
Note:
Observe the difference between ARP rate limiting and ARP Miss rate limiting.
7.1.1.4 IPSG
Configure defense against source address spoofing attacks from VLAN 27 of SW3.
SW3 should discard IP packets with the same source and destination IP addresses.
SW3:
ip anti-attack source-ip equals destination-ip drop
vlan 27
ip source check user-bind enable
R6:
undo anti-attack tcp-syn enable
undo anti-attack icmp-flood enable
anti-attack tcp-syn car cir 15000
anti-attack icmp-flood car cir 15000
Note:
Before configuring, run the undo command to cancel the default configurations for defense
against TCP SYN and ICMP flooding attacks.
8. Section 8: IP Feature
R2:
capture-packet interface G0/0/0 destination terminal time-out 100
8.1.1.2 VRRP
Add R1 and R3 to a VRRP group with IP address 157.68.3.102. Set R1 to master
and preemption delay to 10 seconds. To lessen fault impact on services, configure
ICMP on R1 to monitor packets on R5's S1/0/1 and set the detection interval to 20
seconds. When the packet rate reaches 80%, an active/standby switchover occurs in
the VRRP group.
R1
Interface GigabitEthernet0/0/0
vrrp vrid 1 virtual-ip 157.68.3.102
vrrp vrid 1 priority 120
vrrp vrid 1 preempt-mode timer delay 10
R3
Interface GigabitEthernet0/0/0
vrrp vrid 1 virtual-ip 157.68.3.102
R1
nqa test-instance user test
test-type icmp
destination-address ipv4 10.1.135.5
frequency 20
fail-percent 80
start now
Interface GigabitEthernet0/0/0
vrrp vrid 1 track nqa user test reduced 40
Note:
Understand the NQA functions, plan the detection and destination points in NQA
tests, and configure VRRP and NQA association.
impacting service traffic, allow the NMS server to monitor R1 only between 7:00-
21:00 on weekends.
R3
info-center source ping channel 4 log level warning
R1
time-range acl_1 7:00 to 21:00 off-day
acl number 2001
rule 1 permit source 157.68.3.101 0.0.0.0 time-range acl_1
snmp-agent
snmp-agent sys-info version v3
snmp-agent usm-user v3 testuser testgroup authentication-mode sha password
snmp-agent group v3 testgroup privacy write-view SNMPV3 notify-view SNMPV3
snmp-agent target-host trap-paramsname SNMPV3 v3 securityname testuser privacy
snmp-agent target-host trap-hostname SNMPHOST address 157.68.3.101 trap-paramsname
SNMPV3
snmp-agent trap enable feature-name bgp
info-center source BGP channel 5 trap level error
Note:
1. This section of the exam implies that information will be output through channel 4.
2. This section requires a time range-based ACL.
8.1.1.4 SSH
Set up secure login for users to VTY 0-4 of R6 through R3. The listening port of
R6 is port 1025. Ensure that SFTP and SCP are supported. Use password
authentication and set user name to R3, password to Hellow, and update interval to
24 hours. Give the R3 administrator all configuration rights on R6.
R6:
ssh user R3 authentication-type password
aaa
local-user R3 password cipher Hellow
local-user R3 service-type ssh
local-user R3 privilege level 3
stelnet server enable
ssh server port 1025
user-interface vty 0 4
authentication-mode aaa
protocol inbound ssh
R3
ssh client first-time enable
Note:
Use SSH and management level for this section.
8.1.1.5 NTP
R6 has synchronized with the standard clock. Configure the R3 clock to
synchronize with R6. Set the clock stratum to 5, encrypt NTP broadcast traffic on
the LAN with hmac-sha256, set key ID to 16, and set the password to Hello.
R6
ntp-service refclock-master 4
ntp-service authentication enable
ntp-service authentication-keyid 16 authentication-mode hmac-sha256 Hello
ntp-service reliable authentication-keyid 16
interface gigabitethernet 0/0/0
ntp-service broadcast-server authentication-keyid 16
R3
ntp-service authentication enable
ntp-service authentication-keyid 16 authentication-mode hmac-sha256 Hello
ntp-service reliable authentication-keyid 16
interface gigabitethernet G/0/0
ntp-service broadcast-client
Note:
Configure R6 as the NTP server.