Implementing Multicast Service Reflection

Download as pdf or txt
Download as pdf or txt
You are on page 1of 16

Implementing Multicast Service Reflection

First Published: September 22, 2006


Last Updated: September 22, 2006

The Multicast Service Reflection feature provides the capability for users to translate externally received
multicast destination addresses to addresses that conform to their organization’s internal addressing
policy. Using this feature, users do not need to redistribute routes at the translation boundary into their
network infrastructure for Reverse Path Forwarding (RPF) to work properly, and users can receive
identical feeds from two ingress points in the network and route them independently.

Finding Feature Information in This Module


Your Cisco IOS software release may not support all of the features documented in this module. To reach
links to specific feature documentation in this module and to see a list of the releases in which each feature is
supported, use the Feature Information for Multicast Service Reflection section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images
Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS
software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An
account on Cisco.com is not required.

Contents
• Prerequisites for Implementing Multicast Service Reflection, page 2
• Restrictions for Implementing Multicast Service Reflection, page 2
• Information About Implementing Multicast Service Reflection, page 2
• How to Implement Multicast Service Reflection, page 5
• Configuration Examples for Multicast Service Reflection, page 7
• Additional References, page 10
• Feature Information for Multicast Service Reflection, page 14

Corporate Headquarters
Cisco Systems, Inc., 170 West Tasman Drive, San Jose, CA 95134-1706 USA

© 2006 Cisco Systems, Inc. All rights reserved.


Implementing Multicast Service Reflection
Prerequisites for Implementing Multicast Service Reflection

Prerequisites for Implementing Multicast Service Reflection


The following prerequisites apply to implementing multicast service reflection:
• Because virtual interface (Vif1) handling of replicated packets to the multicast code is done in the
same switching context as the one in which it receives the initial packet, you must enable the ip
mroute-cache command to avoid process switching.
• Configure your multicast enabled network with the necessary infrastructure to run either
Protocol-Independent Multicast-Sparse Mode (PIM-SM), Bidirectional PIM (bidir-PIM), or PIM
Source Specific Multicast (PIM-SSM). The configuration process may include configuring RPs,
interface boundaries, or SSM ranges.
For configuration information, see the “Configuring Basic IP Multicast” module in the Cisco IOS
IP Multicast Configuration Guide, Release 12.4.
• Confirm that the Vif1 interface is installed in your border router and the Multicast Service
Reflection application is installed and operational.
• Each active receiver must initiate an Internet Group Management Protocol (IGMP) join to the
multicast group that is defined on the router in the PIM domain.

Restrictions for Implementing Multicast Service Reflection


The following restrictions apply to implementing multicast services reflection:
• When translating groups of multicast packets that are destined for the same multicast group but are
originating from different sources, as in the case when using Source Specific Multicast, all multicast
packets destined for a particular SSM group will get mapped to a single (S, G) after translation has
occurred. For example, if 10.1.1.1, 232.1.1.1 and 10.1.1.2, 232.1.1.1 need to be translated, they will
appear as a single entry, for example, 192.168.1.2, 232.239.1.1, where 192.168.1.2 is an IP address
that resides in the Vif1 IP subnet.
• PIM/IGMP control packets are not translated.
• The multicast services reflection feature is implemented only in the fast switching path. There is no
hardware support.

Information About Implementing Multicast Service Reflection


To implement multicast service reflection, you should understand the following concepts:
• Benefits of Using Multicast Service Reflection, page 3
• Rendezvous Points, page 3
• Vif1 Interface, page 4
• Multicast Service Reflection Application, page 4
• General Configuration Procedure for Implementing Multicast Service Reflection, page 5

Cisco IOS Release 12.4T


2
Implementing Multicast Service Reflection
Information About Implementing Multicast Service Reflection

Benefits of Using Multicast Service Reflection


• Users can translate externally received multicast destination addresses to addresses that conform to
their company’s internal addressing policy.
• Provides logical separation between private and public multicast networks.
• Provides the flexibility to forward multicast packets—translate or untranslated—out the same
outgoing interface.
• Provides redundancy by allowing users to get identical feeds from two ingress points in the network
and route them independently.
• Users can use the subnet of their choice to be the source network and scope it appropriately.

Rendezvous Points
A rendezvous point (RP) is a role that a router performs when operating in PIM-SM or bidirectional PIM.
An RP is required only in networks running PIM-SM or bidirectional PIM. In PIM-SM, only network
segments with active receivers that have explicitly requested multicast data will be forwarded the traffic.
An RP acts as the meeting place for sources and receivers of multicast data. In a PIM-SM network,
sources must send their traffic to the RP. This traffic is then forwarded to receivers down a shared
distribution tree. By default, when the first hop router of the receiver learns about the source, it will send
a Join message directly to the source, creating a source-based distribution tree from the source to the
receiver. This source tree does not include the RP unless the RP is located within the shortest path
between the source and receiver.
In most cases, the placement of the RP in the network is not a complex decision. By default, the RP is
needed only to start new sessions with sources and receivers. Consequently, the RP experiences little
overhead from traffic flow or processing. In PIM version 2, the RP performs less processing than in PIM
version 1 because sources must register only periodically with the RP to create state.

PIM Sparse Mode


PIM sparse mode (PIM-SM) uses a pull model to deliver multicast traffic. Only network segments with
active receivers that have explicitly requested the data will receive the traffic.
Unlike dense mode interfaces, sparse mode interfaces are added to the multicast routing table only when
periodic join messages are received from downstream routers, or when a directly connected member is
on the interface. When forwarding from a LAN, sparse mode operation occurs if an RP is known for the
group. If so, the packets are encapsulated and sent toward the RP. When no RP is known, the packet is
flooded in a dense mode fashion. If the multicast traffic from a specific source is sufficient, the first hop
router of the receiver may send Join messages toward the source to build a source-based distribution tree.
PIM-SM distributes information about active sources by forwarding data packets on the shared tree.
Because PIM-SM uses shared trees (at least, initially), it requires the use of a rendezvous point (RP).
The RP must be administratively configured in the network.
In sparse mode, a router assumes that other routers do not want to forward multicast packets for a group,
unless there is an explicit request for the traffic. When hosts join a multicast group, the directly
connected routers send PIM Join messages toward the RP. The RP tracks multicast groups. Hosts that
send multicast packets are registered with the RP by the first hop router of that host. The RP then sends
Join messages toward the source. At this point, packets are forwarded on a shared distribution tree. If
the multicast traffic from a specific source is sufficient, the first hop router of the host may send Join
messages toward the source to build a source-based distribution tree.

Cisco IOS Release 12.4T


3
Implementing Multicast Service Reflection
Information About Implementing Multicast Service Reflection

First-hop designated routers with directly connected sources register with the RP and then data is
forwarded down the shared tree to the receivers. The edge routers learn about a particular source when
they receive data packets on the shared tree from that source through the RP. The edge router then sends
PIM (S, G) Join messages toward that source. Each router along the reverse path compares the unicast
routing metric of the RP address to the metric of the source address. If the metric for the source address
is better, it will forward a PIM (S, G) Join message toward the source. If the metric for the RP is the same
or better, then the PIM (S, G) Join message will be sent in the same direction as the RP. In this case, the
shared tree and the source tree would be considered congruent.
If the shared tree is not an optimal path between the source and the receiver, the routers dynamically
create a source tree and stop traffic from flowing down the shared tree. This behavior is the default
behavior in Cisco IOS software. Network administrators can force traffic to stay on the shared tree by
using the Cisco IOS ip pim spt-threshold infinity command.
PIM-SM scales well to a network of any size, including those with WAN links. The explicit join
mechanism prevents unwanted traffic from flooding the WAN links.

Vif1 Interface
The Vif1 interface is similar to a loopback interface—it is a logical IP interface that is always up when
the router is active.
The Vif1 interface needs to reside on its own unique subnet, and that subnet should be included in the
routing protocol updates (RIP, OSPF, and so on).
The Vif1 interface maintains information about the input interface, private-to-public mgroup mappings,
mask length, which defines your pool range, and the source of the translated packet.

Multicast Service Reflection Application


The multicast service reflection is an application running in Cisco IOS software interrupt level switching
that processes packets forwarded by Cisco IOS software to the Vif1 interface. Unlike IP multicast
Network Address Translation (NAT), the IP reflect service is not integrated into IP multicast routing.
When a packet is forwarded to the Vif1 interface, the packet’s source IP address is changed to the IP
address of the Vif subnet thereby preventing RPF failures. Finally, the destination IP address is translated
to the new multicast group. Additionally, the original multicast packet can be forwarded untranslated
through the router. For example, users that have not yet moved to the new multicast group can still
receive the untranslated stream.
Each configured multicast service reflection line establishes a packet match and rewrite operation acting
on packets sent by Cisco IOS unicast or multicast packet routing onto the Vif1 interface. The matched
and rewritten packet is sent back into Cisco IOS unicast or multicast packet routing, where it is handled
like any other packet arriving from an interface.
The Vif1 interface acts like a “sink” or receiver for the original stream and makes it appear that the new
stream is coming from a source directly connected to the Vif1 subnet. The Vif1 interface acts like a
Designated Router (DR) for the source and registers with the appropriate RP.
More than one multicast service reflection operation can be configured to match the same packets, which
allows you to replicate the same received traffic to multiple destination addresses. There is no hard limit
to the number of multicast service reflection statements you can configure under the Vif1 interface.
The Multicast Service Reflection feature is available in Cisco IOS Release 12.4(4)T on software-based
nondistributed forwarding platforms, up to and including the Cisco 7200 series routers.

Cisco IOS Release 12.4T


4
Implementing Multicast Service Reflection
How to Implement Multicast Service Reflection

General Configuration Procedure for Implementing Multicast Service


Reflection
To implement multicast service reflection, you would complete the following procedure:
1. Identify the multicast groups to be translated.
2. On the Vif1 interface, statically configure an IGMP join to the service provider multicast group(s).
3. Configure the IP reflect service application to translate the destination addresses in the content
provider’s multicast group into a pool of multicast addresses that can be used in your PIM domain,
and define a new source for those addresses.
4. Advertise the newly created source address to your interior gateway protocol (OSPF, IS-IS, EIGRP,
and so on).

How to Implement Multicast Service Reflection


This section contains the following task:
• Configuring Multicast Service Reflection, page 5

Configuring Multicast Service Reflection


Perform this task to configure multicast service reflection.

SUMMARY STEPS

1. enable
2. configure terminal
3. ip multicast-routing [distributed]
4. interface type number
5. ip pim sparse-mode
6. no shutdown
7. exit
8. Repeat Steps 4 through 7 for each PIM interface.
9. interface type number
10. ip address ip-address mask [secondary]
11. ip pim sparse-mode
12. ip service reflect input-interface destination destination-address to new-destination-address
mask-len number source new-source-address
13. ip igmp static-group {* | group-address [source {source-address | ssm-map}]}
14. end

Cisco IOS Release 12.4T


5
Implementing Multicast Service Reflection
How to Implement Multicast Service Reflection

DETAILED STEPS

Command or Action Purpose


Step 1 enable Enables privileged EXEC mode.
• Enter your password if prompted.
Example:
Router> enable
Step 2 configure terminal Enters global configuration mode.

Example:
Router# configure terminal
Step 3 ip multicast-routing [distributed] Enables IP multicast routing.
• Use the distributed keyword to enable the Multicast
Example:
Distributed Switching feature.
Router(config)# ip multicast-routing
Step 4 interface type number Enters interface configuration mode for the specified
interface type and number.
Example:
Router(config)# interface ethernet 0
Step 5 ip pim sparse-mode Enables PIM sparse mode on the interface.

Example:
Router(config-if)# ip pim sparse-mode
Step 6 no shutdown Enables an interface.

Example:
Router(config-if)# no shutdown
Step 7 exit Exits interface configuration mode, and returns to global
configuration mode.
Example:
Router(config-if)# exit
Step 8 Repeat Steps 4 through 7 for each PIM interface. —
Step 9 interface type number Enters interface configuration mode for the specified
interface type and number.
Example: • The Vif1 interface is the virtual interface for multicast
Router(config)# interface Vif1 service reflection.
Step 10 ip address ip-address mask [secondary] Sets a primary or secondary IP address for an interface.

Example:
Router(config-if)# ip address 10.1.1.1
255.255.255.0
Step 11 ip pim sparse-mode Enables PIM sparse mode on an interface.

Example:
Router(config-if)# ip pim sparse-mode

Cisco IOS Release 12.4T


6
Implementing Multicast Service Reflection
Configuration Examples for Multicast Service Reflection

Command or Action Purpose


Step 12 ip service reflect input-interface destination Matches and rewrites multicast packets routed onto the Vif1
destination-address to new-destination-address interface.
mask-len number source new-source-address
• The matched and rewritten packets are sent back into
Cisco multicast packet routing, where they are handled
Example: like any other packets arriving from an interface.
Router(config-if)# ip service reflect ethernet0
destination 224.1.1.0 to 239.2.2.0 mask-len 24
source 10.1.1.2
Step 13 ip igmp static-group {* | group-address [source Configures the router to be a statically connected member
{source-address | ssm-map}]} of the specified group on the interface, or to statically
forward for a multicast group onto the interface.
Example:
Router(config-if)# ip igmp static-group
224.1.1.1
Step 14 end Exits interface configuration mode, and returns to
privileged EXEC mode.
Example:
Router(config-if)# end

Configuration Examples for Multicast Service Reflection


This section contains the following example:
• Multicast Service Reflection in a Service Provider Network: Example, page 7

Multicast Service Reflection in a Service Provider Network: Example


The following example shows how to implement multicast service reflection in a service provider
network.
This example uses the topology illustrated in Figure 1.

Cisco IOS Release 12.4T


7
Implementing Multicast Service Reflection
Configuration Examples for Multicast Service Reflection

Figure 1 Multicast Service Reflection in a Service Provider Network Example Topology

! These commands are entered on the router


running the multicast service reflection feature (R1)
!
ip multicast-routing
!
interface Ethernet 0
ip address 10.0.2.1 255.255.255.0
ip pim sparse-mode
no shutdown
!
interface Ethernet 1
ip address 10.0.3.1 255.255.255.0
ip pim sparse-mode
no shutdown Content
!
Provider
! Configure the loopback interface for the Service Private
Provider RP multicast
! Source Destination
10.2.2.2 224.1.1.1 group
interface Loopback 0
ip address 192.168.2.1 255.255.255.255
!
ip pim rp-address 192.168.2.1 mcast-content-
provider-groups override
ip pim rp-address 192.168.2.2 mcast-service-
provider-groups override
ip access-list standard mcast-content-provider- E0
Private network
groups permit 224.1.1.0 0.0.0.255
ip access-list standard mcast-service-provider- Vif1 Interface R1 Edge router Public network
groups permit 239.2.2.0 0.0.0.255 1.1.1.1/24
10.1.1.1/24 E1 running multicast
!
service reflection
! Configure the Vif1 virtual interface for multicast
service reflection application
!
interface Vif1
PIM router/RP along
ip address 10.1.1.1 255.255.255.0 Loopback 0 R2 the distribution tree
ip pim sparse-mode 192.168.2.2/32
ip service reflect Ethernet 0 destination 224.1.1.0 to
Service Provider
239.2.2.0 mask-len 24 source 10.1.1.2
ip igmp static-group 224.1.1.1 PIM Domain
...
ip igmp static-group 224.1.1.255 R3 Edge router

! These commands are entered on the router that is


the RP in the service provider network (R2)
! Receiver
R4
ip multicast-routing
interface Loopback 0
Source Destination
ip address 192.168.2.2 255.255.255.255
! 10.1.1.2 239.2.2.1
ip pim rp-address 192.168.2.2 mcast-service-provider-
groups override
ip access-list standard mcast-service-provider-groups
permit 239.2.2.0 0.0.0.255

! These commands are entered on all the other


routers in the service provider network (R3)
!
ip multicast-routing
!

170638
ip pim rp-address 192.168.2.2 mcast-service-provider-
groups override
ip access-list standard mcast-service-provider-groups
permit 239.2.2.0 0.0.0.255

In this example topology, a content provider is sending financial market information to a service
provider, which in turn is sending that information to active receivers (brokerage houses). The service
provider may be receiving market data from multiple content providers.
Router R1 is an edge router in the service provider’s PIM domain. R1 has a Vif1 interface and is running
the multicast service reflection application.
Router R2 has a loopback interface and is acting as the RP for the 239.2.2.0 address range.

Cisco IOS Release 12.4T


8
Implementing Multicast Service Reflection
Configuration Examples for Multicast Service Reflection

Router R3 is another edge router in the service provider’s PIM domain.


! Enter these commands on the router running the multicast service reflection application
(R1 in Figure 1)
!
configure terminal
ip multicast-routing
interface Ethernet 0
ip address 10.0.2.1 255.255.255.0
ip pim sparse-mode
no shutdown
!
interface Ethernet 1
ip address 10.0.3.1 255.255.255.0
ip pim sparse-mode
no shutdown
!
! Configure the loopback interface for the Service Provider RP
!
interface loopback 0
ip address 192.168.2.1 255.255.255.255
!
ip pim rp-address 192.168.2.1 mcast-content-provider-groups override
ip pim rp-address 192.168.2.2 mcast-service-provider-groups override
ip access-list standard mcast-content-provider-groups permit 224.1.1.0 0.0.0.255
ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255
!
! Configure the Vif1 virtual interface for multicast service reflection
!
interface Vif1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip service reflect Ethernet 0 destination 224.1.1.0 to 239.2.2.0 mask-len 24 source
10.1.1.2
ip igmp static-group 224.1.1.1
ip igmp static-group 224.1.1.2
ip igmp static-group 224.1.1.3
.
.
.
ip igmp static-group 224.1.1.255
!
! Enter these commands on the router that is the RP in the service provider network (R2 in
Figure 1)
!
ip multicast-routing
interface loopback 0
ip address 192.168.2.2 255.255.255.255
!
ip pim rp-address 192.168.2.2 mcast-service-provider-groups override
ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255
!
!Enter these commands on all the other routers in the service provider network (R3 in
Figure 1)
!
ip multicast-routing
ip pim rp-address 192.168.2.2 mcast-service-provider-groups override
ip access-list standard mcast-service-provider-groups permit 239.2.2.0 0.0.0.255
end
!

Cisco IOS Release 12.4T


9
Implementing Multicast Service Reflection
Additional References

Additional References
The following sections provide references related to the Multicast Service Reflection feature.

Related Documents
Related Topic Document Title
Multicast commands: complete command syntax, Cisco IOS IP Multicast Command Reference, Release 12.4
command mode, command history, defaults, usage
guidelines, and examples
Multicast configuration tasks Cisco IOS IP Multicast Configuration Guide, Release 12.4.

Standards
Standards Title
No new or modified standards are supported by this —
feature, and support for existing standards has not been
modified by this feature.

MIBs
MIBs MIBs Link
No new or modified MIBs are supported by this To locate and download MIBs for selected platforms, Cisco IOS
feature. releases, and feature sets, use Cisco MIB Locator found at the
following URL:
http://www.cisco.com/go/mibs

RFCs
RFCs Title
No new or modified RFCs are supported by this —
feature, and support for existing RFCs has not been
modified by this feature.

Cisco IOS Release 12.4T


10
Implementing Multicast Service Reflection
Glossary

Technical Assistance
Description Link
The Cisco Technical Support & Documentation http://www.cisco.com/techsupport
website contains thousands of pages of searchable
technical content, including links to products,
technologies, solutions, technical tips, tools, and
technical documentation. Registered Cisco.com users
can log in from this page to access even more content.

Glossary
distribution tree—Multicast traffic flows from the source to the multicast group over a distribution tree
that connects all of the sources to all of the receivers in the group. This tree may be shared by all sources
(a shared tree), or a separate distribution tree can be built for each source (a source tree). The shared tree
may be one-way or bidirectional.
multicast—A routing technique that allows IP traffic to be sent from one source or multiple sources and
delivered to multiple destinations. Instead of sending individual packets to each destination, a single
packet is sent to a group of destinations known as a multicast group, which is identified by a single IP
destination group address. Multicast addressing supports the transmission of a single IP datagram to
multiple hosts.
Protocol Independent Multicast (PIM)—A multicast routing architecture defined by the IETF that
enables IP multicast routing on existing IP networks. Its key point is its independence from any
underlying unicast protocol such as OSPF or BGP.
rendezvous point (RP)—The multicast router that is the root of the PIM-SM shared multicast
distribution tree.
source tree—A multicast distribution path that directly connects the source’s and receivers’ designated
router (or the rendezvous point) to obtain the shortest path through the network. This results in most
efficient routing of data between source and receivers, but may result in unnecessary data duplication
throughout the network if built by anything other than the RP.
unicast—Point-to-point transmission requiring the source to send an individual copy of a message to
each requester.

Note Refer to Internetworking Terms and Acronyms for terms not included in this glossary.

Command Reference
This section documents the following new command only.
• ip service reflect

Cisco IOS Release 12.4T


11
Implementing Multicast Service Reflection
ip service reflect

ip service reflect
To match and rewrite multicast packets routed onto a Vif1 interface, use the ip service reflect command
in interface configuration mode. To disable this feature, use the no form of this command.

ip service reflect input-interface destination destination-address to new-destination-address


mask-len number source new-source-address

no ip service reflect input-interface destination destination-address to new-destination-address


mask-len number source new-source-address

Syntax Description input-interface Interface type and number.


destination Identifies packets with destination address.
destination-address Destination IP address in the packets, in A.B.C.D format.
to Modifies the destination IP address in reflected packets to a new IP
address.
new-destination-address New destination address to be used, in A.B.C.D format.
mask-len number Mask length of destination address to match. The number argument is a
value from 0 to 32.
source Modifies the source address in reflected packets.
new-source-address New source address to be used, in A.B.C.D format.

Command Default The multicast service reflection feature is disabled.

Command Modes Interface configuration

Command History Release Modification


12.4(4)T This command was introduced.

Usage Guidelines Use the ip service reflect command to match and rewrite multicast packets routed onto a rendezvous
point (RP) Vif1 interface.
The matched and rewritten packet is sent back into Cisco multicast packet routing, where it is handled
like any other packet arriving from an interface.
More than one multicast service reflection operation can be configured to match the same packet,
allowing you to replicate the same received traffic to multiple destination addresses.

Cisco IOS Release 12.4T


12
Implementing Multicast Service Reflection
ip service reflect

Examples This example would translate any multicast packet with a destination address of 239.1.1.0/24 to a
destination of 239.2.2.0/24 with a new source address of 10.1.1.2. For example, a packet with a source
and destination of 10.10.10.10, 239.1.1.15 would be translated to 10.1.1.2, 239.2.2.15.
Router(config-if)# ip service reflect Ethernet 0/0 destination 239.1.1.0 to 239.2.2.0
mask-len 24 source 10.1.1.2

Cisco IOS Release 12.4T


13
Implementing Multicast Service Reflection
Feature Information for Multicast Service Reflection

Feature Information for Multicast Service Reflection


Table 1 lists the release history for this feature.
Not all commands may be available in your Cisco IOS software release. For release information about a
specific command, see the command reference documentation.
Use Cisco Feature Navigator to find information about platform support and software image support.
Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images
support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to
http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given
Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS
software release train also support that feature.

Table 1 Feature Information for Multicast Service Reflection

Feature Name Releases Feature Information


Multicast Service Reflection 12.4(4)T The Multicast Service Reflection feature allows you
translate externally received multicast destination addresses
to addresses that conform to an organization’s internal
addressing policy. Using this feature, users do not need to
redistribute routes at the translation boundary into their
network infrastructure for Reverse Path Forwarding (RPF)
to work properly, and users can receive identical feeds from
two ingress points in the network and route them
independently.
The following sections provide information about this
feature:
• Multicast Service Reflection Application, page 4
• Configuring Multicast Service Reflection, page 5
The following command was introduced by this feature: ip
service reflect.

CCVP, the Cisco logo, and Welcome to the Human Network are trademarks of Cisco Systems, Inc.; Changing the Way We Work, Live, Play, and Learn is
a service mark of Cisco Systems, Inc.; and Access Registrar, Aironet, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, Cisco, the Cisco
Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity,
Enterprise/Solver, EtherChannel, EtherFast, EtherSwitch, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink, Internet Quotient, IOS,
iPhone, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, iQuick Study, LightStream, Linksys, MeetingPlace, MGX, Networkers,
Networking Academy, Network Registrar, PIX, ProConnect, ScriptShare, SMARTnet, StackWise, The Fastest Way to Increase Your Internet Quotient,
and TransPath are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a
partnership relationship between Cisco and any other company. (0711R)

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and
figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and

Cisco IOS Release 12.4T


14
Implementing Multicast Service Reflection
Feature Information for Multicast Service Reflection

coincidental.

© 2006 Cisco Systems, Inc. All rights reserved.

Cisco IOS Release 12.4T


15
Implementing Multicast Service Reflection
Feature Information for Multicast Service Reflection

Cisco IOS Release 12.4T


16

You might also like