MPLS10S08-MPLS VPN Configuration On IOS Platforms
MPLS10S08-MPLS VPN Configuration On IOS Platforms
MPLS10S08-MPLS VPN Configuration On IOS Platforms
MPLS VPN
Configuration on IOS
Platforms
© 2001, Cisco Systems, Inc.
Objectives
VPN A
• There are two backbones with
10.1.1.0/24
overlapping addresses.
RI MPLS VPN Backbone
P
CE-VPN-A
• RIP routes entered in the VRF routing table are redistributed into BGP
for further propagation into the MPLS VPN backbone.
• Redistribution between RIP and BGP has to be configured for proper
MPLS VPN operation.
© 2001, Cisco Systems, Inc. MPLS v1.0—8-12
Routing Contexts, VRF, and
MP-BGP Interaction: 5/9
RIP Routing Process VRF-A Routing Table BGP Routing Process
Instance for VRF-A
CE-RIP-A Multiprotocol
BGP
Instance for VRF-B VRF-B Routing Table
CE-RIP-B
• MP-IBGP routes imported into a VRF are redistributed into the instance
of RIP configured for that VRF.
• Redistribution between BGP and RIP has to be configured
for end-
to-end RIP routing between CE routers.
© 2001, Cisco Systems, Inc. MPLS v1.0—8-16
Routing Contexts, VRF, and
MP-BGP Interaction: 9/9
RIP Routing Process VRF-A Routing Table BGP Routing Process
Instance for VRF-A Backbone
CE-RIP-A Multiprotocol
BGP
Instance for VRF-B VRF-B Routing Table
CE-RIP-B
• Routes redistributed from BGP into a VRF instance of RIP are sent to
RIP-speaking CE routers.
ip cef
!
interface serial 0/0
ip vrf forwarding Customer_ABC
ip address 10.0.0.1 255.255.255.252
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
CE-RIP-B1 CE-RIP-B2
router(config-router)#
address-family vpnv4
router(config-router-af)#
neighbor IP-address next-hop-self
router(config-router)#
no bgp default route-target filter Cisco IOS Release 12.1(4)T
Usage guidelines:
• Extended BGP communities attached to
VPNv4 prefixes have to be exchanged
between MP-BGP neighbors for proper MPLS
VPN operation.
• To propagate standard BGP communities
© 2001, Cisco Systems, Inc. MPLS v1.0—8-41
Sample VPN Network
MP-IBGP Configuration
MPLS VPN Backbone
CE-RIP-A1 CE-RIP-A2
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
interface loopback 0
CE-RIP-B1 ip address 172.16.1.1 255.255.255.255 CE-RIP-B2
!
router bgp 115
neighbor 172.16.1.2 remote-as 115
neighbor 172.16.1.2 update-source loopback 0
!
address-family vpnv4
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 next-hop-self
neighbor 172.16.1.2 send-community both
© 2001, Cisco Systems, Inc. MPLS v1.0—8-42
Configuring MP-BGP
Disabling IPv4 Route Exchange
router(config-router)#
no bgp default ipv4 unicast
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
CE-RIP-B1 CE-RIP-B2
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
router#
show ip vrf interfaces
Router#show ip vrf
Name Default RD Interfaces
SiteA2 103:30 Serial1/0.20
SiteB 103:11 Serial1/0.100
SiteX 103:20 Ethernet0/0
Router#
router#
show ip bgp vpnv4 vrf name …
… rest deleted …
… rest deleted …
router#
show ip bgp neighbor
... Continued
... Continued
router#
trace vrf name …
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
P-Network
CE-Spoke CE-Spoke
PE-1 PE-2
CE-Spoke CE-Spoke
Selective import:
• Specify additional criteria for importing
routes into the VRF.
Selective export:
• Specify additional RTs attached to
exported routes.
VRF route limit:
• Specify the maximum number of routes
in a VRF to prevent memory exhaustion
on PE routers or denial-of-service
attacks.
© 2001, Cisco Systems, Inc. MPLS v1.0—8-106
Selective VRF Import
router(config-vrf)#
import map route-map-name
• This command attaches a route map to VRF
import process.
• A route is imported into the VRF only if at
least one RT attached to route matches one
RT configured in the VRF and the route is
accepted by the route map.
CE-BGP-A1
PE-Site-X
ip vrf Site_A
rd 115:317
export map RTMAP
route-target both 115:317
!
access-list 10 permit 192.168.30.0 0.0.0.0
!
route-map RTMAP permit 10
match ip address 10
set extcommunity rt 115:273 additive
© 2001, Cisco Systems, Inc. MPLS v1.0—8-112
Limiting the Number of
Routes in a VRF
Service Providers offering MPLS VPN
services are at risk of denial-of-service
attacks similar to those aimed at
Internet service providers (ISPs) offering
BGP connectivity.
• Any customer can generate any number of
routes, using resources in the PE routers.
Therefore, resources used by a single
customer have to be limited.
Cisco IOS software offers two solutions.
• It can limit the number of routes received
from a BGP neighbor.
• It can limit the total number of routes in a
© 2001, Cisco Systems, Inc. MPLS v1.0—8-113
Limiting the Number of Prefixes
Received from a BGP Neighbor
router(config-
router-af)#
neighbor ip-address maximum-prefix maximum
[threshold] [warning-only]
router(config-vrf)#
maximum route number { warning-percent | warn-only}
• This command configures the maximum
number of routes accepted into a VRF:
• Number is the route limit for the VRF.
• Warning-percent is the percentage value
over
which a warning message is sent to syslog.
• With warn-only the PE continues accepting
routes after the configured limit.
• Syslog messages generated by this
command are rate-limited.
Site A AS 115
AS 213
VPN-IPv4 VPN-IPv4
update: update:
IPv4 update: IPv4 update: RD:192.168.60.0/ RD:192.168.70.0/
192.168.0.5/ 192.168.50.0/ 24 24
CE-BGP-A1
32 24 RT=100:1 RT=100:1
PE-Site-X PE-Site-Y
IPv4 update:
192.168.55.0/
24 ip vrf Site_A
rd 115:317
route-target both 115:317
maximum-routes 4 75
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
i 10.1.0.0/16 10.1.0.0/16 115
10.1.0.0/16 213 213 213
router(config-router-af)#
neighbor ip-address as-override
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
i 10.1.0.0/16 10.1.0.0/16 115
10.1.0.0/16 213 213 115
CE-BGP-A1 CE-BGP-A2
PE-Site-X PE-Site-Y
10.1.0.0/16 213 i 10.1.0.0/16 213 10.1.0.0/16 115 115
213 213 115
CE-BGP-A1
VPN-A VPN-B
VPN-A VPN-B
router(config-router)#
neighbor ip-address allowas-in limit
router(config-router-af)#
neighbor ip-address route-map name in
router(config-if)#
ip vrf sitemap route-map-name