Annotation of pkgsrc/www/webkit-gtk/Makefile, revision 1.263
1.263 ! wiz 1: # $NetBSD: Makefile,v 1.262 2024/08/25 06:19:18 wiz Exp $
1.4 snj 2:
1.237 leot 3: DISTNAME= webkitgtk-2.36.8
1.62 drochner 4: PKGNAME= ${DISTNAME:S/webkitgtk/webkit-gtk/}
1.263 ! wiz 5: PKGREVISION= 16
1.98 leot 6: CATEGORIES= www
1.127 wiz 7: MASTER_SITES= https://www.webkitgtk.org/releases/
1.98 leot 8: EXTRACT_SUFX= .tar.xz
1.1 ahoka 9:
1.98 leot 10: MAINTAINER= [email protected]
1.127 wiz 11: HOMEPAGE= https://www.webkitgtk.org/
1.92 wiz 12: COMMENT= GTK port of the WebKit browser engine
1.98 leot 13: LICENSE= 2-clause-bsd AND gnu-lgpl-v2
1.42 drochner 14:
1.92 wiz 15: # shm_open(3) and shm_unlink(3) appeared in NetBSD 7.0
1.145 leot 16: NOT_FOR_PLATFORM= NetBSD-[1-6].*-*
1.87 joerg 17:
1.145 leot 18: TOOL_DEPENDS+= gettext-tools>=0.18:../../devel/gettext-tools
1.98 leot 19:
1.219 gutterid 20: USE_LANGUAGES= c c++17
1.226 leot 21: USE_TOOLS+= automake bash bison flex gdbus-codegen gmake perl pkg-config msgfmt
1.98 leot 22:
1.150 jperkin 23: # Enabling -gdwarf-2 hits GNU ar limits on file size.
24: CTF_SUPPORTED= no
25:
1.219 gutterid 26: # GCC >= 8 is required, it no longer builds with lower versions.
27: GCC_REQD+= 8
28:
1.98 leot 29: PKGCONFIG_OVERRIDE+= Source/JavaScriptCore/javascriptcoregtk.pc.in
1.137 wiz 30: PKGCONFIG_OVERRIDE+= Source/WebKit/gtk/webkit2gtk-web-extension.pc.in
31: PKGCONFIG_OVERRIDE+= Source/WebKit/gtk/webkit2gtk.pc.in
1.98 leot 32:
1.262 wiz 33: CMAKE_CONFIGURE_ARGS+= -DCMAKE_BUILD_TYPE=Release
34: CMAKE_CONFIGURE_ARGS+= -DPORT=GTK
35: CMAKE_CONFIGURE_ARGS+= -DENABLE_X11_TARGET=ON
36: CMAKE_CONFIGURE_ARGS+= -DENABLE_MINIBROWSER=ON
37: CMAKE_CONFIGURE_ARGS+= -DENABLE_GAMEPAD=OFF
38: CMAKE_CONFIGURE_ARGS+= -DENABLE_GEOLOCATION=OFF
39: CMAKE_CONFIGURE_ARGS+= -DENABLE_INTROSPECTION=ON
40: CMAKE_CONFIGURE_ARGS+= -DENABLE_JOURNALD_LOG=OFF
41: CMAKE_CONFIGURE_ARGS+= -DENABLE_BUBBLEWRAP_SANDBOX=OFF
42: CMAKE_CONFIGURE_ARGS+= -DUSE_GSTREAMER_GL=OFF
43: CMAKE_CONFIGURE_ARGS+= -DUSE_LIBHYPHEN=OFF
44: CMAKE_CONFIGURE_ARGS+= -DUSE_OPENJPEG=OFF
45: CMAKE_CONFIGURE_ARGS+= -DUSE_SOUP2=ON
1.98 leot 46:
1.249 gutterid 47: .include "../../mk/bsd.prefs.mk"
1.256 wiz 48: .if ${MACHINE_PLATFORM:MNetBSD-*-aarch64*}
1.262 wiz 49: CMAKE_CONFIGURE_ARGS+= -DAVOID_INT128=ON
1.239 nia 50: .endif
51:
1.171 leot 52: REPLACE_PERL+= Source/JavaScriptCore/Scripts/*.pl
1.136 wiz 53: REPLACE_PERL+= Source/JavaScriptCore/create_hash_table
1.171 leot 54: REPLACE_PERL+= Source/WebCore/Scripts/*.pl
1.136 wiz 55: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pl
1.145 leot 56: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pm
1.136 wiz 57: REPLACE_PERL+= Source/WebCore/css/*.pl
58: REPLACE_PERL+= Source/WebCore/dom/*.pl
59: REPLACE_PERL+= Source/WebCore/make-hash-tools.pl
1.171 leot 60: REPLACE_PERL+= Source/WebInspectorUI/Scripts/*.pl
61: REPLACE_PERL+= Source/WebKit/Scripts/*.pl
62: REPLACE_PERL+= Source/cmake/tools/scripts/*.pl
1.136 wiz 63:
1.145 leot 64: REPLACE_PYTHON+= Source/JavaScriptCore/Scripts/*.py
1.171 leot 65: REPLACE_PYTHON+= Source/JavaScriptCore/Scripts/wkbuiltins/*.py
1.145 leot 66: REPLACE_PYTHON+= Source/JavaScriptCore/inspector/scripts/*.py
67: REPLACE_PYTHON+= Source/JavaScriptCore/inspector/scripts/codegen/*.py
68: REPLACE_PYTHON+= Source/JavaScriptCore/wasm/*.py
1.171 leot 69: REPLACE_PYTHON+= Source/JavaScriptCore/yarr/*.py
1.136 wiz 70: REPLACE_PYTHON+= Source/JavaScriptCore/yarr/create_regex_tables
71: REPLACE_PYTHON+= Source/JavaScriptCore/yarr/generateYarrCanonicalizeUnicode
1.171 leot 72: REPLACE_PYTHON+= Source/ThirdParty/ANGLE/src/compiler/translator/*.py
73: REPLACE_PYTHON+= Source/ThirdParty/ANGLE/src/libANGLE/*.py
1.145 leot 74: REPLACE_PYTHON+= Source/ThirdParty/gtest/scripts/*.py
75: REPLACE_PYTHON+= Source/ThirdParty/gtest/test/*.py
76: REPLACE_PYTHON+= Source/ThirdParty/gtest/xcode/Scripts/*.py
77: REPLACE_PYTHON+= Source/WebCore/css/*.py
1.136 wiz 78: REPLACE_PYTHON+= Source/WebCore/html/parser/create-html-entity-table
79: REPLACE_PYTHON+= Source/WebCore/platform/network/create-http-header-name-table
1.145 leot 80: REPLACE_PYTHON+= Source/WebKit/Scripts/*.py
81: REPLACE_PYTHON+= Tools/glib/*.py
1.171 leot 82: REPLACE_PYTHON+= Tools/gtkdoc/generate-gtkdoc
83:
1.187 rillig 84: REPLACE_BASH+= Source/JavaScriptCore/postprocess-headers.sh
85: REPLACE_BASH+= Source/ThirdParty/ANGLE/adjust-angle-include-paths-rule
1.171 leot 86: REPLACE_BASH+= Source/ThirdParty/gtest/xcode/Samples/FrameworkSample/runtests.sh
87: REPLACE_BASH+= Source/ThirdParty/gtest/xcode/Scripts/runtests.sh
1.187 rillig 88: REPLACE_BASH+= Source/WebKit/Scripts/copy-webcontent-resources-to-private-headers.sh
89: REPLACE_BASH+= Source/WebKit/Scripts/generate-https-upgrade-database.sh
1.171 leot 90: REPLACE_BASH+= Source/WebKit/Scripts/process-entitlements.sh
91: REPLACE_BASH+= Tools/gtk/install-dependencies
92:
93: REPLACE_RUBY+= Source/JavaScriptCore/b3/air/*.rb
94: REPLACE_RUBY+= Source/JavaScriptCore/offlineasm/*.rb
95: REPLACE_RUBY+= Source/WebCore/Scripts/*.rb
96: REPLACE_RUBY+= Source/WebCore/domjit/*.rb
97: REPLACE_RUBY+= Source/WebInspectorUI/Scripts/*.rb
98: REPLACE_RUBY+= Source/WebKit/Scripts/*.rb
1.136 wiz 99:
100: SUBST_CLASSES+= python
101: SUBST_FILES.python+= Source/WebInspectorUI/Scripts/copy-user-interface-resources.pl
1.226 leot 102: SUBST_SED.python+= -e 's,"python3","${PYTHONBIN}",'
1.136 wiz 103: SUBST_STAGE.python= pre-configure
104: SUBST_MESSAGE.python= Fixing path to python binary.
1.98 leot 105:
106: .include "../../lang/ruby/rubyversion.mk"
1.171 leot 107: .include "../../lang/ruby/replace.mk"
1.145 leot 108: TOOL_DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
1.262 wiz 109: CMAKE_CONFIGURE_ARGS+= -DRUBY_EXECUTABLE=${RUBY}
1.98 leot 110:
111: PYTHON_FOR_BUILD_ONLY= yes
1.251 wiz 112: .include "../../lang/python/batteries-included.mk"
1.98 leot 113: .include "../../lang/python/application.mk"
1.262 wiz 114: CMAKE_CONFIGURE_ARGS+= -DPYTHON_EXECUTABLE=${PYTHONBIN}
1.98 leot 115:
116: CXXFLAGS.SunOS+= -fpermissive
117:
118: .include "../../mk/compiler.mk"
119: .if !empty(PKGSRC_COMPILER:Mclang)
1.126 jperkin 120: CXXFLAGS+= -Wno-c++11-narrowing
1.98 leot 121: .endif
122:
1.138 jperkin 123: # This does not disable optimisations, merely avoids #error if there are none.
124: CFLAGS+= -DRELEASE_WITHOUT_OPTIMIZATIONS
125:
1.166 leot 126: # Needed for JavaScript JIT
1.145 leot 127: NOT_PAX_MPROTECT_SAFE+= libexec/webkit2gtk-4.0/WebKitWebProcess
128: NOT_PAX_MPROTECT_SAFE+= libexec/webkit2gtk-4.0/jsc
129:
1.235 tnn 130: CHECK_PORTABILITY_SKIP+= Source/JavaScriptCore/Scripts/create-symlink-to-altroot.sh
131: CHECK_PORTABILITY_SKIP+= Source/WebCore/Scripts/create-symlink-to-altroot.sh
132: CHECK_PORTABILITY_SKIP+= Source/WebKit/Scripts/create-symlink-to-altroot.sh
1.225 tnn 133: CHECK_PORTABILITY_SKIP+= Source/WebKit/Scripts/generate-feature-flags-plist.sh
134:
1.98 leot 135: .include "options.mk"
136:
1.243 wiz 137: .include "../../devel/cmake/build.mk"
1.98 leot 138: BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
139: .include "../../devel/glib2/buildlink3.mk"
140: .include "../../devel/zlib/buildlink3.mk"
141: .include "../../databases/sqlite3/buildlink3.mk"
1.228 wiz 142: BUILDLINK_API_DEPENDS.gobject-introspection+= gobject-introspection>=0.9.5
143: BUILDLINK_DEPMETHOD.gobject-introspection+= build
144: .include "../../devel/gobject-introspection/buildlink3.mk"
1.98 leot 145: .include "../../devel/gperf/buildlink3.mk"
146: .include "../../devel/pango/buildlink3.mk"
1.197 nia 147: .include "../../fonts/harfbuzz-icu/buildlink3.mk"
1.136 wiz 148: .include "../../fonts/woff2/buildlink3.mk"
1.254 wiz 149: BUILDLINK_API_DEPENDS.cairo+= cairo>=1.18
150: .include "../../graphics/cairo/buildlink3.mk"
1.98 leot 151: .include "../../graphics/freetype2/buildlink3.mk"
152: .include "../../graphics/libwebp/buildlink3.mk"
153: .include "../../mk/jpeg.buildlink3.mk"
1.212 leot 154: .include "../../graphics/lcms2/buildlink3.mk"
1.98 leot 155: BUILDLINK_API_DEPENDS.png+= png>=1.5.1beta08
156: .include "../../graphics/png/buildlink3.mk"
157: .include "../../multimedia/gstreamer1/buildlink3.mk"
158: BUILDLINK_API_DEPENDS.gst-plugins1-base+= gst-plugins1-base>=1.0.3
159: .include "../../multimedia/gst-plugins1-base/buildlink3.mk"
1.218 leot 160: .include "../../multimedia/gst-plugins1-good/buildlink3.mk"
1.98 leot 161: .include "../../net/libsoup/buildlink3.mk"
162: .include "../../security/libsecret/buildlink3.mk"
1.168 leot 163: .include "../../security/libtasn1/buildlink3.mk"
1.98 leot 164: .include "../../sysutils/libnotify/buildlink3.mk"
165: .include "../../textproc/icu/buildlink3.mk"
166: .include "../../textproc/libxslt/buildlink3.mk"
1.92 wiz 167: .include "../../x11/gtk3/buildlink3.mk"
1.98 leot 168: .include "../../x11/libXdamage/buildlink3.mk"
169: .include "../../x11/libXt/buildlink3.mk"
170: .include "../../mk/pthread.buildlink3.mk"
1.200 nia 171: .include "../../mk/atomic64.mk"
1.1 ahoka 172: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>