Annotation of pkgsrc/www/webkit-gtk/Makefile, revision 1.226

1.226   ! leot        1: # $NetBSD: Makefile,v 1.223 2022/02/17 16:55:16 leot Exp $
1.4       snj         2: 
1.226   ! leot        3: DISTNAME=      webkitgtk-2.36.3
1.62      drochner    4: PKGNAME=       ${DISTNAME:S/webkitgtk/webkit-gtk/}
1.98      leot        5: CATEGORIES=    www
1.127     wiz         6: MASTER_SITES=  https://www.webkitgtk.org/releases/
1.98      leot        7: EXTRACT_SUFX=  .tar.xz
1.1       ahoka       8: 
1.98      leot        9: MAINTAINER=    [email protected]
1.127     wiz        10: HOMEPAGE=      https://www.webkitgtk.org/
1.92      wiz        11: COMMENT=       GTK port of the WebKit browser engine
1.98      leot       12: LICENSE=       2-clause-bsd AND gnu-lgpl-v2
1.42      drochner   13: 
1.92      wiz        14: # shm_open(3) and shm_unlink(3) appeared in NetBSD 7.0
1.145     leot       15: NOT_FOR_PLATFORM=      NetBSD-[1-6].*-*
1.87      joerg      16: 
1.145     leot       17: TOOL_DEPENDS+= gettext-tools>=0.18:../../devel/gettext-tools
1.173     wiz        18: TOOL_DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
1.98      leot       19: 
                     20: USE_CMAKE=     yes
1.219     gutterid   21: USE_LANGUAGES= c c++17
1.226   ! leot       22: USE_TOOLS+=    automake bash bison flex gdbus-codegen gmake perl pkg-config msgfmt
1.98      leot       23: 
1.150     jperkin    24: # Enabling -gdwarf-2 hits GNU ar limits on file size.
                     25: CTF_SUPPORTED= no
                     26: 
1.219     gutterid   27: # GCC >= 8 is required, it no longer builds with lower versions.
                     28: GCC_REQD+=             8
1.156     leot       29: USE_GCC_RUNTIME=       yes
1.98      leot       30: 
1.219     gutterid   31: .include "../../mk/bsd.prefs.mk"
                     32: 
                     33: # This package will link against libstdc++.so from the pkgsrc GCC when the
                     34: # base OS GCC doesn't meet the minimum requirement. Thus we do this so the
                     35: # appropriate gcc-libs package will be captured as a dependency, otherwise
                     36: # binary packages will be broken. See also PR pkg/56604.
                     37: .if ${OPSYS} == "NetBSD" && ${OPSYS_VERSION} < 099915
                     38: USE_PKGSRC_GCC=                yes
                     39: USE_PKGSRC_GCC_RUNTIME=        yes
                     40: .endif
                     41: 
1.98      leot       42: PKGCONFIG_OVERRIDE+=   Source/JavaScriptCore/javascriptcoregtk.pc.in
1.137     wiz        43: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk-web-extension.pc.in
                     44: PKGCONFIG_OVERRIDE+=   Source/WebKit/gtk/webkit2gtk.pc.in
1.98      leot       45: 
1.132     wiz        46: CMAKE_ARGS+=           -DCMAKE_BUILD_TYPE=Release
1.98      leot       47: CMAKE_ARGS+=           -DPORT=GTK
                     48: CMAKE_ARGS+=           -DENABLE_X11_TARGET=ON
                     49: CMAKE_ARGS+=           -DENABLE_MINIBROWSER=ON
1.203     leot       50: CMAKE_ARGS+=           -DENABLE_GAMEPAD=OFF
1.98      leot       51: CMAKE_ARGS+=           -DENABLE_GEOLOCATION=OFF
1.226   ! leot       52: CMAKE_ARGS+=           -DENABLE_JOURNALD_LOG=OFF
1.183     tnn        53: CMAKE_ARGS+=           -DENABLE_BUBBLEWRAP_SANDBOX=OFF
1.132     wiz        54: CMAKE_ARGS+=           -DUSE_GSTREAMER_GL=OFF
1.98      leot       55: CMAKE_ARGS+=           -DUSE_LIBHYPHEN=OFF
1.159     leot       56: CMAKE_ARGS+=           -DUSE_OPENJPEG=OFF
1.212     leot       57: CMAKE_ARGS+=           -DUSE_SOUP2=ON
1.98      leot       58: 
1.171     leot       59: REPLACE_PERL+= Source/JavaScriptCore/Scripts/*.pl
1.136     wiz        60: REPLACE_PERL+= Source/JavaScriptCore/create_hash_table
1.171     leot       61: REPLACE_PERL+= Source/WebCore/Scripts/*.pl
1.136     wiz        62: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pl
1.145     leot       63: REPLACE_PERL+= Source/WebCore/bindings/scripts/*.pm
1.136     wiz        64: REPLACE_PERL+= Source/WebCore/css/*.pl
                     65: REPLACE_PERL+= Source/WebCore/dom/*.pl
                     66: REPLACE_PERL+= Source/WebCore/make-hash-tools.pl
1.171     leot       67: REPLACE_PERL+= Source/WebInspectorUI/Scripts/*.pl
                     68: REPLACE_PERL+= Source/WebKit/Scripts/*.pl
                     69: REPLACE_PERL+= Source/cmake/tools/scripts/*.pl
1.136     wiz        70: 
1.145     leot       71: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/*.py
1.171     leot       72: REPLACE_PYTHON+=       Source/JavaScriptCore/Scripts/wkbuiltins/*.py
1.145     leot       73: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/*.py
                     74: REPLACE_PYTHON+=       Source/JavaScriptCore/inspector/scripts/codegen/*.py
                     75: REPLACE_PYTHON+=       Source/JavaScriptCore/wasm/*.py
1.171     leot       76: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/*.py
1.136     wiz        77: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/create_regex_tables
                     78: REPLACE_PYTHON+=       Source/JavaScriptCore/yarr/generateYarrCanonicalizeUnicode
1.171     leot       79: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/compiler/translator/*.py
                     80: REPLACE_PYTHON+=       Source/ThirdParty/ANGLE/src/libANGLE/*.py
1.145     leot       81: REPLACE_PYTHON+=       Source/ThirdParty/gtest/scripts/*.py
                     82: REPLACE_PYTHON+=       Source/ThirdParty/gtest/test/*.py
                     83: REPLACE_PYTHON+=       Source/ThirdParty/gtest/xcode/Scripts/*.py
                     84: REPLACE_PYTHON+=       Source/WebCore/css/*.py
1.136     wiz        85: REPLACE_PYTHON+=       Source/WebCore/html/parser/create-html-entity-table
                     86: REPLACE_PYTHON+=       Source/WebCore/platform/network/create-http-header-name-table
1.145     leot       87: REPLACE_PYTHON+=       Source/WebKit/Scripts/*.py
                     88: REPLACE_PYTHON+=       Tools/glib/*.py
1.171     leot       89: REPLACE_PYTHON+=       Tools/gtkdoc/generate-gtkdoc
                     90: 
1.187     rillig     91: REPLACE_BASH+=         Source/JavaScriptCore/postprocess-headers.sh
                     92: REPLACE_BASH+=         Source/ThirdParty/ANGLE/adjust-angle-include-paths-rule
1.171     leot       93: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Samples/FrameworkSample/runtests.sh
                     94: REPLACE_BASH+=         Source/ThirdParty/gtest/xcode/Scripts/runtests.sh
1.187     rillig     95: REPLACE_BASH+=         Source/WebKit/Scripts/copy-webcontent-resources-to-private-headers.sh
                     96: REPLACE_BASH+=         Source/WebKit/Scripts/generate-https-upgrade-database.sh
1.171     leot       97: REPLACE_BASH+=         Source/WebKit/Scripts/process-entitlements.sh
                     98: REPLACE_BASH+=         Tools/gtk/install-dependencies
                     99: 
                    100: REPLACE_RUBY+=         Source/JavaScriptCore/b3/air/*.rb
                    101: REPLACE_RUBY+=         Source/JavaScriptCore/offlineasm/*.rb
                    102: REPLACE_RUBY+=         Source/WebCore/Scripts/*.rb
                    103: REPLACE_RUBY+=         Source/WebCore/domjit/*.rb
                    104: REPLACE_RUBY+=         Source/WebInspectorUI/Scripts/*.rb
                    105: REPLACE_RUBY+=         Source/WebKit/Scripts/*.rb
1.136     wiz       106: 
                    107: SUBST_CLASSES+=                python
                    108: SUBST_FILES.python+=   Source/WebInspectorUI/Scripts/copy-user-interface-resources.pl
1.226   ! leot      109: SUBST_SED.python+=     -e 's,"python3","${PYTHONBIN}",'
1.136     wiz       110: SUBST_STAGE.python=    pre-configure
                    111: SUBST_MESSAGE.python=  Fixing path to python binary.
1.98      leot      112: 
                    113: .include "../../lang/ruby/rubyversion.mk"
1.171     leot      114: .include "../../lang/ruby/replace.mk"
1.145     leot      115: TOOL_DEPENDS+= ${RUBY_BASE}>=${RUBY_VERSION}:${RUBY_SRCDIR}
1.98      leot      116: CMAKE_ARGS+=   -DRUBY_EXECUTABLE=${RUBY}
                    117: 
                    118: PYTHON_FOR_BUILD_ONLY= yes
                    119: .include "../../lang/python/application.mk"
                    120: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PYTHONBIN}
                    121: 
                    122: CXXFLAGS.SunOS+=       -fpermissive
                    123: 
                    124: .include "../../mk/compiler.mk"
                    125: .if !empty(PKGSRC_COMPILER:Mclang)
1.126     jperkin   126: CXXFLAGS+=     -Wno-c++11-narrowing
1.98      leot      127: .endif
                    128: 
1.138     jperkin   129: # This does not disable optimisations, merely avoids #error if there are none.
                    130: CFLAGS+=       -DRELEASE_WITHOUT_OPTIMIZATIONS
                    131: 
1.166     leot      132: # Needed for JavaScript JIT
1.145     leot      133: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/WebKitWebProcess
                    134: NOT_PAX_MPROTECT_SAFE+=        libexec/webkit2gtk-4.0/jsc
                    135: 
1.225     tnn       136: CHECK_PORTABILITY_SKIP+=       Source/WebKit/Scripts/generate-feature-flags-plist.sh
                    137: 
1.98      leot      138: .include "options.mk"
                    139: 
                    140: BUILDLINK_API_DEPENDS.glib2+= glib2>=2.32.1
                    141: .include "../../devel/glib2/buildlink3.mk"
                    142: .include "../../devel/zlib/buildlink3.mk"
                    143: .include "../../databases/sqlite3/buildlink3.mk"
                    144: .include "../../devel/gperf/buildlink3.mk"
                    145: .include "../../devel/pango/buildlink3.mk"
1.197     nia       146: .include "../../fonts/harfbuzz-icu/buildlink3.mk"
1.136     wiz       147: .include "../../fonts/woff2/buildlink3.mk"
1.98      leot      148: .include "../../graphics/cairo-gobject/buildlink3.mk"
                    149: .include "../../graphics/freetype2/buildlink3.mk"
                    150: .include "../../graphics/libwebp/buildlink3.mk"
                    151: .include "../../mk/jpeg.buildlink3.mk"
1.212     leot      152: .include "../../graphics/lcms2/buildlink3.mk"
1.98      leot      153: BUILDLINK_API_DEPENDS.png+= png>=1.5.1beta08
                    154: .include "../../graphics/png/buildlink3.mk"
                    155: .include "../../multimedia/gstreamer1/buildlink3.mk"
                    156: BUILDLINK_API_DEPENDS.gst-plugins1-base+=      gst-plugins1-base>=1.0.3
                    157: .include "../../multimedia/gst-plugins1-base/buildlink3.mk"
1.218     leot      158: .include "../../multimedia/gst-plugins1-good/buildlink3.mk"
1.98      leot      159: .include "../../net/libsoup/buildlink3.mk"
                    160: .include "../../security/libsecret/buildlink3.mk"
1.168     leot      161: .include "../../security/libtasn1/buildlink3.mk"
1.98      leot      162: .include "../../sysutils/libnotify/buildlink3.mk"
                    163: .include "../../textproc/icu/buildlink3.mk"
                    164: .include "../../textproc/libxslt/buildlink3.mk"
1.92      wiz       165: .include "../../x11/gtk3/buildlink3.mk"
1.98      leot      166: .include "../../x11/libXdamage/buildlink3.mk"
                    167: .include "../../x11/libXt/buildlink3.mk"
                    168: .include "../../mk/pthread.buildlink3.mk"
1.200     nia       169: .include "../../mk/atomic64.mk"
1.1       ahoka     170: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>