Annotation of pkgsrc/textproc/fop/Makefile, revision 1.9
1.9 ! agc 1: # $NetBSD: Makefile,v 1.8 2001/03/14 01:43:40 jwise Exp $
1.1 jwise 2: #
3: # Note: we currently use the pre-built (-bin) distribution of FOP,
4: # because although FOP runs fine under JDK 1.1, JDK 1.2 or greater is
5: # required to build it.
1.7 jwise 6: #
7: # Note: please do NOT update this package to a more recent version of FOP --
8: # this is the most recent version which works with cocoon. If you need a
9: # newer version, let me know, and I will import the latest version as
10: # fop-current -- [email protected]
11: #
1.1 jwise 12:
1.7 jwise 13: DISTNAME= fop-0_15_0-forBeginners
14: PKGNAME= fop-0.15.0
1.9 ! agc 15: WRKSRC= ${WRKDIR}
1.1 jwise 16: CATEGORIES= textproc www
1.7 jwise 17: MASTER_SITES= http://xml.apache.org/dist/fop/recent/
18: EXTRACT_SUFX= .zip
1.1 jwise 19:
20: MAINTAINER= [email protected]
21: HOMEPAGE= http://xml.apache.org/fop/
1.5 wiz 22: COMMENT= the Apache Project's XSL Formatting Objects implementation
1.1 jwise 23:
24: USE_JAVA= yes
25: NO_PATCH=
26: NO_CONFIGURE=
27: NO_BUILD=
28:
1.4 jwise 29: post-extract:
1.7 jwise 30: ${FIND} -d ${WRKSRC}/docs -name cvs -exec ${RM} -r '{}' \;
1.1 jwise 31:
32: do-install:
1.6 hubertf 33: ${INSTALL_DATA_DIR} ${PREFIX}/lib/java
1.7 jwise 34: ${INSTALL_DATA} ${WRKSRC}/build/fop.jar ${PREFIX}/lib/java/fop.jar
1.8 jwise 35: ${INSTALL_DATA} ${WRKSRC}/lib/w3c.jar ${PREFIX}/lib/java/fop-w3c.jar
1.7 jwise 36: ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/java/fop
37: cd ${WRKSRC}/docs; ${GTAR} pcf - . | ( cd ${PREFIX}/share/doc/java/fop ; ${GTAR} pvxf - )
1.3 jwise 38: ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/doc/java/fop
1.1 jwise 39:
40: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>