Annotation of pkgsrc/mail/postfix/Makefile, revision 1.33

1.33    ! itojun      1: # $NetBSD: Makefile,v 1.32 2001/04/02 10:48:58 itojun Exp $
1.1       christos    2: 
1.32      itojun      3: DISTNAME=      postfix-20010228-pl01
                      4: PKGNAME=       postfix-20010228-pl1
1.1       christos    5: CATEGORIES=    mail
                      6: MASTER_SITES=  ftp://postfix.cloud9.net/official/
                      7: 
1.33    ! itojun      8: PATCHFILES=    postfix-20010228release-v6-20010408a.diff.gz \
1.28      hubertf     9:                postfix-20010228release-ercpt.diff
                     10: PATCH_SITES=   ftp://ftp.kame.net/pub/kame/misc/ \
                     11:                ftp://ftp.gw.com/pub/people/kim/patches/
                     12: PATCH_DIST_STRIP+=     -p1
1.19      kim        13: 
1.28      hubertf    14: MAINTAINER=    [email protected]
1.5       tron       15: HOMEPAGE=      http://www.postfix.org/
1.26      wiz        16: COMMENT=       postfix smtp server and tools
1.1       christos   17: 
1.19      kim        18: DIST_SUBDIR=   postfix
1.1       christos   19: 
1.18      bad        20: POSTFIX_SPOOL= /var/spool/postfix
1.19      kim        21: 
1.28      hubertf    22: .include "../../mk/bsd.prefs.mk"
                     23: # automagically determines IPv6 support
                     24: BUILD_DEFS+=   USE_INET6
                     25: 
1.19      kim        26: .if defined(POSTFIX_PCRE) && ${POSTFIX_PCRE} == YES
                     27: DEPENDS+=      pcre-2.08:../../devel/pcre
                     28: CFLAGS+=       -DHAS_PCRE -I${LOCALBASE}/include
1.28      hubertf    29: AUXLIBS=       -L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -lpcre
1.19      kim        30: MAKE_ENV+=     AUXLIBS="${AUXLIBS}"
                     31: .endif
                     32: 
1.28      hubertf    33: BUILD_DEFS+=   POSTFIX_PCRE
1.19      kim        34: 
                     35: PLIST_SRC=     ${PKGDIR}/PLIST
1.18      bad        36: 
1.28      hubertf    37: ALL_TARGET=    #empty
1.1       christos   38: 
                     39: pre-configure:
                     40:        ${CP} ${WRKSRC}/conf/main.cf ${WRKSRC}/conf/main.cf.dist
1.28      hubertf    41:        ${CP} ${WRKSRC}/src/util/sys_defs.h ${WRKSRC}/src/util/sys_defs.h.dist
                     42:        ${CP} ${WRKSRC}/INSTALL.sh ${WRKSRC}/INSTALL.sh.dist
1.8       christos   43:        ${SED} -e 's:__PREFIX:'${PREFIX}':g' \
                     44:            < ${WRKSRC}/conf/main.cf.dist \
1.1       christos   45:            > ${WRKSRC}/conf/main.cf
1.8       christos   46:        ${SED} -e 's:__PREFIX:'${PREFIX}':g' \
1.28      hubertf    47:            < ${WRKSRC}/src/util/sys_defs.h.dist \
                     48:            > ${WRKSRC}/src/util/sys_defs.h
                     49:        ${SED} -e 's:__PREFIX:'${PREFIX}':g' \
                     50:            < ${WRKSRC}/INSTALL.sh.dist \
                     51:            > ${WRKSRC}/INSTALL.sh
                     52: 
                     53: do-configure:
                     54:        (cd ${WRKSRC}; ${MAKE} makefiles)
1.1       christos   55: 
1.5       tron       56: post-build:
                     57:        ${SED} -e 's#@@PREFIX@@#${PREFIX}#g' \
1.28      hubertf    58:            <${FILESDIR}/mailer.conf >${WRKDIR}/mailer.conf.postfix
1.5       tron       59: 
1.1       christos   60: pre-install:
1.27      hubertf    61:        ${INSTALL_DATA_DIR} /etc/postfix ${PREFIX}/share/postfix \
1.28      hubertf    62:            ${PREFIX}/share/doc/postfix ${PREFIX}/libexec/postfix
1.16      wiz        63:        ${CHOWN} root:wheel ${PREFIX}/share/postfix ${PREFIX}/libexec/postfix
                     64:        ${CHMOD} 755 ${PREFIX}/share/postfix ${PREFIX}/libexec/postfix
1.28      hubertf    65:        -${RM} -f ${WRKSRC}/conf/*.orig
1.5       tron       66: 
                     67: post-install:
                     68:        ${INSTALL_DATA} ${WRKDIR}/mailer.conf.postfix ${PREFIX}/etc
1.18      bad        69:        ${LN} -sf ${PREFIX}/share/postfix/postfix-script /etc/postfix
1.27      hubertf    70:        -${INSTALL_DATA_DIR} ${POSTFIX_SPOOL}
1.22      wiz        71:        ${CHMOD} 755 ${POSTFIX_SPOOL}
1.28      hubertf    72:        ${TEST} -f /etc/postfix/main.cf || \
                     73:                ${INSTALL_DATA} ${PREFIX}/share/postfix/main.cf /etc/postfix
                     74:        ${TEST} -f /etc/postfix/master.cf || \
                     75:                ${INSTALL_DATA} ${PREFIX}/share/postfix/master.cf /etc/postfix
1.1       christos   76: 
                     77: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>