Annotation of pkgsrc/mail/postfix/Makefile, revision 1.321

1.321   ! taca        1: # $NetBSD: Makefile,v 1.320 2020/06/02 08:24:15 adam Exp $
1.1       christos    2: 
1.286     fhajny      3: .include "../../mail/postfix/Makefile.common"
1.132     martti      4: 
1.312     triaxx      5: COMMENT=       Fast, easy to administer, and secure mail transfer agent
1.1       christos    6: 
1.181     jlam        7: CONFLICTS+=    courier-mta-[0-9]* fastforward>=0.51nb2 sendmail-[0-9]*
1.253     cheusov     8: CONFLICTS+=    esmtp>=1.2 nullmailer-[0-9]*
1.122     grant       9: 
1.311     triaxx     10: USE_TOOLS+=    perl pkg-config
1.69      wiz        11: 
1.293     jperkin    12: SPECIAL_PERMS+=        sbin/postdrop ${POSTFIX_USER} ${MAILDROP_GROUP} 2555
                     13: SPECIAL_PERMS+=        sbin/postqueue ${POSTFIX_USER} ${MAILDROP_GROUP} 2555
1.227     martti     14: 
1.177     martti     15: REPLACE_PERL+= auxiliary/qshape/qshape.pl
                     16: 
1.147     jlam       17: # options.mk appends to CCARGS and AUXLIBS the options needed to build
                     18: # Postfix with support for various add-on modules.
1.140     jlam       19: #
1.147     jlam       20: .include "options.mk"
1.28      hubertf    21: 
1.217     martti     22: FILES_SUBST+=          EXAMPLEDIR=${EXAMPLEDIR}
1.140     jlam       23: MESSAGE_SUBST+=                EXAMPLEDIR=${EXAMPLEDIR}
1.142     jlam       24: MESSAGE_SUBST+=                DOCDIR=${DOCDIR}
1.86      jlam       25: 
1.140     jlam       26: MESSAGE_SRC+=          ${PKGDIR}/MESSAGE
                     27: .if exists(${PKGDIR}/MESSAGE.${OPSYS})
                     28: MESSAGE_SRC+=          ${PKGDIR}/MESSAGE.${OPSYS}
1.95      martti     29: .endif
1.140     jlam       30: PLIST_SRC+=            ${PKGDIR}/PLIST
1.50      kent       31: 
1.140     jlam       32: RCD_SCRIPTS=           postfix
1.173     martti     33: OWN_DIRS+=             ${POSTFIX_QUEUE_DIR} ${POSTFIX_QUEUE_DIR}/etc
1.293     jperkin    34: OWN_DIRS_PERMS+=       ${POSTFIX_DATA_DIR} ${POSTFIX_USER} ${POSTFIX_GROUP} 0700
1.286     fhajny     35: MAKE_DIRS+=            ${METADIR}/dynamicmaps.cf.d ${METADIR}/postfix-files.d
1.140     jlam       36: 
1.293     jperkin    37: PKG_GROUPS?=           ${POSTFIX_GROUP} ${MAILDROP_GROUP}
                     38: PKG_USERS?=            ${POSTFIX_USER}:${POSTFIX_GROUP}
                     39: 
                     40: PKG_GECOS.${POSTFIX_USER}=     Postfix User
                     41: PKG_HOME.${POSTFIX_USER}=      ${POSTFIX_QUEUE_DIR}
1.140     jlam       42: 
1.141     jlam       43: CONF_FILES=            # empty
1.224     martti     44: .for i in main.cf master.cf
1.192     martti     45: CONF_FILES+=           ${EXAMPLEDIR}/${i} ${PKG_SYSCONFDIR}/${i}
1.141     jlam       46: .endfor
                     47: CONF_FILES_PERMS=      # empty
1.93      jmmv       48: 
1.176     joerg      49: SUBST_CLASSES+=                paths
                     50: SUBST_FILES.paths=     ${WRKDIR}/mailer.conf
1.310     rillig     51: SUBST_VARS.paths=      PREFIX
1.303     jperkin    52: SUBST_STAGE.paths=     pre-configure
1.176     joerg      53: 
1.286     fhajny     54: INSTALLATION_DIRS+=    ${LIBEXECDIR} ${METADIR} ${SHLIBDIR} ${EXAMPLEDIR} ${DOCDIR}
1.229     heinz      55: 
1.176     joerg      56: post-extract:
1.190     martti     57:        cp ${FILESDIR}/mailer.conf ${WRKDIR}/mailer.conf
1.193     martti     58:        rm -f ${WRKSRC}/auxiliary/MacOSX/Postfix.StartupItem/Postfix
1.176     joerg      59: 
1.5       tron       60: post-build:
1.145     jlam       61: .if !empty(PKG_OPTIONS:Msasl)
1.140     jlam       62:        ${ECHO} "pwcheck_method: ${PWCHECK_METHOD}" > ${WRKDIR}/smtpd.conf
                     63: .endif
1.5       tron       64: 
1.140     jlam       65: do-install:
1.190     martti     66:        rm -f ${WRKSRC}/conf/*.orig
1.145     jlam       67: .if !empty(PKG_OPTIONS:Msasl)
1.229     heinz      68:        ${INSTALL_DATA} ${WRKDIR}/smtpd.conf ${DESTDIR}${EXAMPLEDIR}
1.50      kent       69: .endif
1.294     adam       70:        cd ${WRKSRC} && ${SH} ./postfix-install -non-interactive \
1.229     heinz      71:                ${DESTDIR_INSTALLOPTIONS} config_directory="${EXAMPLEDIR}"
                     72:        ${INSTALL_DATA} ${WRKDIR}/mailer.conf \
                     73:                ${DESTDIR}${EXAMPLEDIR}/mailer.conf
1.177     martti     74:        ${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/qshape/qshape.pl \
1.229     heinz      75:                ${DESTDIR}${PREFIX}/sbin/qshape
1.204     martti     76:        ${INSTALL_MAN} ${WRKSRC}/man/man1/qshape.1 \
1.229     heinz      77:                ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
1.316     triaxx     78: .for dir in ${POSTFIX_QUEUE_SUBDIR}
                     79:        ${RMDIR} ${DESTDIR}${POSTFIX_QUEUE_DIR}/${dir}
                     80: .endfor
1.1       christos   81: 
                     82: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>