Annotation of pkgsrc/mail/postfix/Makefile, revision 1.25
1.25 ! wiz 1: # $NetBSD: Makefile,v 1.24 2000/12/10 09:00:46 itojun Exp $
1.1 christos 2:
1.25 ! wiz 3: DISTNAME= postfix-19991231-pl13
! 4: PKGNAME= postfix-19991231pl13
1.1 christos 5: CATEGORIES= mail
6: MASTER_SITES= ftp://postfix.cloud9.net/official/
7:
1.19 kim 8: .include "../../mk/bsd.prefs.mk"
9:
10: .if defined(POSTFIX_VERP) && ${POSTFIX_VERP} == YES
11: PATCHFILES= postfix-19991231-pl06-verp.patch.gz
12: PATCH_SITES= ftp://ftp.gw.com/pub/people/kim/patches/
13: PATCH_DIST_STRIP= -p1
14: .endif
15:
1.1 christos 16: MAINTAINER= [email protected]
1.5 tron 17: HOMEPAGE= http://www.postfix.org/
1.1 christos 18:
1.19 kim 19: DIST_SUBDIR= postfix
1.1 christos 20:
1.18 bad 21: POSTFIX_SPOOL= /var/spool/postfix
1.19 kim 22:
23: .if defined(POSTFIX_PCRE) && ${POSTFIX_PCRE} == YES
24: DEPENDS+= pcre-2.08:../../devel/pcre
25: CFLAGS+= -DHAS_PCRE -I${LOCALBASE}/include
26: AUXLIBS= -lpcre
27: MAKE_ENV+= AUXLIBS="${AUXLIBS}"
28: .endif
29:
30: MANINSTALL?= maninstall catinstall
31:
32: BUILD_DEFS+= POSTFIX_PCRE POSTFIX_VERP MANINSTALL
33:
34: PLIST_SRC= ${PKGDIR}/PLIST
35: .for i in ${MANINSTALL}
36: PLIST_SRC+= ${PKGDIR}/PLIST.$i
37: .endfor
1.18 bad 38:
1.1 christos 39: pre-patch:
40: ${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.dist
41:
42: pre-configure:
43: ${CP} ${WRKSRC}/conf/main.cf ${WRKSRC}/conf/main.cf.dist
44: ${CP} ${WRKSRC}/util/sys_defs.h ${WRKSRC}/util/sys_defs.h.dist
1.8 christos 45: ${CP} ${WRKSRC}/Makefile.inc ${WRKSRC}/Makefile.inc.dist
46: ${SED} -e 's:__PREFIX:'${PREFIX}':g' \
47: < ${WRKSRC}/conf/main.cf.dist \
1.1 christos 48: > ${WRKSRC}/conf/main.cf
1.8 christos 49: ${SED} -e 's:__PREFIX:'${PREFIX}':g' \
50: < ${WRKSRC}/util/sys_defs.h.dist \
1.1 christos 51: > ${WRKSRC}/util/sys_defs.h
1.12 agc 52: capitalopsys=`${ECHO} ${OPSYS} | ${TR} a-z A-Z`; \
53: osmajorversion=`${ECHO} ${OS_VERSION} | ${SED} -e 's/\..*//g'`; \
54: ${SED} -e 's:@OPSYS@:'$$capitalopsys$$osmajorversion':g' \
1.8 christos 55: < ${WRKSRC}/Makefile.inc.dist \
56: > ${WRKSRC}/Makefile.inc
1.1 christos 57:
1.5 tron 58: post-build:
59: ${SED} -e 's#@@PREFIX@@#${PREFIX}#g' \
60: <${FILESDIR}/mailer.conf >${WRKDIR}/mailer.conf.postfix
61:
1.1 christos 62: pre-install:
1.6 tron 63: ${MKDIR} /etc/postfix ${PREFIX}/share/postfix \
64: ${PREFIX}/share/doc/postfix ${PREFIX}/libexec/postfix
1.16 wiz 65: ${CHOWN} root:wheel ${PREFIX}/share/postfix ${PREFIX}/libexec/postfix
66: ${CHMOD} 755 ${PREFIX}/share/postfix ${PREFIX}/libexec/postfix
1.5 tron 67:
68: post-install:
69: ${INSTALL_DATA} ${WRKDIR}/mailer.conf.postfix ${PREFIX}/etc
1.18 bad 70: ${LN} -sf ${PREFIX}/share/postfix/postfix-script /etc/postfix
71: -${MKDIR} ${POSTFIX_SPOOL}
1.22 wiz 72: ${CHMOD} 755 ${POSTFIX_SPOOL}
1.18 bad 73: ${TEST} -f /etc/postfix/main.cf || ${INSTALL_DATA} ${PREFIX}/share/postfix/main.cf /etc/postfix
74: ${TEST} -f /etc/postfix/master.cf || ${INSTALL_DATA} ${PREFIX}/share/postfix/master.cf /etc/postfix
1.1 christos 75:
76: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>