Annotation of pkgsrc/mail/nmh/Makefile, revision 1.88
1.88 ! leot 1: # $NetBSD: Makefile,v 1.87 2015/08/18 07:31:11 wiz Exp $
1.1 agc 2:
1.84 schnoebe 3: DISTNAME= nmh-1.6
1.38 jlam 4: CATEGORIES= mail
1.68 epg 5: MASTER_SITES= http://savannah.nongnu.org/download/nmh/
1.87 wiz 6: PKGREVISION= 2
1.1 agc 7:
1.71 wiz 8: MAINTAINER= [email protected]
1.52 salo 9: HOMEPAGE= http://www.nongnu.org/nmh/
1.39 wiz 10: COMMENT= Cleaned up MH mailer suite
1.76 drochner 11: LICENSE= modified-bsd
1.30 sakamoto 12:
1.43 jlam 13: CONFLICTS= ja-mh-[0-9]*
14: CONFLICTS+= ja-mh6-[0-9]*
1.1 agc 15:
1.66 rillig 16: USE_TOOLS+= lex
17:
1.24 kim 18: # We choose DOT_LOCKING in our patches because ".lock" files are
19: # the most common locking mechanism supported by mail software.
20: # It also works well over NFS.
21:
22: # Locks supported by `mail.local' are ".lock" and flock(2).
23:
24: .include "../../mk/bsd.prefs.mk"
1.63 schwarz 25: # Avoids SEGV in nmh's private version of strcasecmp() under gcc4
26: .if !empty(PKGSRC_COMPILER:Mgcc*)
27: CFLAGS+= -O1
28: .endif
29:
1.57 jlam 30: .include "options.mk"
1.24 kim 31:
1.10 hubertf 32: # Mail Transport Agent - either "smtp" or "sendmail"
1.38 jlam 33: NMH_MTA?= smtp
1.7 agc 34:
1.57 jlam 35: GNU_CONFIGURE= yes
1.55 jmmv 36:
1.82 obache 37: GNU_CONFIGURE_LIBDIR= ${PREFIX}/libexec/nmh
1.84 schnoebe 38: CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
1.60 rillig 39: CONFIGURE_ARGS+= --with-mts=${NMH_MTA:Q}
1.24 kim 40:
1.38 jlam 41: DOCDIR= share/doc/nmh
1.68 epg 42: EGDIR= ${PREFIX}/share/examples/nmh
1.70 epg 43: INSTALLATION_DIRS= ${DOCDIR} ${EGDIR}
1.27 agc 44:
1.38 jlam 45: BUILD_DEFS+= NMH_MTA NMH_EDITOR NMH_PAGER NMH_HASH_BACKUP
1.25 kim 46:
1.55 jmmv 47: PKG_SYSCONFSUBDIR= nmh
48: CONF_FILES= # empty
49: .for f in MailAliases \
50: components \
51: digestcomps \
52: distcomps \
53: forwcomps \
54: mhl.body \
55: mhl.digest \
56: mhl.format \
57: mhl.forward \
58: mhl.headers \
59: mhl.reply \
60: mhn.defaults \
61: mts.conf \
62: rcvdistcomps \
63: rcvdistcomps.outbox \
64: replcomps \
65: replgroupcomps \
66: scan.MMDDYY \
67: scan.YYYYMMDD \
68: scan.default \
69: scan.mailx \
70: scan.nomime \
71: scan.size \
72: scan.time \
73: scan.timely \
1.68 epg 74: scan.unseen
1.55 jmmv 75: CONF_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
76: .endfor
77:
1.86 dholland 78: # The configure script checks for arc4random(), but the program uses
79: # arc4random_buf(); netbsd-5 (and presumably earlier) has the one but
80: # not the other. Just disable it, because all it's using the
81: # randomness for is message-ids.
82: .if !empty(MACHINE_PLATFORM:MNetBSD-[1-5].*-*)
83: CONFIGURE_ENV+= ac_cv_func_arc4random=no
84: .endif
85:
1.1 agc 86: post-install:
1.68 epg 87: ${INSTALL_DATA} ${FILESDIR}/mhn.defaults.dist \
88: ${DESTDIR}${EGDIR}/mhn.defaults
1.1 agc 89:
1.72 sbd 90: .include "../../mk/bsd.prefs.mk"
91:
92: .if ${OPSYS} == "Linux"
93: .include "../../databases/gdbm_compat/buildlink3.mk"
94: CONFIGURE_ARGS+= --with-ndbm='gdbm_compat -lgdbm'
95: CONFIGURE_ARGS+= --with-ndbmheader=ndbm.h
96: .endif
97:
1.85 dholland 98: .include "../../mk/terminfo.buildlink3.mk"
1.14 agc 99: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>