Annotation of pkgsrc/lang/parrot/Makefile, revision 1.49
1.49 ! he 1: # $NetBSD: Makefile,v 1.48 2011/08/26 08:30:30 he Exp $
1.1 agc 2: #
3:
1.49 ! he 4: VERSION= 3.8.0
1.43 he 5: RTYPE= devel
1.16 he 6: DISTNAME= parrot-${VERSION}
1.8 wiz 7: CATEGORIES= lang
1.16 he 8: MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/
1.1 agc 9:
1.15 he 10: MAINTAINER= [email protected]
1.8 wiz 11: HOMEPAGE= http://www.parrotcode.org/
12: COMMENT= Virtual machine made to run Perl 6 and other languages
1.16 he 13: LICENSE= artistic-2.0
1.8 wiz 14:
1.16 he 15: PKG_DESTDIR_SUPPORT= user-destdir
1.12 obache 16: USE_LANGUAGES= c c++
1.9 wiz 17: USE_TOOLS+= perl
18: PTHREAD_OPTS+= require
19: BUILD_TARGET= world
20: TEST_TARGET= test
1.13 obache 21: HAS_CONFIGURE= yes
1.8 wiz 22:
1.9 wiz 23: .include "../../mk/pthread.buildlink3.mk"
1.8 wiz 24: .include "../../mk/bsd.prefs.mk"
25:
1.13 obache 26: CONFIG_SHELL= perl
27: CONFIGURE_SCRIPT= Configure.pl
1.9 wiz 28: CONFIGURE_ARGS+= --prefix=${PREFIX:Q} \
1.33 he 29: --icu-config=${PREFIX}/bin/icu-config \
30: --optimize
1.8 wiz 31:
1.13 obache 32: SUBST_CLASSES+= pthread
33: SUBST_STAGE.pthread= post-configure
34: SUBST_FILES.pthread= Makefile
35: SUBST_SED.pthread= -e 's|-pthread||g'
36: SUBST_SED.pthread+= -e 's|-lpthread||g'
37: SUBST_SED.pthread+= -e 's|-lc_r||g'
38: SUBST_SED.pthread+= -e '/^CFLAGS /s|$$|${PTHREAD_CFLAGS:Q}|'
39: SUBST_SED.pthread+= -e '/^LINKFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
40: SUBST_SED.pthread+= -e '/^LDFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
1.8 wiz 41:
1.23 he 42: PLIST_SUBST+= VERSION=${VERSION:Q}
43: PLIST_SRC+= ${PLIST_SRC_DFLT}
44: # Default this to ELF shared libs with .so,
45: # Darwin has PLIST.Darwin which gets included automatically.
46: .if (${OPSYS} != "Darwin")
47: PLIST_SRC+= PLIST.shared
48: .endif
49:
1.25 he 50: REPLACE_PERL+= tools/build/ops2c.pl
51: REPLACE_PERL+= tools/build/pmc2c.pl
1.35 he 52: REPLACE_PERL+= tools/dev/create_language.pl
1.25 he 53: REPLACE_PERL+= tools/dev/gen_makefile.pl
1.36 he 54: REPLACE_PERL+= tools/dev/pprof2cg.pl
1.25 he 55: REPLACE_PERL+= tools/dev/reconfigure.pl
56:
57: REPLACE_INTERPRETER+= parrot
58: REPLACE.parrot.old= .*parrot[^[:space:]]*
59: REPLACE.parrot.new= ${PREFIX}/bin/parrot
60: REPLACE_FILES.parrot+= tools/dev/pbc_to_exe.pir
61:
1.30 joerg 62: # Does relink internally, so allow local rpath entries
63: BUILDLINK_PASSTHRU_RPATHDIRS+= ${WRKSRC}
1.23 he 64:
1.16 he 65: pre-install:
66: ${CHMOD} -R g-w ${WRKSRC}
67:
1.8 wiz 68: .include "../../textproc/icu/buildlink3.mk"
1.33 he 69: .include "../../devel/gmp/buildlink3.mk"
1.1 agc 70: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>