Annotation of pkgsrc/lang/parrot/Makefile, revision 1.25
1.25 ! he 1: # $NetBSD: Makefile,v 1.24 2009/12/09 09:23:50 he Exp $
1.1 agc 2: #
3:
1.25 ! he 4: VERSION= 1.8.0
1.20 he 5: RTYPE= devel
1.16 he 6: DISTNAME= parrot-${VERSION}
1.8 wiz 7: CATEGORIES= lang
1.16 he 8: MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/
1.1 agc 9:
1.15 he 10: MAINTAINER= [email protected]
1.8 wiz 11: HOMEPAGE= http://www.parrotcode.org/
12: COMMENT= Virtual machine made to run Perl 6 and other languages
1.16 he 13: LICENSE= artistic-2.0
1.8 wiz 14:
1.16 he 15: PKG_DESTDIR_SUPPORT= user-destdir
1.12 obache 16: USE_LANGUAGES= c c++
1.9 wiz 17: USE_TOOLS+= perl
18: PTHREAD_OPTS+= require
19: BUILD_TARGET= world
20: TEST_TARGET= test
1.13 obache 21: HAS_CONFIGURE= yes
1.8 wiz 22:
1.9 wiz 23: .include "../../mk/pthread.buildlink3.mk"
1.8 wiz 24: .include "../../mk/bsd.prefs.mk"
25:
1.13 obache 26: CONFIG_SHELL= perl
27: CONFIGURE_SCRIPT= Configure.pl
1.9 wiz 28: CONFIGURE_ARGS+= --prefix=${PREFIX:Q} \
29: --icu-config=${PREFIX}/bin/icu-config
1.8 wiz 30:
1.13 obache 31: SUBST_CLASSES+= pthread
32: SUBST_STAGE.pthread= post-configure
33: SUBST_FILES.pthread= Makefile
34: SUBST_SED.pthread= -e 's|-pthread||g'
35: SUBST_SED.pthread+= -e 's|-lpthread||g'
36: SUBST_SED.pthread+= -e 's|-lc_r||g'
37: SUBST_SED.pthread+= -e '/^CFLAGS /s|$$|${PTHREAD_CFLAGS:Q}|'
38: SUBST_SED.pthread+= -e '/^LINKFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
39: SUBST_SED.pthread+= -e '/^LDFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
1.8 wiz 40:
1.23 he 41: PLIST_SUBST+= VERSION=${VERSION:Q}
42: PLIST_SRC+= ${PLIST_SRC_DFLT}
43: # Default this to ELF shared libs with .so,
44: # Darwin has PLIST.Darwin which gets included automatically.
45: .if (${OPSYS} != "Darwin")
46: PLIST_SRC+= PLIST.shared
47: .endif
48:
1.25 ! he 49: REPLACE_PERL+= tools/build/ops2c.pl
! 50: REPLACE_PERL+= tools/build/pmc2c.pl
! 51: REPLACE_PERL+= tools/dev/gen_makefile.pl
! 52: REPLACE_PERL+= tools/dev/mk_language_shell.pl
! 53: REPLACE_PERL+= tools/dev/reconfigure.pl
! 54: REPLACE_PERL+= lib/Parrot/Op.pm
! 55: #REPLACE_PERL+= lib/Parrot/OpLib/core.pm
! 56: REPLACE_PERL+= lib/Parrot/OpTrans/CPrederef.pm
! 57: REPLACE_PERL+= lib/Parrot/OpsFile.pm
! 58:
! 59:
! 60: REPLACE_INTERPRETER+= parrot
! 61: REPLACE.parrot.old= .*parrot[^[:space:]]*
! 62: REPLACE.parrot.new= ${PREFIX}/bin/parrot
! 63: REPLACE_FILES.parrot+= tools/dev/pbc_to_exe.pir
! 64:
1.23 he 65:
1.16 he 66: pre-install:
67: ${CHMOD} -R g-w ${WRKSRC}
68:
1.8 wiz 69: .include "../../textproc/icu/buildlink3.mk"
1.1 agc 70: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>