Annotation of pkgsrc/lang/parrot/Makefile, revision 1.24
1.24 ! he 1: # $NetBSD: Makefile,v 1.23 2009/10/21 14:23:13 he Exp $
1.1 agc 2: #
3:
1.24 ! he 4: VERSION= 1.7.0
1.20 he 5: RTYPE= devel
1.16 he 6: DISTNAME= parrot-${VERSION}
1.8 wiz 7: CATEGORIES= lang
1.16 he 8: MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/
1.1 agc 9:
1.15 he 10: MAINTAINER= [email protected]
1.8 wiz 11: HOMEPAGE= http://www.parrotcode.org/
12: COMMENT= Virtual machine made to run Perl 6 and other languages
1.16 he 13: LICENSE= artistic-2.0
1.8 wiz 14:
1.16 he 15: PKG_DESTDIR_SUPPORT= user-destdir
1.12 obache 16: USE_LANGUAGES= c c++
1.9 wiz 17: USE_TOOLS+= perl
18: PTHREAD_OPTS+= require
19: BUILD_TARGET= world
20: TEST_TARGET= test
1.13 obache 21: HAS_CONFIGURE= yes
1.8 wiz 22:
1.9 wiz 23: .include "../../mk/pthread.buildlink3.mk"
1.8 wiz 24: .include "../../mk/bsd.prefs.mk"
25:
1.13 obache 26: CONFIG_SHELL= perl
27: CONFIGURE_SCRIPT= Configure.pl
1.9 wiz 28: CONFIGURE_ARGS+= --prefix=${PREFIX:Q} \
29: --icu-config=${PREFIX}/bin/icu-config
1.8 wiz 30:
1.13 obache 31: SUBST_CLASSES+= pthread
32: SUBST_STAGE.pthread= post-configure
33: SUBST_FILES.pthread= Makefile
34: SUBST_SED.pthread= -e 's|-pthread||g'
35: SUBST_SED.pthread+= -e 's|-lpthread||g'
36: SUBST_SED.pthread+= -e 's|-lc_r||g'
37: SUBST_SED.pthread+= -e '/^CFLAGS /s|$$|${PTHREAD_CFLAGS:Q}|'
38: SUBST_SED.pthread+= -e '/^LINKFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
39: SUBST_SED.pthread+= -e '/^LDFLAGS /s|$$|${PTHREAD_LDFLAGS:Q} ${PTHREAD_LIBS:Q}|'
1.8 wiz 40:
1.23 he 41: PLIST_SUBST+= VERSION=${VERSION:Q}
42: PLIST_SRC+= ${PLIST_SRC_DFLT}
43: # Default this to ELF shared libs with .so,
44: # Darwin has PLIST.Darwin which gets included automatically.
45: .if (${OPSYS} != "Darwin")
46: PLIST_SRC+= PLIST.shared
47: .endif
48:
49:
1.16 he 50: pre-install:
51: ${CHMOD} -R g-w ${WRKSRC}
52:
1.8 wiz 53: .include "../../textproc/icu/buildlink3.mk"
1.1 agc 54: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>