Annotation of pkgsrc/lang/erlang/Makefile, revision 1.63
1.63 ! is 1: # $NetBSD: Makefile,v 1.62 2014/05/29 23:36:42 wiz Exp $
1.1 jtb 2:
1.42 asau 3: DISTNAME= otp_src_${DIST_VERSION_MAJOR}${DIST_VERSION_MINOR:D-${DIST_VERSION_MINOR}}
1.62 wiz 4: PKGREVISION= 3
1.26 ghen 5: PKGNAME= erlang-${ERLANG_VERSION}
1.1 jtb 6: CATEGORIES= lang
1.42 asau 7: MASTER_SITES= http://www.erlang.org/download/
1.1 jtb 8:
1.24 jlam 9: MAINTAINER= [email protected]
1.6 jtb 10: HOMEPAGE= http://www.erlang.org/
1.5 martti 11: COMMENT= Concurrent functional programming language
1.46 asau 12: LICENSE= erlang-public-license
1.1 jtb 13:
14: DIST_SUBDIR= erlang
1.54 asau 15: WRKSRC= $(WRKDIR)/otp_src_${DIST_VERSION_MAJOR}
1.1 jtb 16:
1.39 ahoka 17: MAKE_JOBS_SAFE= no
1.35 ghen 18:
1.1 jtb 19: GNU_CONFIGURE= yes
1.42 asau 20: USE_GNU_CONFIGURE_HOST= ${USE_CROSS_COMPILE}
1.28 joerg 21: OVERRIDE_DIRDEPTH= 4
1.49 fhajny 22: USE_TOOLS+= gmake perl:run flex
1.1 jtb 23:
1.37 martti 24: CONFIGURE_ARGS+= --with-ssl=${BUILDLINK_PREFIX.openssl}
1.19 wiz 25:
1.42 asau 26: PTHREAD_OPTS+= require native
27: CONFIGURE_ARGS+= --enable-threads
28:
1.59 is 29: .include "../../mk/bsd.prefs.mk"
30:
31: # have gcc without the necessary atomic ops?
1.63 ! is 32: .if !empty(MACHINE_PLATFORM:MNetBSD-[56].*)
1.59 is 33:
34: # a machine without native ethread implementation?
35: .if empty(MACHINE_PLATFORM:M*i386) &&\
36: empty(MACHINE_PLATFORM:M*sparc) &&\
37: empty(MACHINE_PLATFORM:M*sparc64) &&\
38: empty(MACHINE_PLATFORM:M*powerpc) &&\
39: empty(MACHINE_PLATFORM:M*x86_64)
40:
41: CONFIGURE_ARGS+= --disable-native-ethr-impls\
42: --disable-smp-require-native-atomics
43:
44: .endif
45: .endif
46:
1.42 asau 47: MAKE_ENV+= DESTDIR=${DESTDIR}
48:
1.47 asau 49: REPLACE_INTERPRETER+= escript
50: REPLACE.escript.old= .*escript
51: REPLACE.escript.new= ${LOCALBASE}/bin/escript
52: REPLACE_FILES.escript= \
53: lib/reltool/examples/display_args \
54: lib/reltool/examples/mnesia_core_dump_viewer \
55: lib/snmp/src/compile/snmpc.src \
56: lib/erl_docgen/priv/bin/codeline_preprocessing.escript \
57: lib/erl_docgen/priv/bin/xml_from_edoc.escript \
1.48 asau 58: lib/snmp/bin/snmpc \
59: lib/diameter/bin/diameterc
1.47 asau 60:
1.21 rillig 61: SUBST_CLASSES+= target
1.14 markd 62: SUBST_STAGE.target= post-patch
63: SUBST_FILES.target= make/target.mk
64: SUBST_SED.target= -e "s|=.*config.guess)|= ${MACHINE_GNU_PLATFORM}|"
1.25 ghen 65: SUBST_MESSAGE.target= Fixing target name.
1.14 markd 66:
1.42 asau 67: TEST_TARGET= tests
1.46 asau 68: TEST_MAKE_FLAGS= ERL_TOP=${WRKSRC}
1.42 asau 69: REPLACE_PERL+= make/make_emakefile
70:
1.61 jperkin 71: SMF_NAME= epmd
72:
1.42 asau 73: PLIST_SRC= PLIST
1.22 ghen 74:
1.42 asau 75: .if exists(${.CURDIR}/PLIST.${OPSYS})
76: PLIST_SRC+= ${.CURDIR}/PLIST.${OPSYS}
77: .endif
78:
1.30 joerg 79: .if ${OPSYS} == "DragonFly"
80: CONFIGURE_ARGS+= --disable-sctp
81: .endif
1.42 asau 82: ###
83: ### XXX There may be others here.
84: ###
85: .if ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD"
86: CONFIGURE_ARGS+= --enable-kernel-poll
87: .endif
1.30 joerg 88:
1.22 ghen 89: .include "options.mk"
90:
1.42 asau 91: .include "Makefile.versions"
1.22 ghen 92:
1.42 asau 93: ###
94: ### Ensure this gets rebuilt.
95: ###
96: pre-build:
97: ${RUN} ${RM} -f ${WRKSRC}/lib/stdlib/ebin/dets_v9.beam
1.26 ghen 98:
1.31 obache 99: post-install:
1.42 asau 100: chmod -R go-w ${DESTDIR}${PREFIX}/lib/erlang/lib
101:
1.13 abs 102: .include "../../security/openssl/buildlink3.mk"
1.58 roy 103: .include "../../mk/termcap.buildlink3.mk"
1.13 abs 104: .include "../../mk/pthread.buildlink3.mk"
1.1 jtb 105: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>