Annotation of pkgsrc/ham/uhd/Makefile, revision 1.64
1.64 ! adam 1: # $NetBSD: Makefile,v 1.63 2021/12/11 17:39:56 tnn Exp $
1.1 mef 2:
1.64 ! adam 3: DISTNAME= uhd-4.1.0.5
1.44 adam 4: CATEGORIES= ham
5: MASTER_SITES= ${MASTER_SITE_GITHUB:=EttusResearch/}
6: GITHUB_TAG= v${PKGVERSION_NOREV}
7:
8: MAINTAINER= [email protected]
9: HOMEPAGE= https://github.com/EttusResearch/uhd
10: COMMENT= USRP (Universal Software Radio Peripheral) Hardware Drivers
1.63 tnn 11: LICENSE= gnu-gpl-v3
1.44 adam 12:
13: DEPENDS+= ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
14: DEPENDS+= ${PYPKGPREFIX}-requests-[0-9]*:../../devel/py-requests
15:
1.61 nia 16: CMAKE_ARGS+= -DLIB_SUFFIX=""
1.55 adam 17: CMAKE_ARGS+= -DENABLE_MAN_PAGE_COMPRESSION=OFF
1.51 adam 18: CMAKE_ARGS+= -DPKG_MAN_DIR=${PKGMANDIR}/man1
1.44 adam 19: CMAKE_ARGS+= -DRST2HTML_EXECUTABLE=${PREFIX}/bin/rst2html-${PYVERSSUFFIX}.py
20: CMAKE_ARGS+= -Wno-dev
21: .include "../../lang/python/pyversion.mk"
22: CMAKE_ARGS+= -DPYTHON_EXECUTABLE=${PYTHONBIN}
23: .if !empty(_PYTHON_VERSION:M3*)
24: CMAKE_ARGS+= -DENABLE_PYTHON3=ON
25: .endif
1.4 mef 26:
1.42 gdt 27: # Upstream says C++11 is required, even though it is not documented.
28: # It is documented that gcc 4.8 is required, when using gcc.
29: # https://github.com/EttusResearch/uhd/issues/236
1.45 gdt 30: #
31: # Upstream does not seem to have any documentation that gnu++11 is
32: # required, but it builds with tha and not with c++11 on netbsd-8. No
33: # ticket filed because #236 resulted in in-ticket clarification only
34: # (and not a doc edit), and having experimented no clarification is
35: # needed.
1.44 adam 36: USE_CMAKE= yes
1.55 adam 37: USE_LANGUAGES= c gnu++14
1.44 adam 38: USE_TOOLS+= pkg-config
1.42 gdt 39: GCC_REQD+= 4.8
1.44 adam 40: # to avoid extra pax_global_header
1.11 mef 41: EXTRACT_USING= gtar
1.44 adam 42: WRKSRC= ${WRKDIR}/${DISTNAME}/host
1.1 mef 43:
44: # The files with their name uhd-xxxx, are moved down from uhd/xxxx for this process.
1.63 tnn 45: REPLACE_PYTHON+= utils/convert_cal_data.py
1.44 adam 46: REPLACE_PYTHON+= utils/converter_benchmark.py
47: REPLACE_PYTHON+= utils/latency/graph.py
48: REPLACE_PYTHON+= utils/latency/run_tests.py
1.63 tnn 49: REPLACE_PYTHON+= utils/rfnoc_image_builder.py
1.44 adam 50: REPLACE_PYTHON+= utils/uhd_images_downloader.py.in
1.63 tnn 51: REPLACE_PYTHON+= utils/uhd_power_cal.py
1.44 adam 52: REPLACE_PYTHON+= utils/usrp2_card_burner.py
53: REPLACE_PYTHON+= utils/usrp2_card_burner_gui.py
1.57 tnn 54: REPLACE_PYTHON+= utils/usrp2_recovery.py
1.44 adam 55: REPLACE_PYTHON+= tests/devtest/benchmark_rate_test.py
56: REPLACE_PYTHON+= tests/devtest/multi_usrp_test.py
57: REPLACE_PYTHON+= tests/devtest/python_api_test.py
1.64 ! adam 58: REPLACE_PYTHON+= tests/devtest/python_rx_stability_test.py
1.44 adam 59: REPLACE_PYTHON+= tests/devtest/run_testsuite.py
1.64 ! adam 60: REPLACE_PYTHON+= tests/devtest/recv_stability_test.py
1.44 adam 61: REPLACE_PYTHON+= tests/devtest/rx_samples_to_file_test.py
62: REPLACE_PYTHON+= tests/devtest/test_messages_test.py
63: REPLACE_PYTHON+= tests/devtest/test_pps_test.py
64: REPLACE_PYTHON+= tests/devtest/tx_bursts_test.py
1.53 mef 65: REPLACE_PYTHON+= tests/devtest/tx_waveforms_test.py
1.44 adam 66: REPLACE_PYTHON+= tests/devtest/uhd_test_base.py
67: REPLACE_PYTHON+= tests/devtest/usrp_probe.py
68: REPLACE_PYTHON+= tests/devtest/usrp_probe_test.py
1.63 tnn 69: REPLACE_PYTHON+= tests/streaming_performance/batch_run_benchmark_rate.py
70: REPLACE_PYTHON+= tests/streaming_performance/run_E3xx_max_rate_tests.py
71: REPLACE_PYTHON+= tests/streaming_performance/run_N3xx_max_rate_tests.py
72: REPLACE_PYTHON+= tests/streaming_performance/run_X3xx_max_rate_tests.py
73:
1.1 mef 74: INSTALLATION_DIRS+= share/uhd
75: INSTALLATION_DIRS+= share/uhd/firmware
76: INSTALLATION_DIRS+= share/uhd/fpga
77: INSTALLATION_DIRS+= share/uhd/images
78:
79: .include "options.mk"
80:
81: .include "../../devel/boost-libs/buildlink3.mk"
82: .include "../../devel/libusb1/buildlink3.mk"
83: .include "../../devel/orc/buildlink3.mk"
1.44 adam 84: .include "../../lang/python/application.mk"
1.28 nros 85: .include "../../mk/curses.buildlink3.mk"
1.1 mef 86: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>