Annotation of pkgsrc/ham/uhd/Makefile, revision 1.45

1.45    ! gdt         1: # $NetBSD: Makefile,v 1.44 2019/03/22 17:58:27 adam Exp $
1.1       mef         2: 
1.44      adam        3: DISTNAME=      uhd-3.13.1.0
                      4: CATEGORIES=    ham
                      5: MASTER_SITES=  ${MASTER_SITE_GITHUB:=EttusResearch/}
                      6: GITHUB_TAG=    v${PKGVERSION_NOREV}
                      7: 
                      8: MAINTAINER=    [email protected]
                      9: HOMEPAGE=      https://github.com/EttusResearch/uhd
                     10: COMMENT=       USRP (Universal Software Radio Peripheral) Hardware Drivers
                     11: LICENSE=       gnu-gpl-v2
                     12: 
                     13: DEPENDS+=      ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
                     14: DEPENDS+=      ${PYPKGPREFIX}-requests-[0-9]*:../../devel/py-requests
                     15: 
                     16: CMAKE_ARGS+=   -DRST2HTML_EXECUTABLE=${PREFIX}/bin/rst2html-${PYVERSSUFFIX}.py
                     17: CMAKE_ARGS+=   -Wno-dev
                     18: .include "../../lang/python/pyversion.mk"
                     19: CMAKE_ARGS+=   -DPYTHON_EXECUTABLE=${PYTHONBIN}
                     20: .if !empty(_PYTHON_VERSION:M3*)
                     21: CMAKE_ARGS+=   -DENABLE_PYTHON3=ON
                     22: .endif
1.4       mef        23: 
1.42      gdt        24: # Upstream says C++11 is required, even though it is not documented.
                     25: # It is documented that gcc 4.8 is required, when using gcc.
                     26: # https://github.com/EttusResearch/uhd/issues/236
1.45    ! gdt        27: #
        !            28: # Upstream does not seem to have any documentation that gnu++11 is
        !            29: # required, but it builds with tha and not with c++11 on netbsd-8.  No
        !            30: # ticket filed because #236 resulted in in-ticket clarification only
        !            31: # (and not a doc edit), and having experimented no clarification is
        !            32: # needed.
1.44      adam       33: USE_CMAKE=             yes
1.45    ! gdt        34: USE_LANGUAGES=         c gnu++11
1.44      adam       35: USE_TOOLS+=            pkg-config
1.42      gdt        36: GCC_REQD+=             4.8
1.44      adam       37: # to avoid extra pax_global_header
1.11      mef        38: EXTRACT_USING=         gtar
1.44      adam       39: WRKSRC=                        ${WRKDIR}/${DISTNAME}/host
1.1       mef        40: 
                     41: # The files with their name uhd-xxxx, are moved down from uhd/xxxx for this process.
1.44      adam       42: REPLACE_PYTHON+=       utils/converter_benchmark.py
                     43: REPLACE_PYTHON+=       utils/latency/graph.py
                     44: REPLACE_PYTHON+=       utils/latency/run_tests.py
                     45: REPLACE_PYTHON+=       utils/uhd_images_downloader.py.in
                     46: REPLACE_PYTHON+=       utils/usrp2_card_burner.py
                     47: REPLACE_PYTHON+=       utils/usrp2_card_burner_gui.py
                     48: REPLACE_PYTHON+=       tests/devtest/benchmark_rate_test.py
                     49: REPLACE_PYTHON+=       tests/devtest/multi_usrp_test.py
                     50: REPLACE_PYTHON+=       tests/devtest/python_api_test.py
                     51: REPLACE_PYTHON+=       tests/devtest/run_testsuite.py
                     52: REPLACE_PYTHON+=       tests/devtest/rx_samples_to_file_test.py
                     53: REPLACE_PYTHON+=       tests/devtest/test_messages_test.py
                     54: REPLACE_PYTHON+=       tests/devtest/test_pps_test.py
                     55: REPLACE_PYTHON+=       tests/devtest/tx_bursts_test.py
                     56: REPLACE_PYTHON+=       tests/devtest/uhd_test_base.py
                     57: REPLACE_PYTHON+=       tests/devtest/usrp_probe.py
                     58: REPLACE_PYTHON+=       tests/devtest/usrp_probe_test.py
1.1       mef        59: 
                     60: INSTALLATION_DIRS+=    share/uhd
                     61: INSTALLATION_DIRS+=    share/uhd/firmware
                     62: INSTALLATION_DIRS+=    share/uhd/fpga
                     63: INSTALLATION_DIRS+=    share/uhd/images
                     64: 
                     65: SUBST_CLASSES+=                man
                     66: SUBST_MESSAGE.man=     Convert share/man to man
                     67: SUBST_STAGE.man=       pre-configure
                     68: SUBST_FILES.man=       docs/CMakeLists.txt
                     69: SUBST_SED.man=         -e '/UHD_INSTALL/s,$${PKG_MAN_DIR},${PREFIX}/${PKGMANDIR}/man1,'
                     70: # UHD_INSTALL(FILES ${gzfile} DESTINATION ${PKG_MAN_DIR} COMPONENT manpages)
                     71: 
                     72: .include "options.mk"
                     73: 
                     74: .include "../../devel/boost-libs/buildlink3.mk"
                     75: .include "../../devel/libusb1/buildlink3.mk"
                     76: .include "../../devel/orc/buildlink3.mk"
1.44      adam       77: .include "../../lang/python/application.mk"
1.28      nros       78: .include "../../mk/curses.buildlink3.mk"
1.1       mef        79: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>