Annotation of pkgsrc/ham/uhd/Makefile, revision 1.31
1.31 ! adam 1: # $NetBSD: Makefile,v 1.30 2017/09/06 10:40:30 wiz Exp $
1.1 mef 2:
1.18 mef 3: DISTNAME= uhd-3.9.4
1.31 ! adam 4: PKGREVISION= 8
1.1 mef 5: CATEGORIES= ham
1.11 mef 6: MASTER_SITES= ${MASTER_SITE_GITHUB:=EttusResearch/}
1.14 mef 7: # 3.9.1 -> 003_009_001
8: GITHUB_TAG= release_${PKGVERSION_NOREV:C/([0-9])\.([0-9])\.([0-9])/00\1_00\2_00\3/}
1.1 mef 9:
10: MAINTAINER= [email protected]
1.30 wiz 11: #HOMEPAGE= http://code.ettus.com/redmine/ettus/projects/uhd/wiki
1.1 mef 12: COMMENT= USRP (Universal Software Radio Peripheral) Hardware Drivers
13: LICENSE= gnu-gpl-v2
14:
15: BUILD_DEPENDS+= ${PYPKGPREFIX}-cheetah-[0-9]*:../../devel/py-cheetah
1.9 wiz 16: BUILD_DEPENDS+= ${PYPKGPREFIX}-docutils>=0.12:../../textproc/py-docutils
1.14 mef 17: BUILD_DEPENDS+= ${PYPKGPREFIX}-mako-[0-9]*:../../devel/py-mako
1.8 joerg 18:
1.24 wiz 19: PYTHON_VERSIONS_INCOMPATIBLE= 34 35 36 # py-cheetah
20:
1.8 joerg 21: CMAKE_ARGS+= -DRST2HTML_EXECUTABLE=${PREFIX}/bin/rst2html-${PYVERSSUFFIX}.py
1.12 mef 22: CMAKE_ARGS+= -Wno-dev
1.4 mef 23:
1.1 mef 24: USE_LANGUAGES= c c++
1.3 obache 25: USE_TOOLS= cmake pkg-config
1.4 mef 26: USE_CMAKE= yes
1.11 mef 27: # extra pax_global_header exists, and to avoid that:
28: EXTRACT_USING= gtar
29: #EXTRACT_ELEMENTS= uhd-${GITHUB_TAG}
1.1 mef 30:
31: # Please note distribution has many stuff under uhd/, but build itself
32: # needs under host/ only. Those uhd/ stuff will be handled post-{patch,install}:
1.11 mef 33: WRKSRC= ${WRKDIR}/uhd-${GITHUB_TAG}/host
1.1 mef 34:
35: # The files with their name uhd-xxxx, are moved down from uhd/xxxx for this process.
36: REPLACE_PYTHON= \
1.12 mef 37: utils/latency/graph.py \
38: utils/latency/run_tests.py \
1.1 mef 39: utils/uhd_images_downloader.py.in \
40: utils/usrp2_card_burner.py \
41: utils/usrp2_card_burner_gui.py \
42: utils/usrp_n2xx_net_burner.py \
1.18 mef 43: utils/usrp_n2xx_net_burner_gui.py
1.1 mef 44:
45: INSTALLATION_DIRS+= share/uhd
46: INSTALLATION_DIRS+= share/uhd/firmware
47: INSTALLATION_DIRS+= share/uhd/fpga
48: INSTALLATION_DIRS+= share/uhd/images
49:
50: SUBST_CLASSES+= man
51: SUBST_MESSAGE.man= Convert share/man to man
52: SUBST_STAGE.man= pre-configure
53: SUBST_FILES.man= docs/CMakeLists.txt
54: SUBST_SED.man= -e '/UHD_INSTALL/s,$${PKG_MAN_DIR},${PREFIX}/${PKGMANDIR}/man1,'
55: # UHD_INSTALL(FILES ${gzfile} DESTINATION ${PKG_MAN_DIR} COMPONENT manpages)
56:
57: # is it default ? and redundent ?
58: PLIST_SRC= ${PKGDIR}/PLIST
59: .include "options.mk"
60:
61: .include "../../lang/python/application.mk"
62: .include "../../devel/boost-libs/buildlink3.mk"
63: .include "../../devel/libusb1/buildlink3.mk"
64: .include "../../devel/orc/buildlink3.mk"
1.28 nros 65: .include "../../mk/curses.buildlink3.mk"
1.1 mef 66: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>