Annotation of pkgsrc/graphics/asymptote/Makefile, revision 1.35

1.35    ! riastrad    1: # $NetBSD: Makefile,v 1.34 2020/03/27 03:41:20 riastradh Exp $
1.1       wiz         2: 
1.25      wiz         3: DISTNAME=      asymptote-2.41
1.30      wiz         4: PKGREVISION=   4
1.1       wiz         5: CATEGORIES=    graphics
                      6: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=asymptote/}
                      7: EXTRACT_SUFX=  .tgz
                      8: DISTFILES=     ${DISTNAME}.src${EXTRACT_SUFX}
                      9: 
1.4       wiz        10: MAINTAINER=    [email protected]
1.33      rillig     11: HOMEPAGE=      https://asymptote.sourceforge.io/
1.1       wiz        12: COMMENT=       Powerful descriptive vector graphics language for technical drawings
                     13: LICENSE=       gnu-gpl-v3 AND gnu-lgpl-v3
                     14: 
1.34      riastrad   15: TOOL_DEPENDS+= dvipsk-[0-9]*:../../print/dvipsk
                     16: TOOL_DEPENDS+= makeindexk-[0-9]*:../../textproc/makeindexk
                     17: TOOL_DEPENDS+= tex-latex-bin-[0-9]*:../../print/tex-latex-bin
                     18: TOOL_DEPENDS+= tex-ec-[0-9]*:../../fonts/tex-ec
                     19: TOOL_DEPENDS+= tex-epsf-[0-9]*:../../print/tex-epsf
1.35    ! riastrad   20: TOOL_DEPENDS+= tex-etoolbox-[0-9]*:../../devel/tex-etoolbox
1.34      riastrad   21: TOOL_DEPENDS+= tex-pdftex-[0-9]*:../../print/tex-pdftex
                     22: TOOL_DEPENDS+= tex-parskip-[0-9]*:../../print/tex-parskip
                     23: TOOL_DEPENDS+= tex-texinfo-[0-9]*:../../print/tex-texinfo
                     24: TOOL_DEPENDS+= tex-tools-[0-9]*:../../print/tex-tools
                     25: TOOL_DEPENDS+= ghostscript-agpl>=9.16:../../print/ghostscript-agpl
1.17      markd      26: DEPENDS+=      tex-geometry-[0-9]*:../../print/tex-geometry
1.1       wiz        27: 
1.6       joerg      28: UNLIMIT_RESOURCES=     datasize
1.24      wiz        29: MAKE_JOBS_SAFE=                no # random failure during build as of 2.38
1.6       joerg      30: 
1.1       wiz        31: GNU_CONFIGURE=         yes
                     32: INFO_FILES=            yes
1.31      rillig     33: USE_LANGUAGES=         c c++
1.1       wiz        34: 
                     35: CONFIGURE_ARGS+=       --enable-gc=system
                     36: CONFIGURE_ARGS+=       --infodir=${PREFIX}/info
                     37: USE_TOOLS+=            gmake makeinfo perl
                     38: CFLAGS+=               -DGC_NO_THREAD_REDIRECTS
                     39: 
1.5       jym        40: REPLACE_PYTHON+=       GUI/*.py
                     41: 
                     42: SUBST_CLASSES+=                python
1.26      jperkin    43: SUBST_STAGE.python=    pre-configure
1.5       jym        44: SUBST_FILES.python=    Makefile.in
                     45: SUBST_MESSAGE.python=  Fixing path to python interpreter.
                     46: SUBST_SED.python+=     -e "s|/usr/bin/env python|${PYTHONBIN:Q}|g"
                     47: 
1.21      jperkin    48: # DragonFly has stripped makeinfo in the base - without texi2dvi.
1.34      riastrad   49: OPSYSVARS+=                    TOOL_DEPENDS
                     50: TOOL_DEPENDS.DragonFly+=       gtexinfo-[0-9]*:../../devel/gtexinfo
1.21      jperkin    51: 
1.1       wiz        52: post-install:
                     53:        ${MV} ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xasy.1x \
                     54:                ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xasy.1
                     55: 
                     56: .include "../../devel/boehm-gc/buildlink3.mk"
                     57: .include "../../devel/readline/buildlink3.mk"
1.16      jperkin    58: .include "../../devel/zlib/buildlink3.mk"
1.5       jym        59: .include "../../lang/python/application.mk"
1.1       wiz        60: # next two could be split off into options
                     61: .include "../../math/fftw/buildlink3.mk"
                     62: .include "../../math/gsl/buildlink3.mk"
1.24      wiz        63: # wants library called 'glut', but pkgsrc only provides 'freeglut'
                     64: #BUILDLINK_API_DEPENDS.freeglut+=      freeglut>=3.0
1.1       wiz        65: #.include "../../graphics/freeglut/buildlink3.mk"
                     66: # recognized, but makes asy dump core during creation of documentation
                     67: #.include "../../graphics/glut/buildlink3.mk"
                     68: 
                     69: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>