Annotation of pkgsrc/graphics/asymptote/Makefile, revision 1.14

1.14    ! wiz         1: # $NetBSD: Makefile,v 1.13 2014/04/30 14:19:41 wiz Exp $
1.1       wiz         2: #
                      3: 
1.7       markd       4: DISTNAME=      asymptote-2.15
1.14    ! wiz         5: PKGREVISION=   6
1.1       wiz         6: CATEGORIES=    graphics
                      7: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=asymptote/}
                      8: EXTRACT_SUFX=  .tgz
                      9: DISTFILES=     ${DISTNAME}.src${EXTRACT_SUFX}
                     10: 
1.4       wiz        11: MAINTAINER=    [email protected]
1.1       wiz        12: HOMEPAGE=      http://asymptote.sourceforge.net/
                     13: COMMENT=       Powerful descriptive vector graphics language for technical drawings
                     14: LICENSE=       gnu-gpl-v3 AND gnu-lgpl-v3
                     15: 
                     16: BUILD_DEPENDS+=        dvipsk-[0-9]*:../../print/dvipsk
                     17: BUILD_DEPENDS+=        tex-pdftex-[0-9]*:../../print/tex-pdftex
1.7       markd      18: BUILD_DEPENDS+=        tex-parskip-[0-9]*:../../print/tex-parskip
1.10      dholland   19: #BUILD_DEPENDS+=ghostscript-[0-9]*:../../print/ghostscript
                     20: USE_TOOLS+=    gs
1.1       wiz        21: 
1.6       joerg      22: UNLIMIT_RESOURCES=     datasize
                     23: 
1.1       wiz        24: GNU_CONFIGURE=         yes
                     25: INFO_FILES=            yes
                     26: USE_LANGUAGES=          c c++
                     27: 
                     28: CONFIGURE_ARGS+=       --enable-gc=system
                     29: CONFIGURE_ARGS+=       --infodir=${PREFIX}/info
                     30: USE_TOOLS+=            gmake makeinfo perl
                     31: CFLAGS+=               -DGC_NO_THREAD_REDIRECTS
                     32: 
1.5       jym        33: REPLACE_PYTHON+=       GUI/*.py
                     34: 
                     35: SUBST_CLASSES+=                python
                     36: SUBST_STAGE.python=    post-patch
                     37: SUBST_FILES.python=    Makefile.in
                     38: SUBST_MESSAGE.python=  Fixing path to python interpreter.
                     39: SUBST_SED.python+=     -e "s|/usr/bin/env python|${PYTHONBIN:Q}|g"
                     40: 
1.1       wiz        41: post-install:
                     42:        ${MV} ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xasy.1x \
                     43:                ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xasy.1
                     44: 
1.2       hasso      45: .include "../../mk/bsd.prefs.mk"
                     46: 
                     47: # DragonFly has stripped makeinfo in the base - without texi2dvi.
                     48: .if ${OPSYS} == "DragonFly"
                     49: BUILD_DEPENDS+=         gtexinfo-[0-9]*:../../devel/gtexinfo
                     50: .endif
                     51: 
1.1       wiz        52: .include "../../devel/boehm-gc/buildlink3.mk"
                     53: .include "../../devel/readline/buildlink3.mk"
1.5       jym        54: .include "../../lang/python/application.mk"
1.1       wiz        55: # next two could be split off into options
                     56: .include "../../math/fftw/buildlink3.mk"
                     57: .include "../../math/gsl/buildlink3.mk"
                     58: # freeglut too old, not recognized
                     59: #.include "../../graphics/freeglut/buildlink3.mk"
                     60: # recognized, but makes asy dump core during creation of documentation
                     61: #.include "../../graphics/glut/buildlink3.mk"
                     62: 
                     63: .include "../../mk/tex.buildlink3.mk"
                     64: .include "../../mk/bsd.pkg.mk"

CVSweb <[email protected]>