Annotation of pkgsrc/editors/vile/Makefile, revision 1.22
1.22 ! wiz 1: # $NetBSD: Makefile,v 1.21 2001/01/07 01:48:19 wiz Exp $
1.1 agc 2: # FreeBSD Id: Makefile,v 1.13 1997/09/06 19:55:09 gj Exp
3:
1.20 jlam 4: DISTNAME= vile-9.0
5: CATEGORIES= editors
6: MASTER_SITES= ftp://ftp.clark.net/pub/dickey/vile/ \
7: ftp://ftp.uni-trier.de/pub/unix/editor/vile/ \
8: ftp://ftp.phred.org/pub/vile/
9: EXTRACT_SUFX= .tgz
10:
11: MAINTAINER= [email protected]
1.22 ! wiz 12: COMMENT= VI Like Emacs. a vi "workalike", with many additional features
1.20 jlam 13:
14: USE_PERL5= # defined
1.21 wiz 15: USE_CURSES= # defined
1.20 jlam 16:
17: GNU_CONFIGURE= # defined
18: CONFIGURE_ARGS+= --with-perl
19: CONFIGURE_ARGS+= --datadir=${DATADIR}
20: CONFIGURE_ARGS+= --with-libdir-path=${FILTERDIR}
21:
22: # Until the source catches up to the current Perl API, we need PERL_POLLUTE
23: # to look like an older perl.
24: CPPFLAGS+= -DPERL_POLLUTE=1
25: CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
1.1 agc 26:
1.16 tron 27: MAKEFILE= makefile
1.20 jlam 28: INSTALL_TARGET= install install-perl
1.16 tron 29:
1.20 jlam 30: DATADIR= ${PREFIX}/share/vile
31: FILTERDIR= ${PREFIX}/libexec/vile
32: EGDIR= ${PREFIX}/share/examples/vile
1.17 agc 33:
1.1 agc 34: post-install:
1.20 jlam 35: @${INSTALL_SCRIPT} ${WRKSRC}/perl/vileget ${PREFIX}/bin/vileget
36: @${INSTALL_DATA_DIR} ${EGDIR}
1.15 agc 37: @for f in filters/spell.rc filters/filters.rc \
38: macros/digraphs.rc macros/pictmode.rc \
39: macros/manpage.rc visvile/visvile.rc; do \
1.20 jlam 40: ${INSTALL_DATA} ${WRKSRC}/$$f ${EGDIR}; \
1.15 agc 41: done
1.21 wiz 42:
43: .include "../../mk/bsd.prefs.mk"
44:
45: .if ${NEED_NCURSES} == "YES"
46: CPPFLAGS+= -DHAVE_NCURSES_H
47: CONFIGURE_ARGS+= --with-screen=ncurses
48: .endif
1.1 agc 49:
1.5 agc 50: .include "../../mk/bsd.pkg.mk"
CVSweb <[email protected]>